v0.39 lots of issues

*** Please report new bugs here! ***

Moderator: Dreamer

Post Reply
soulky
Posts: 133
Joined: Tue Dec 06, 2011 9:20 am

v0.39 lots of issues

Post by soulky » Thu Dec 22, 2011 10:28 pm

There are lots of issues emerging with that new unstable version. I will try to explain them:

1. Responsiveness
Responsiveness is very very bad. Selecting a file, scrolling down, deleting, often takes a couple of seconds before the action starts. This gets really annoying. Often the sandclock shows up and I have to wait until something has been completed inthe background before it starst the requested action.
2. Thumbnailing
It feels like it never ends. Although all thumbnails are completed. It keeps redoing them. Even when files have been completed it starts redoing thumbnails, slowing everything down dramatically.
3. Keyboard shortcut "M" does not work.
For any other letter using the keyboard let me jump to the first file with that letter. Only "M" is not working.
4. Deleting does not work at all times. Sometimes there is that popup telling me that the file is in use (while it is not). After pressing "OK" Xnview removes the thumbnails from the view, but when restarting XNview the files are there again.
5. Filenames are not completely visible. The left side gets cut off.
6. Thumbnail layout
I could not find a way for a more compact view. There gets lots of space wasted as there is so much space between the filenames and the thumbnails.
7. Selected does not selected
Often although a file has been selected it cannot get opened using the keyboard shortcut. Using the shortcut simply does nothing. Only using the shortcut again the file gets opened.
8. Context menu
Right click opens the context menu. Opening the submenu rating and colour marking is difficult as it closes too easily if you don´t move the mouse 100% accurate. This can lead to accidentally hit delete marks on the menu above which is not very useful.
I hope this helps to improve the application.

thibaud
Posts: 269
Joined: Sat Dec 02, 2006 12:41 am
Contact:

Re: v0.39 lots of issues

Post by thibaud » Fri Dec 23, 2011 3:28 pm

At the very least, You need to provide:
  • installed XnViewMP version ! (win?, linux?, OSX?, 32 or 64bit?)
  • your Operating system (windows 7 ultimate x64?, OSX 10.7.3? , Ubuntu 11.10 32bit?, ... )
Additionally you may also want to provide and check some specific installation details that may influence xnviewMP behaviour :
  • installed plugins
  • xnViewMP settings that where changed (including xnview.ini changes)
  • ...

soulky
Posts: 133
Joined: Tue Dec 06, 2011 9:20 am

Re: v0.39 lots of issues

Post by soulky » Sat Dec 24, 2011 12:35 pm

It is running on winxp sp3. Of course windows verision then.
Xnviewmp version is 0.39

mpeg plugin installed. No other. And no particular changes in the ini.

User avatar
xnview
Author of XnView
Posts: 31738
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: v0.39 lots of issues

Post by xnview » Fri Feb 03, 2012 1:59 pm

soulky wrote:1. Responsiveness
Responsiveness is very very bad. Selecting a file, scrolling down, deleting, often takes a couple of seconds before the action starts. This gets really annoying. Often the sandclock shows up and I have to wait until something has been completed inthe background before it starst the requested action.
Do you have a lot of files in this folder?
2. Thumbnailing
It feels like it never ends. Although all thumbnails are completed. It keeps redoing them. Even when files have been completed it starts redoing thumbnails, slowing everything down dramatically.
The progress bar that show thumbnail progress always works??
3. Keyboard shortcut "M" does not work.
For any other letter using the keyboard let me jump to the first file with that letter. Only "M" is not working.
4. Deleting does not work at all times. Sometimes there is that popup telling me that the file is in use (while it is not). After pressing "OK" Xnview removes the thumbnails from the view, but when restarting XNview the files are there again.
I can't reproduce...
5. Filenames are not completely visible. The left side gets cut off.
6. Thumbnail layout
I could not find a way for a more compact view. There gets lots of space wasted as there is so much space between the filenames and the thumbnails.
Could you post a screenshot?
7. Selected does not selected
Often although a file has been selected it cannot get opened using the keyboard shortcut. Using the shortcut simply does nothing. Only using the shortcut again the file gets opened.
You means Ctrl+O??
Pierre.

soulky
Posts: 133
Joined: Tue Dec 06, 2011 9:20 am

Re: v0.39 lots of issues

Post by soulky » Sun Feb 05, 2012 8:42 am

xnview wrote:
soulky wrote:1. Responsiveness
Responsiveness is very very bad. Selecting a file, scrolling down, deleting, often takes a couple of seconds before the action starts. This gets really annoying. Often the sandclock shows up and I have to wait until something has been completed inthe background before it starst the requested action.
Do you have a lot of files in this folder?
Yes. 20k - 50k+.
MP is really great. But I think it has issues when there are a lot of files to handle.
xnview wrote:
soulky wrote:2. Thumbnailing
It feels like it never ends. Although all thumbnails are completed. It keeps redoing them. Even when files have been completed it starts redoing thumbnails, slowing everything down dramatically.
The progress bar that show thumbnail progress always works??
It does not work accurately. After a long time of thumbnailing files, the progress bar goes away and the harddisk stops. So this would mean that thumbnailing has been completed. When I look into cache settings, there is the number of thumbnailed files which is only 15% of the files in the folder. When I restart MP it starts thumbnailing again and when I look into cache settings again I can see the number of thumbnailed files go up again.

So maybe there are two issues:

1. Thumbnailing or rebuilding the view restarts quite often (like after deleting on file)
2. Thumbnailing does not complete correctly. It simply halts at some point pretending is has been finished but resumes after restart of MP.
xnview wrote:
soulky wrote: 3. Keyboard shortcut "M" does not work.
For any other letter using the keyboard let me jump to the first file with that letter. Only "M" is not working.
4. Deleting does not work at all times. Sometimes there is that popup telling me that the file is in use (while it is not). After pressing "OK" Xnview removes the thumbnails from the view, but when restarting XNview the files are there again.
I can't reproduce...
I have figures out the following:
When the files are on root level and you want to access them by keyboard, it does not work for the files starting with the same letter like the drive letter.
In subfolders it works. So if you put files on drive named D on root level and try to acces the files "Delila" by pressing D, it does not work.

It seems that as long as thumbnailing is in progress it is impossible to delete files. When thumbnailing has been completed then I have not received that error.
xnview wrote:
soulky wrote:5. Filenames are not completely visible. The left side gets cut off.
6. Thumbnail layout
I could not find a way for a more compact view. There gets lots of space wasted as there is so much space between the filenames and the thumbnails.
Could you post a screenshot?
7. Selected does not selected
Often although a file has been selected it cannot get opened using the keyboard shortcut. Using the shortcut simply does nothing. Only using the shortcut again the file gets opened.
You means Ctrl+O??
I mean ALT+1 or ALT+2. It often requires 1 or 2 attempts until the file opens with the designated application. It is always like MP is doing something in the background and does not listen to the users input.

Post Reply