OpenEXR incorrect gamma and missing alpha

*** Please report new bugs here! ***

Moderators: XnTriq, helmut, xnview, Dreamer

harumscarum
Posts: 65
Joined: Tue Nov 30, 2010 6:04 pm

OpenEXR incorrect gamma and missing alpha

Post by harumscarum »

here is problem with 32bits OpenEXR image - missing alpha and incorrect gamma on thumbnails and in the viewer
both same files are opened in MP and Bridge

http://dl.dropbox.com/u/2069868/web/night_0001.exr

Image
Last edited by harumscarum on Tue Apr 24, 2012 6:34 am, edited 1 time in total.
thibaud
Posts: 274
Joined: Sat Dec 02, 2006 12:41 am

Re: OpenEXR incorrect gamma and missing alpha

Post by thibaud »

for previews/view mode
just hit ctrl+h (or "view" > "use alpha channel")
ctrl+M (or "view" > "show alpha") is quite handy too...
now that's actually feature richer than Bridge isn't it ?

As for the gamma issue, maybe it has to do with the color profile used here "sRGB IEC61966-2.1 (linear)" ?
for what it's worth Photoshop and Fusion don't seem to interpret the color space and gamma automatically for this file either. (ae and Nuke do though).
harumscarum
Posts: 65
Joined: Tue Nov 30, 2010 6:04 pm

Re: OpenEXR incorrect gamma and missing alpha

Post by harumscarum »

"use alpha channel" affects only Viewer, but not Thumbnails (rebuild it didnt help)

Photoshop and Bridge view and open this EXR with correct colorspace (maybe because of OpenEXR plugin installed)
thibaud
Posts: 274
Joined: Sat Dec 02, 2006 12:41 am

Re: OpenEXR incorrect gamma and missing alpha

Post by thibaud »

I suppose the use alpha for thumbnail is something I can live with... as the viewer gives more control.
in any case, if additional functionality for how thumbnail uses the alpha was to be implemented IMO this is not something that should be generic or even file format base but rather thumbnail based.
for reference this is how some other app handle that: (format specific context menu on the thumbnail)

.psd thumbnail context menu:
Image

.exr thumbnail context menu (note the "Default transparency" to revert to format specific default because Opaque was choosen):
Image
Photoshop and Bridge view and open this EXR with correct colorspace (maybe because of OpenEXR plugin installed)
you're right Photoshop does display it correctly (I had "proof color" turned on my first test which disabled the gamma correction)
harumscarum
Posts: 65
Joined: Tue Nov 30, 2010 6:04 pm

Re: OpenEXR incorrect gamma and missing alpha

Post by harumscarum »

there is correct gamma in Bridge from CS6 version
thibaud
Posts: 274
Joined: Sat Dec 02, 2006 12:41 am

Re: OpenEXR incorrect gamma and missing alpha

Post by thibaud »

Yes, it would be great if this gamma issue could be fixed.
User avatar
xnview
Author of XnView
Posts: 38817
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: OpenEXR incorrect gamma and missing alpha

Post by xnview »

You would like to view alpha in thumbnail?
Currently i don't know how to get gamma for OpenEXR :(

You can change default gamma for openEXR (Load settings>OpenExr>Gamma), 2.2 is better
Pierre.
jho
Posts: 11
Joined: Fri May 17, 2013 2:32 pm

Re: OpenEXR incorrect gamma and missing alpha

Post by jho »

Hi xnview,
first of all I would appreciate your great work.

I have the same exact problem with the alpha in the thumbnails. My picture has a black alpha channel. Now in the viewer the picture is shown correct but in the thumbnail view I see nothing because the alpha is black. ;)
jho
Posts: 11
Joined: Fri May 17, 2013 2:32 pm

Re: OpenEXR incorrect gamma and missing alpha

Post by jho »

Can you say if it is being fixed in the upcoming 0.54?
jho
Posts: 11
Joined: Fri May 17, 2013 2:32 pm

Re: OpenEXR incorrect gamma and missing alpha

Post by jho »

I attached a screenshot where you can see that the thumbnail is not showing the red ball because in the alpha it is black.
You do not have the required permissions to view the files attached to this post.
User avatar
xnview
Author of XnView
Posts: 38817
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: OpenEXR incorrect gamma and missing alpha

Post by xnview »

jho wrote:I attached a screenshot where you can see that the thumbnail is not showing the red ball because in the alpha it is black.
could you send me the file?
Pierre.
jho
Posts: 11
Joined: Fri May 17, 2013 2:32 pm

Re: OpenEXR incorrect gamma and missing alpha

Post by jho »

Hi,
thanks for the fast reply. When I am at home I can sent you the exr file.
jho
Posts: 11
Joined: Fri May 17, 2013 2:32 pm

Re: OpenEXR incorrect gamma and missing alpha

Post by jho »

I have sent you the image to contact@<-- removed* --> : Subject is OpenEXR alpha
User avatar
xnview
Author of XnView
Posts: 38817
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: OpenEXR incorrect gamma and missing alpha

Post by xnview »

Pierre.