0.51: Scroll doesn't work

*** Please report new bugs here! ***

Moderator: Dreamer

Post Reply
User avatar
Zheitk
Posts: 64
Joined: Sun May 01, 2011 3:44 am

0.51: Scroll doesn't work

Post by Zheitk »

I have attached my conf for you to test
XnViewMP.zip
(7.52 KiB) Downloaded 128 times
[/size]
It just sometimes doesn't work after leaving fullscreen, but you can reproduce it like this: just scroll till the bottom of the thumbnails :bug:
XnViewMP v0.64 / Win32 XP:SP3. [last update: apr9, 2014]
User avatar
Zheitk
Posts: 64
Joined: Sun May 01, 2011 3:44 am

Re: Scroll doesn't work

Post by Zheitk »

If you test with my configuration (I don't know if it happens with the defaults), just enter fullscreen, navigate through some pics (via the little bar at the bottom or the arrow keys) until the screen gets self-scrolled downwards, then exit fullscreen and try to scroll up. You need to scroll down before you can scroll upwards again...
XnViewMP v0.64 / Win32 XP:SP3. [last update: apr9, 2014]
User avatar
xnview
Author of XnView
Posts: 34672
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Scroll doesn't work

Post by xnview »

could you make a screen movie?
Pierre.
User avatar
Zheitk
Posts: 64
Joined: Sun May 01, 2011 3:44 am

Re: Scroll doesn't work

Post by Zheitk »

Like this?: http://www.mediafire.com/?69o7picd9s4rm47

First I am using the arrow keys in fullscreen to navigate through some pics and force the thumbnails view to "self-scroll" to the next row. Now it's impossible to scroll upwards with the mouse wheel, it's needed to first scroll down or use the scroll bar at the right (sorry, my screencast software can only highlight mouse clicks)

Después, after scrolling till the bottom, it's impossible to scroll downwards so I need to use the scroll bar to go up again.

Hope it's clear now :P
XnViewMP v0.64 / Win32 XP:SP3. [last update: apr9, 2014]
User avatar
xnview
Author of XnView
Posts: 34672
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Scroll doesn't work

Post by xnview »

So :)
On a file, you press F11 (for example), use wheel mouse to navigate through some pics, press ESC to return on the browser, and here mouse wheel doesn't work anymore?
Pierre.
User avatar
Zheitk
Posts: 64
Joined: Sun May 01, 2011 3:44 am

Re: Scroll doesn't work

Post by Zheitk »

Sorry, this seem to be another strange "corrupt configuration case" :(:

a.- I use f11 or Enter (I have ENTER key set to browse<>fullscreen)
b.- arrow keys to move to previous next file
c.- mouse wheel (in fullscreen) to zoom in-out, and to scroll in browser mode (the one that doesn't work)

To reproduce (as say, it seem to just work with the configuration attached):
On a file, press F11 (or Enter to go fullscreen), use arrow keys to navigate through some pics ('till the browser self scroll at leat one row), press ESC to return on the browser, and here mouse wheel doesn't work anymore...

Right now I tried to change the mouse wheel to "previous/next file" and then again to "zoom in-out", now it works well with my new conf ¬_¬...
...but strangely, I tested with the configuration I have attached in this post and the problems returns, so it's rare indeed O_o
XnViewMP v0.64 / Win32 XP:SP3. [last update: apr9, 2014]
User avatar
Zheitk
Posts: 64
Joined: Sun May 01, 2011 3:44 am

Re: Scroll doesn't work

Post by Zheitk »

Not, I found the problem:
2012-09-27 [18_25_02].png
2012-09-27 [18_25_02].png (201.36 KiB) Viewed 1848 times
That toolbar at the bottom is causing the problem (use "Restore layout A" to show it, it disappears after any configuration change). Deleting that toolbar or making it "float" solves the problem U_U
XnViewMP v0.64 / Win32 XP:SP3. [last update: apr9, 2014]
User avatar
xnview
Author of XnView
Posts: 34672
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Scroll doesn't work

Post by xnview »

If you have the toolbar at the bottom, you have the problem??
Pierre.
User avatar
Zheitk
Posts: 64
Joined: Sun May 01, 2011 3:44 am

Re: Scroll doesn't work

Post by Zheitk »

xnview wrote:If you have the toolbar at the bottom, you have the problem??
Yes, it's another toolbar... use this:
XnViewMP.rar
(7.39 KiB) Downloaded 97 times
and "restore layout A" to send that toolbar to the bottom (otherwise the bug won't show), then in viewer mode scroll downwards 'till the bottom... now the scroll doesn't work anymore.
BTW, I'm using windows xp sp3, xnviewmp 0.51b and my screen resolution is 1280x800
XnViewMP v0.64 / Win32 XP:SP3. [last update: apr9, 2014]
User avatar
xnview
Author of XnView
Posts: 34672
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Scroll doesn't work

Post by xnview »

I've tried and no problem :((
Pierre.
User avatar
Zheitk
Posts: 64
Joined: Sun May 01, 2011 3:44 am

Re: 0.51: Scroll doesn't work

Post by Zheitk »

xnview wrote:I've tried and no problem :((
So I just find the problem here (this time for sure, I swear :D), look here:
Nice screen-shoot ñ_ñ
Nice screen-shoot ñ_ñ
2012-12-29 [12_02_21].png (191.51 KiB) Viewed 1509 times
It's a clean install of xnview-mp v0.53, the only thing I made was configure the thumbnails (margin, border, padding/spacing) to exactly fit the visible portion of the browser (there's no others partially-seen thumbnails). Thats all, go to the bottom of the screen and then you can't scroll upwards (or in fullscreen, using the floating "playbar" at the bottom and exiting with Esc)...

Also, this behavior cause some problem with this bugfix: Thumbnails refresh & 'create whole folder' not checked (http://newsgroup.xnview.com/viewtopic.php?f=62&t=26330, http://newsgroup.xnview.com/viewtopic.php?f=62&t=26209). The fix works, but not if thumbnails are configured like this... they refresh after any slight scroll (via mouse or the scrollbar)
XnViewMP v0.64 / Win32 XP:SP3. [last update: apr9, 2014]
baklazanek
Posts: 1
Joined: Wed Jun 19, 2013 3:48 pm

Re: 0.51: Scroll doesn't work

Post by baklazanek »

Zheitk wrote:
xnview wrote:I've tried and no problem :((
So I just find the problem here (this time for sure, I swear :D), look here:
2012-12-29 [12_02_21].png
It's a clean install of xnview-mp v0.53, the only thing I made was configure the thumbnails (margin, border, padding/spacing) to exactly fit the visible portion of the browser (there's no others partially-seen thumbnails). Thats all, go to the bottom of the screen and then you can't scroll upwards (or in fullscreen, using the floating "playbar" at the bottom and exiting with Esc)...

Also, this behavior cause some problem with this bugfix: Thumbnails refresh & 'create whole folder' not checked (http://newsgroup.xnview.com/viewtopic.php?f=62&t=26330, http://newsgroup.xnview.com/viewtopic.php?f=62&t=26209). The fix works, but not if thumbnails are configured like this... they refresh after any slight scroll (via mouse or the scrollbar)
Doesnt work for me :bug:
Image
User avatar
Zheitk
Posts: 64
Joined: Sun May 01, 2011 3:44 am

Re: 0.51: Scroll doesn't work

Post by Zheitk »

baklazanek wrote:Doesnt work for me
Are you confirming the bug?

Still present in win 0.56: Options»Thumbnails»Appearance»Padding=10 | Increase browser view-port to show complete thumbnails only | tada!
XnViewMP v0.64 / Win32 XP:SP3. [last update: apr9, 2014]
Post Reply