0.64 create and delete folder bug

*** Please report new bugs here! ***

Moderators: XnTriq, helmut, xnview, Dreamer

aa123ntcn
Posts: 5
Joined: Tue Jul 03, 2012 11:11 am

0.64 create and delete folder bug

Post by aa123ntcn »

Version: XnViewMP 0.64 x64
Windows 7 x64

Step to reproduce:

1. Start XnView MP
2. Press F7 to create a folder and input a name "test", then press "Enter"
Expect: create a new folder named "test"
Actual: the folder still named "New Folder 1" and XnView enter the folder directly.

3. go back to the original folder
4. delete "New Folder 1"
5. goto some other folder
6. go back to thr original folder
Exect: "New Folder 1" should not exist
Actual: "New Folder 1" still there
User avatar
m.Th.
XnThusiast
Posts: 1610
Joined: Wed Aug 16, 2006 6:31 am

Re: 0.64 create and delete folder bug

Post by m.Th. »

aa123ntcn wrote:Version: XnViewMP 0.64 x64
Windows 7 x64

Step to reproduce:

1. Start XnView MP
2. Press F7 to create a folder and input a name "test", then press "Enter"
Expect: create a new folder named "test"
Actual: the folder still named "New Folder 1" and XnView enter the folder directly.

3. go back to the original folder
4. delete "New Folder 1"
5. goto some other folder
6. go back to thr original folder
Exect: "New Folder 1" should not exist
Actual: "New Folder 1" still there
Cannot reproduce - neither the 1st, neither the 2nd. Perhaps others can...

See my specs in sig. Btw what are your specs?
m. Th.

- Dark Themed XnViewMP 1.0 64bit on Win10 x64 -
aa123ntcn
Posts: 5
Joined: Tue Jul 03, 2012 11:11 am

Re: 0.64 create and delete folder bug

Post by aa123ntcn »

I can reproduce in both my pc and vmware.

Both of them are Windows 7 x64 sp1
XnView MP 0.64

This is how I reproduce the issue:
https://www.youtube.com/watch?v=TZQfqmW ... e=youtu.be
User avatar
xnview
Author of XnView
Posts: 39325
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: 0.64 create and delete folder bug

Post by xnview »

See Issue 300 for current status and details.
Pierre.
User avatar
Akovia
Posts: 124
Joined: Sat Apr 02, 2011 2:10 am

Re: 0.64 create and delete folder bug

Post by Akovia »

Happens to me as well. Look forward to 0.65.
Arch Linux
XnView MP