Fails to start XnView MP 0.64

*** Please report new bugs here! ***

Moderator: Dreamer

jeb5000
Posts: 5
Joined: Wed Apr 09, 2014 2:32 am

Fails to start XnView MP 0.64

Post by jeb5000 » Wed Apr 09, 2014 2:57 am

lenovo ThinkPad Yoga S1 Display resolution is 1920x1080
Windows 8.1 PRO
XnView MP 0.64

Program installs with no problem and starts. I can maximize to full screen, navigate to different folders, etc.
If I quit while XnViewMP is maximized I get an error the next time I try to start. If I remember to shrink the window first it will start with no problem.
If I get the error I can delete the XnView.ini file and it will start with no problem.

Is there a way around this?

User avatar
xnview
Author of XnView
Posts: 32081
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Fails to start XnView MP 0.64

Post by xnview » Thu Apr 10, 2014 9:12 am

What do yu means by error, crash?
Pierre.

jeb5000
Posts: 5
Joined: Wed Apr 09, 2014 2:32 am

Re: Fails to start XnView MP 0.64

Post by jeb5000 » Thu Apr 10, 2014 5:19 pm

Appears to be a windows dialog box,
"XnViewMP has stopped working
A problem caused the program to stop working correctly. Windows will close the program and notify you if a solution is available."

Have to delete or edit the XnView.ini file to get it to run again.

Kept a copy of each XnView.ini file and compared them in Notepad++. Tried several variations of window size and found one line in the XnView.ini caused the problem.

WORKS = XnViewMP opens and runs. FAILS = The above message pops up and XnViewMP is closed.

WORKS geom=@ByteArray(\x1\xd9\xd0\xcb\0\x1\0\0\0\0\x1\xc2\0\0\0\x9b\0\0\x5)\0\0\x3>\0\0\x1\xcd\0\0\0\xc8\0\0\x5\x1e\0\0\x3\x33\0\0\0\0\0\0)
WORKS geom=@ByteArray(\x1\xd9\xd0\xcb\0\x1\0\0\0\0\0\x7f\0\0\0\0\0\0\x5)\0\0\x3\xff\0\0\0\x8a\0\0\0-\0\0\x5\x1e\0\0\x3\xf4\0\0\0\0\0\0)
WORKS geom=@ByteArray(\x1\xd9\xd0\xcb\0\x1\0\0\0\0\0\x7f\0\0\0\x9b\0\0\x5)\0\0\x3>\0\0\0\x8a\0\0\0\xc8\0\0\x5\x1e\0\0\x3\x33\0\0\0\0\0\0)
FAILS geom=@ByteArray(\x1\xd9\xd0\xcb\0\x1\0\0\xff\xff\xff\xf5\xff\xff\xff\xf5\0\0\a\x8a\0\0\x4\n\0\0\x1\xcd\0\0\0\xc8\0\0\x5\x1e\0\0\x3\x33\0\0\0\0\x2\0)
FAILS geom=@ByteArray(\x1\xd9\xd0\xcb\0\x1\0\0\0\0\0\x7f\0\0\0\x9b\0\0\x6\x9d\0\0\x3>\0\0\0\x8a\0\0\0\xc8\0\0\x6\x92\0\0\x3\x33\0\0\0\0\0\0)
FAILS geom=@ByteArray(\x1\xd9\xd0\xcb\0\x1\0\0\0\0\0\x7f\0\0\0\x9b\0\0\a\x4\0\0\x3>\0\0\0\x8a\0\0\0\xc8\0\0\x6\xf9\0\0\x3\x33\0\0\0\0\0\0)
FAILS geom=@ByteArray(\x1\xd9\xd0\xcb\0\x1\0\0\xff\xff\xff\xf5\xff\xff\xff\xf5\0\0\a\x8a\0\0\x4\n\0\0\0\x8a\0\0\0\xc8\0\0\x5\x1e\0\0\x3\x33\0\0\0\0\x2\0)
FAILS geom=@ByteArray(\x1\xd9\xd0\xcb\0\x1\0\0\0\0\0\x7f\0\0\0\0\0\0\x6\x80\0\0\x3\xff\0\0\0\x8a\0\0\0-\0\0\x6u\0\0\x3\xf4\0\0\0\0\0\0)

After it fails to run I can edit XnView.ini and paste in one of the WORKS geom= lines above and the program starts with no problem.

I have the PortableApps.com version of XnView on a thumb drive that runs with no problem.

Would like to use XnViewMP because it appears to be faster, especially on larger folders. It works with no problem as long as it is not Maximized when I quit.

Thank you for your time.

User avatar
xnview
Author of XnView
Posts: 32081
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Fails to start XnView MP 0.64

Post by xnview » Mon Apr 14, 2014 12:41 pm

when you have the crash, could you send the crash report?
Pierre.

jeb5000
Posts: 5
Joined: Wed Apr 09, 2014 2:32 am

Re: Fails to start XnView MP 0.64

Post by jeb5000 » Mon Apr 14, 2014 1:02 pm

Crash Report

One of many over the last week. Have uninstalled XnViewMP and gone back to old version.

Code: Select all

Version=1
EventType=APPCRASH
EventTime=130415129509438373
ReportType=2
Consent=1
UploadTime=130415129510735290
ReportIdentifier=c950bd7e-bfd1-11e3-82af-ac7ba14c873a
IntegratorReportIdentifier=c950bd7d-bfd1-11e3-82af-ac7ba14c873a
NsAppName=xnview.exe
Response.BucketId=14170c76868d430a87da9136a6c9a4b0
Response.BucketTable=4
Response.LegacyBucketId=153333479
Response.type=4
Sig[0].Name=Application Name
Sig[0].Value=xnview.exe
Sig[1].Name=Application Version
Sig[1].Value=0.52.0.0
Sig[2].Name=Application Timestamp
Sig[2].Value=52c817f0
Sig[3].Name=Fault Module Name
Sig[3].Value=QtGui4.dll
Sig[4].Name=Fault Module Version
Sig[4].Value=4.8.5.0
Sig[5].Name=Fault Module Timestamp
Sig[5].Value=528a69e6
Sig[6].Name=Exception Code
Sig[6].Value=c000041d
Sig[7].Name=Exception Offset
Sig[7].Value=00000000001922b4
DynamicSig[1].Name=OS Version
DynamicSig[1].Value=6.3.9600.2.0.0.256.48
DynamicSig[2].Name=Locale ID
DynamicSig[2].Value=1033
DynamicSig[22].Name=Additional Information 1
DynamicSig[22].Value=353c
DynamicSig[23].Name=Additional Information 2
DynamicSig[23].Value=353c50ff37976df155015f6d05f240cd
DynamicSig[24].Name=Additional Information 3
DynamicSig[24].Value=f036
DynamicSig[25].Name=Additional Information 4
DynamicSig[25].Value=f03670ae5d0e580d4d4a61eb0b71a4ef
UI[2]=C:\Program Files\XnViewMP\xnview.exe
UI[3]=XnViewMP has stopped working
UI[4]=Windows can check online for a solution to the problem.
UI[5]=Check online for a solution and close the program
UI[6]=Check online for a solution later and close the program
UI[7]=Close the program
LoadedModule[0]=C:\Program Files\XnViewMP\xnview.exe
LoadedModule[1]=C:\windows\SYSTEM32\ntdll.dll
LoadedModule[2]=C:\windows\system32\KERNEL32.DLL
LoadedModule[3]=C:\windows\system32\KERNELBASE.dll
LoadedModule[4]=C:\windows\SYSTEM32\VERSION.dll
LoadedModule[5]=C:\Program Files\XnViewMP\QtXml4.dll
LoadedModule[6]=C:\Program Files\XnViewMP\QtCore4.dll
LoadedModule[7]=C:\Program Files\XnViewMP\QtGui4.dll
LoadedModule[8]=C:\Program Files\XnViewMP\QtWebKit4.dll
LoadedModule[9]=C:\Program Files\XnViewMP\QtNetwork4.dll
LoadedModule[10]=C:\Program Files\XnViewMP\QtSvg4.dll
LoadedModule[11]=C:\Program Files\XnViewMP\phonon4.dll
LoadedModule[12]=C:\windows\system32\USER32.dll
LoadedModule[13]=C:\windows\system32\GDI32.dll
LoadedModule[14]=C:\windows\system32\COMDLG32.dll
LoadedModule[15]=C:\windows\system32\ADVAPI32.dll
LoadedModule[16]=C:\windows\system32\SHELL32.dll
LoadedModule[17]=C:\windows\system32\ole32.dll
LoadedModule[18]=C:\windows\system32\OLEAUT32.dll
LoadedModule[19]=C:\windows\WinSxS\amd64_microsoft.vc90.crt_1fc8b3b9a1e18e3b_9.0.30729.8387_none_08e793bfa83a89b5\MSVCP90.dll
LoadedModule[20]=C:\windows\WinSxS\amd64_microsoft.vc90.crt_1fc8b3b9a1e18e3b_9.0.30729.8387_none_08e793bfa83a89b5\MSVCR90.dll
LoadedModule[21]=C:\windows\WinSxS\amd64_microsoft.vc90.openmp_1fc8b3b9a1e18e3b_9.0.30729.6161_none_390d35aa0a1f21f9\VCOMP90.DLL
LoadedModule[22]=C:\windows\system32\msvcrt.dll
LoadedModule[23]=C:\windows\system32\WS2_32.dll
LoadedModule[24]=C:\windows\system32\IMM32.dll
LoadedModule[25]=C:\windows\SYSTEM32\WINMM.dll
LoadedModule[26]=C:\windows\SYSTEM32\WINSPOOL.DRV
LoadedModule[27]=C:\windows\system32\SHLWAPI.dll
LoadedModule[28]=C:\windows\WinSxS\amd64_microsoft.windows.common-controls_6595b64144ccf1df_5.82.9600.16384_none_34a8918f959016ea\COMCTL32.dll
LoadedModule[29]=C:\windows\SYSTEM32\sechost.dll
LoadedModule[30]=C:\windows\system32\RPCRT4.dll
LoadedModule[31]=C:\windows\SYSTEM32\combase.dll
LoadedModule[32]=C:\windows\system32\NSI.dll
LoadedModule[33]=C:\windows\system32\MSCTF.dll
LoadedModule[34]=C:\windows\SYSTEM32\WINMMBASE.dll
LoadedModule[35]=C:\windows\SYSTEM32\cfgmgr32.dll
LoadedModule[36]=C:\windows\SYSTEM32\DEVOBJ.dll
LoadedModule[37]=C:\windows\SYSTEM32\SHCORE.DLL
LoadedModule[38]=C:\windows\system32\uxtheme.dll
LoadedModule[39]=C:\Program Files\Common Files\microsoft shared\ink\tiptsf.dll
LoadedModule[40]=C:\windows\system32\dwmapi.dll
LoadedModule[41]=C:\windows\SYSTEM32\kernel.appcore.dll
LoadedModule[42]=C:\windows\SYSTEM32\CRYPTBASE.dll
LoadedModule[43]=C:\windows\SYSTEM32\bcryptPrimitives.dll
LoadedModule[44]=C:\windows\system32\SETUPAPI.dll
LoadedModule[45]=C:\windows\SYSTEM32\clbcatq.dll
LoadedModule[46]=C:\windows\system32\propsys.dll
LoadedModule[47]=C:\windows\SYSTEM32\profapi.dll
LoadedModule[48]=C:\Program Files\XnViewMP\Plugins\Xjp2.dll
LoadedModule[49]=C:\windows\SYSTEM32\dbghelp.dll
LoadedModule[50]=C:\Program Files\Intel\iCLS Client\ssleay32.dll
LoadedModule[51]=C:\Program Files\Intel\iCLS Client\LIBEAY32.dll
LoadedModule[52]=C:\windows\SYSTEM32\CRYPTSP.dll
LoadedModule[53]=C:\windows\system32\rsaenh.dll
LoadedModule[54]=C:\windows\SYSTEM32\bcrypt.dll
LoadedModule[55]=C:\windows\system32\Crypt32.DLL
LoadedModule[56]=C:\windows\system32\MSASN1.dll
LoadedModule[57]=C:\windows\system32\mswsock.dll
LoadedModule[58]=C:\windows\SYSTEM32\DNSAPI.dll
LoadedModule[59]=C:\Windows\System32\rasadhlp.dll
LoadedModule[60]=C:\windows\SYSTEM32\IPHLPAPI.DLL
LoadedModule[61]=C:\windows\SYSTEM32\WINNSI.DLL
LoadedModule[62]=C:\windows\system32\userenv.dll
LoadedModule[63]=C:\windows\WinSxS\amd64_microsoft.windows.common-controls_6595b64144ccf1df_6.0.9600.16384_none_62475f7becb72503\comctl32.dll
LoadedModule[64]=C:\windows\SYSTEM32\WindowsCodecs.dll
LoadedModule[65]=C:\Windows\System32\thumbcache.dll
LoadedModule[66]=C:\Program Files\XnViewMP\plugins\imageformats\qgif4.dll
LoadedModule[67]=C:\Program Files\XnViewMP\plugins\imageformats\qico4.dll
LoadedModule[68]=C:\Program Files\XnViewMP\plugins\imageformats\qjpeg4.dll
LoadedModule[69]=C:\Program Files\XnViewMP\plugins\imageformats\qsvg4.dll
LoadedModule[70]=C:\Program Files\XnViewMP\plugins\imageformats\qtga4.dll
LoadedModule[71]=C:\Program Files\XnViewMP\plugins\imageformats\qtiff4.dll
LoadedModule[72]=C:\windows\SYSTEM32\oleacc.dll
LoadedModule[73]=C:\windows\SYSTEM32\SspiCli.dll
LoadedModule[74]=C:\windows\SYSTEM32\MPR.dll
LoadedModule[75]=C:\windows\System32\drprov.dll
LoadedModule[76]=C:\windows\System32\WINSTA.dll
LoadedModule[77]=C:\windows\System32\ntlanman.dll
LoadedModule[78]=C:\windows\System32\davclnt.dll
LoadedModule[79]=C:\windows\System32\DAVHLPR.dll
LoadedModule[80]=C:\windows\System32\wkscli.dll
LoadedModule[81]=C:\windows\SYSTEM32\cscapi.dll
LoadedModule[82]=C:\windows\System32\netutils.dll
LoadedModule[83]=C:\windows\SYSTEM32\apphelp.dll
LoadedModule[84]=C:\Windows\System32\dlnashext.dll
LoadedModule[85]=C:\Windows\System32\PlayToDevice.dll
LoadedModule[86]=C:\Program Files (x86)\Adobe\Adobe Creative Cloud\CoreSync\CoreSync_x64.dll
LoadedModule[87]=C:\windows\SYSTEM32\MSVCP110.dll
LoadedModule[88]=C:\windows\SYSTEM32\MSVCR110.dll
LoadedModule[89]=C:\Windows\System32\EhStorShell.dll
LoadedModule[90]=C:\windows\System32\cscui.dll
LoadedModule[91]=C:\windows\System32\CSCDLL.dll
LoadedModule[92]=C:\windows\system32\mssprxy.dll
State[0].Key=Transport.DoneStage1
State[0].Value=1
FriendlyEventName=Stopped working
ConsentKey=APPCRASH
AppName=XnViewMP
AppPath=C:\Program Files\XnViewMP\xnview.exe
NsPartner=windows
NsGroup=windows8
ApplicationIdentity=A75D5EDFE1A7627BBB07AB4DE278BF12

User avatar
xnview
Author of XnView
Posts: 32081
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Fails to start XnView MP 0.64

Post by xnview » Tue Apr 15, 2014 1:49 pm

you have not a dialog to send crash dump?
Pierre.

jeb5000
Posts: 5
Joined: Wed Apr 09, 2014 2:32 am

Re: Fails to start XnView MP 0.64

Post by jeb5000 » Tue Apr 15, 2014 5:18 pm

The first few times it stopped working there was a popup to send something to Microsoft but that was all, hit send report the first couple of times. Have no idea where report goes, have no idea how to send to you. Would need a how to explanation on how to send to you, this is not something I've had to do before. Since I was setting up a new laptop I decided to try XnViewMP. With the problem I've uninstalled XnViewMP and installed XnView which runs with no problem. Sorry for my ignorance. Have been using XnView for years and should have made a donation a long time ago.

Have a good day and a better tomorrow!

User avatar
m.Th.
XnThusiast
Posts: 1572
Joined: Wed Aug 16, 2006 6:31 am
Contact:

Re: Fails to start XnView MP 0.64

Post by m.Th. » Wed Apr 16, 2014 5:20 am

PMFJI but just to clarify:

Pierre speaks about the XnView MP's crash reporter which is a popup window of (almost) square shape with a red logo on it.

However, in this case the crash wasn't caught by the above handler, but by the WER (Windows Error Reporter) - the user (correctly) posted a typical report from this error handler.

Pierre wants the 'crash dump' file in order to "see" what was the state of the program in the moment of crashing.

You can go to C:\Users\{your user name here}\AppData\Local\Microsoft\Windows\WER\ReportQueue

...and look for folders named like this: - ...Note: In order to get the latest crashes sort the folders by date and get the most recent ones:

AppHang_xnview.exe_c3ac75c5c12ba34759a049b5895ceb95e870ab_32e1bab4 (just ignore the long tail at the end. It is just a hash).

There you'll find some files - grab the report.wer (which you already posted here) and the file with the extension .mdmp and send it to Pierre via email or PM.

Also, looking at your list of WORKS & FAILS it strikes me that all your WORKS have in the middle an "\x5)" whereas the FAILS have instead other value in there. I think that isn't so much that the program is Maximized or not when you close it (IOW when the config is saved) but rather a pane or something similar is causing the problem. What resolution do you have on your laptop?
m. Th.

The Ascetic Experience - The best photos and texts from Holy Mountain (Athos)

- Dark Themed XnViewMP 0.90 64bit & XnView 2.00 x64 on Win7 x64 -

jeb5000
Posts: 5
Joined: Wed Apr 09, 2014 2:32 am

Re: Fails to start XnView MP 0.64

Post by jeb5000 » Fri Apr 18, 2014 4:43 pm

Do not get XnView MP's crash reporter.
Nothing in C:\Users\{your user name here}\AppData\Local\Microsoft\Windows\WER\ReportQueue for AppHang.xnview.exe
Searched for and did not find AppHang_xnview.exe. . . anywhere on the hard drive
There are 32 AppCrash xnview.exe. . . files
Resolution is 1920x1080
Have uninstalled XnViewMP and installed XnView 2.22 which runs fine.

User avatar
m.Th.
XnThusiast
Posts: 1572
Joined: Wed Aug 16, 2006 6:31 am
Contact:

Re: Fails to start XnView MP 0.64

Post by m.Th. » Sat Apr 19, 2014 5:24 am

jeb5000 wrote:Do not get XnView MP's crash reporter.
Nothing in C:\Users\{your user name here}\AppData\Local\Microsoft\Windows\WER\ReportQueue for AppHang.xnview.exe
Searched for and did not find AppHang_xnview.exe. . . anywhere on the hard drive
There are 32 AppCrash xnview.exe. . . files
Resolution is 1920x1080
Have uninstalled XnViewMP and installed XnView 2.22 which runs fine.
:) - Nevermind...

Let's try another route. Because most probably is a corner case, something about your GUI layout, do like this:

1. Try to crash XnView MP - it seems that it is easy for you :)
2. Remember which was the disposition of windows/panes etc. on your screen.
3. Enter again with a working configuration, reproduce the configuration that fails BUT do not close the program
4. Take a screenshot an post it here.
m. Th.

The Ascetic Experience - The best photos and texts from Holy Mountain (Athos)

- Dark Themed XnViewMP 0.90 64bit & XnView 2.00 x64 on Win7 x64 -

maximiliano
Posts: 21
Joined: Thu May 01, 2014 2:00 pm

Re: Fails to start XnView MP 0.64

Post by maximiliano » Thu May 01, 2014 2:12 pm

Seems to have the same problem.
Have to delete xnview.ini file to start XnView MP. If no maximize or change the window size, no problem.
Uninstall and reinstall not solve the problem.
When fails a error windows appear (XnViewMP dejo de funcionar) and the only option is to close.
Have no files in ReportQueue folder.
With Windows 8 works fine, but after upgrade to Windows 8.1 have this problem.

Gérard 91
Posts: 88
Joined: Wed Sep 23, 2009 8:33 pm

Re: Fails to start XnView MP 0.64

Post by Gérard 91 » Mon May 05, 2014 1:50 pm

Hello!

1)I got the same problem
I decided, 4 days ago, to uninstall MP (last version 0.63 I think) on a laptop/netbook Win 8.1 just after windows update (the one of April's end).
After installing MP 0.64 impossible to launch MP without a crash imediatly after the main frame displayed.
(no problem with Xnview Win)
As read here upon, I was obliged to delete (rename in fact) the old .ini
With the new created .ini, XnView MP run normally, but it's necessary to set up again all displaying options.
Something to do to prevent this ?

2) A another small bugg for "exif shutter speed" displaying. I hesitate to open à new topic for that because I don't remember how I got the solution , perhaps Pierre ? ...
The label proposed for "thumb label" and for " informations to display" on full screen view, is "Shutter speed", but don't process.
It's necessary to choose instead (write in custom fields) "Exposure time"
It should be nice for dummies like me to have it fixed.

Thanks again to Pierre for that marvellous soft.
Gérard

User avatar
xnview
Author of XnView
Posts: 32081
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Fails to start XnView MP 0.64

Post by xnview » Tue May 06, 2014 1:53 pm

Gérard 91 wrote: As read here upon, I was obliged to delete (rename in fact) the old .ini
With the new created .ini, XnView MP run normally, but it's necessary to set up again all displaying options.
Something to do to prevent this ?
could you send the crash report please (kolor dialog)?
Pierre.

Gérard 91
Posts: 88
Joined: Wed Sep 23, 2009 8:33 pm

Re: Fails to start XnView MP 0.64

Post by Gérard 91 » Tue May 06, 2014 9:36 pm

I find this Pierre. Not sure that's the answer you wish!

Nom de l’application défaillante xnview.exe, version : 0.52.0.0, horodatage : 0x52c817f0
Nom du module défaillant : QtGui4.dll, version : 4.8.5.0, horodatage : 0x528a69e6
Code d’exception : 0xc000041d
Décalage d’erreur : 0x00000000001922b4
ID du processus défaillant : 0xcfc
Heure de début de l’application défaillante : 0x01cf68619565d4f7
Chemin d’accès de l’application défaillante : C:\Program Files\XnViewMP\xnview.exe
Chemin d’accès du module défaillant: C:\Program Files\XnViewMP\QtGui4.dll
ID de rapport : d370ab07-d454-11e3-be8d-60a44cd7cbe7
Nom complet du package défaillant :
ID de l’application relative au package défaillant :

User avatar
xnview
Author of XnView
Posts: 32081
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Fails to start XnView MP 0.64

Post by xnview » Wed May 07, 2014 9:33 am

Gérard 91 wrote:I find this Pierre. Not sure that's the answer you wish!
when you have the crash, you have not a dialog to send the mini dump?
Pierre.

Post Reply