0.64 Win: Doesn't remember last save directory

Older bugs which are supposed to be fixed in 0.84. *** Please try to reproduce your bug and confirm the bug fix. ***

Moderator: Dreamer

Post Reply
Anamon
Posts: 9
Joined: Mon Jan 27, 2014 9:59 pm

0.64 Win: Doesn't remember last save directory

Post by Anamon » Sat Apr 12, 2014 4:39 pm

It seems strange that I couldn't find this bug reported so far, but I'm pretty positive it is one.

XnView MP 0.64 on Win7 x64 never remembers the last folder I saved a copy of an image to, either using "Save as..." or "Export...". This is the case even during one single session. The save dialogue always points to the directory that the current picture resides in. When saving or exporting, I switch to the directory I want to save to and confirm, but even when not doing anything at all before choosing to save again, the dialogue will be back pointing at the current image directory, and not the one I just saved to.

Whenever I save or export a file to a directory and then check the xnview.ini, SaveFolder in section [Viewer] is updated to that path. However, XnView MP never seems to read that value back again. I thought the problem could be due to paths containing spaces or special characters, or using forward slashes on a Window system, but the setting still isn't read when neither is the case.

User avatar
xnview
Author of XnView
Posts: 31175
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Doesn't remember last save directory (Windows)

Post by xnview » Mon Apr 14, 2014 12:52 pm

See Issue 339 for current status and details.
Pierre.

Tup3x
Posts: 8
Joined: Sun Jun 28, 2015 10:30 am
Location: Finland

Re: Doesn't remember last save directory (Windows)

Post by Tup3x » Sun Jun 28, 2015 10:40 am

I assume that this is same problem that I have. For some reason it still doesn't remember the last save location when using Export function.

How to reproduce:
- Drag some images to XnViewMP from same location.
- Save the one of those images to different location using the Export function. (By default it seems to use same folder where the original image was.)
- Save another opened image using the Export function. It will not remember the last save location and gives image source folder instead.


Also XnViewMP crashes when I select bestfit option in Exporter.

Platform:
Windows 8.1 Pro x64, XnViewMP 0.72 x64

Excluding those two issues it runs great vs. XnView.

User avatar
xnview
Author of XnView
Posts: 31175
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Doesn't remember last save directory (Windows)

Post by xnview » Tue Jun 30, 2015 8:33 am

Tup3x wrote:I assume that this is same problem that I have. For some reason it still doesn't remember the last save location when using Export function.
could you try the 0.75?
Pierre.

Anamon
Posts: 9
Joined: Mon Jan 27, 2014 9:59 pm

Re: Doesn't remember last save directory (Windows)

Post by Anamon » Sun Feb 21, 2016 6:07 pm

I still have this problem in the Export dialogue on 0.78 x64 (Jan 12 2016), although it seems fixed for Save As.

Toggling For 'Save as', use original pathname switches between the path of the original file and the last used save path when using File > Save as…, but the setting is ignored for File > Export which will always point to the original location (even when exporting, closing the Export dialog, and immediately exporting again, it will revert). I assume the setting should also be used for the Export dialogue?

User avatar
xnview
Author of XnView
Posts: 31175
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Doesn't remember last save directory (Windows)

Post by xnview » Thu Feb 25, 2016 2:58 pm

Anamon wrote:I still have this problem in the Export dialogue on 0.78 x64 (Jan 12 2016), although it seems fixed for Save As.

Toggling For 'Save as', use original pathname switches between the path of the original file and the last used save path when using File > Save as…, but the setting is ignored for File > Export which will always point to the original location (even when exporting, closing the Export dialog, and immediately exporting again, it will revert). I assume the setting should also be used for the Export dialogue?
ok, i'll change for export too
Pierre.

Tup3x
Posts: 8
Joined: Sun Jun 28, 2015 10:30 am
Location: Finland

Re: Doesn't remember last save directory (Windows)

Post by Tup3x » Sat Oct 01, 2016 11:51 am

xnview wrote:
Anamon wrote:I still have this problem in the Export dialogue on 0.78 x64 (Jan 12 2016), although it seems fixed for Save As.

Toggling For 'Save as', use original pathname switches between the path of the original file and the last used save path when using File > Save as…, but the setting is ignored for File > Export which will always point to the original location (even when exporting, closing the Export dialog, and immediately exporting again, it will revert). I assume the setting should also be used for the Export dialogue?
ok, i'll change for export too
I think this is still not working properly (XnviewMP 0.82, Windows 10 Pro 64bit)? When I export a image the save location always reverts to the directory where the original image was located. It's rather large pain in the ass when you want to export multiple images. Save As option seems to remember the last used location though.

User avatar
xnview
Author of XnView
Posts: 31175
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Doesn't remember last save directory (Windows)

Post by xnview » Mon Oct 03, 2016 7:05 am

Tup3x wrote: I think this is still not working properly (XnviewMP 0.82, Windows 10 Pro 64bit)? When I export a image the save location always reverts to the directory where the original image was located. It's rather large pain in the ass when you want to export multiple images. Save As option seems to remember the last used location though.
Export from browser or viewer?
Pierre.

Tup3x
Posts: 8
Joined: Sun Jun 28, 2015 10:30 am
Location: Finland

Re: Doesn't remember last save directory (Windows)

Post by Tup3x » Mon Oct 03, 2016 8:27 am

xnview wrote:
Tup3x wrote: I think this is still not working properly (XnviewMP 0.82, Windows 10 Pro 64bit)? When I export a image the save location always reverts to the directory where the original image was located. It's rather large pain in the ass when you want to export multiple images. Save As option seems to remember the last used location though.
Export from browser or viewer?
It looks like both at doing it. The difference is that when I export from browser it always resets the location to desktop. If I export from viewer (i.e. open a single image directly with XnViewMP) it always reset the location to the directory where the original opened image was located.

User avatar
xnview
Author of XnView
Posts: 31175
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Doesn't remember last save directory (Windows)

Post by xnview » Mon Oct 03, 2016 12:32 pm

Tup3x wrote:It looks like both at doing it. The difference is that when I export from browser it always resets the location to desktop. If I export from viewer (i.e. open a single image directly with XnViewMP) it always reset the location to the directory where the original opened image was located.
ok, in fact, export use 'save as' location, if you 'save as' a picture before, this is the folder used. I fix it...
Pierre.

Tup3x
Posts: 8
Joined: Sun Jun 28, 2015 10:30 am
Location: Finland

Re: Doesn't remember last save directory (Windows)

Post by Tup3x » Mon Oct 03, 2016 12:41 pm

xnview wrote:
Tup3x wrote:It looks like both at doing it. The difference is that when I export from browser it always resets the location to desktop. If I export from viewer (i.e. open a single image directly with XnViewMP) it always reset the location to the directory where the original opened image was located.
ok, in fact, export use 'save as' location, if you 'save as' a picture before, this is the folder used. I fix it...
I see... Now both exports seem to always default to that last "save as" location (I wonder what was going on). It would indeed be great if it would remember the last save location from export too.

User avatar
helmut
Posts: 8153
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: 0.64 Win: Doesn't remember last save directory

Post by helmut » Mon Dec 05, 2016 9:04 pm

The "problem" with the Export folder is supposed to be fixed in XnView MP 0.84 beta 1. Could you please try and confirm the fix, Tup3x?

Post Reply