View modus shows wrong picture

*** Please report new bugs here! ***

Moderator: Dreamer

bdesmet
Posts: 14
Joined: Thu Apr 10, 2014 7:29 pm

View modus shows wrong picture

Post by bdesmet » Sun Jun 29, 2014 2:00 pm

Probably a bug which appears in XnViewMP 0.68 for Mac:

I am using Mac OS X 10.8.5

- Choose a picture in Browse Modus
- Double click the picture, it appears in View Modus.
- While in View Modus, perform an action on the picture, like rotation, crop, etc. Save the modification.
- The modified picture appears correctly in View Modus.
- Close the View Modus
- In Browse Modus, it should be nice if the thumbnail is updated automatically, but ok, press F5 and the thumbnail gets updated correctly.
- Double click the modified picture again.
- Surprisingly, the "old" (unmodified) picture re-appears in View Modus. Probably some cache issue. If you check the picture with an external viewer, the modification is correctly persisted in the picture file. The only work-around I could fine is restarting the application.

Best regards,
Brecht

User avatar
m.Th.
XnThusiast
Posts: 1575
Joined: Wed Aug 16, 2006 6:31 am
Contact:

Re: View modus shows wrong picture

Post by m.Th. » Tue Jul 08, 2014 8:02 am

Yes, it is a cache problem. AFAIK Pierre is aware of the issue. I think & hope it will be fixed in the next version.
m. Th.

The Ascetic Experience - The best photos and texts from Holy Mountain (Athos)

- Dark Themed XnViewMP 0.90 64bit & XnView 2.00 x64 on Win7 x64 -

User avatar
oops66
XnThusiast
Posts: 1999
Joined: Tue Jul 17, 2007 1:17 am
Location: France

Re: View modus shows wrong picture

Post by oops66 » Wed Jul 09, 2014 9:12 am

Hello,
I have already experienced the same issue (the thumbnail preview (browser mode) is not the same as the jpg picture itself (preview mode or view mode or fullscreen mode)).

It's a SEVERE BUG, because you can delete by inadvertence a nice picture, just because a wrong thumbnail is shown for this nice picture.
XnViewMP 0.82 Linux X64 - Ubuntu 16.04 LTS - X64

User avatar
oops66
XnThusiast
Posts: 1999
Joined: Tue Jul 17, 2007 1:17 am
Location: France

Re: View modus shows wrong picture

Post by oops66 » Thu Sep 04, 2014 12:20 pm

... No news ... good new ? ;-)
XnViewMP 0.82 Linux X64 - Ubuntu 16.04 LTS - X64

User avatar
xnview
Author of XnView
Posts: 32251
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: View modus shows wrong picture

Post by xnview » Fri Sep 05, 2014 2:31 pm

oops66 wrote:... No news ... good new ? ;-)
currently i can't reproduce this issue :(
Pierre.

User avatar
m.Th.
XnThusiast
Posts: 1575
Joined: Wed Aug 16, 2006 6:31 am
Contact:

Re: View modus shows wrong picture

Post by m.Th. » Thu Sep 18, 2014 8:26 am

xnview wrote:
oops66 wrote:... No news ... good new ? ;-)
currently i can't reproduce this issue :(
I do. See my specs in signature.

Steps:

1. Double click on a JPG in thumbs pane. The file opens in view mode.
2. On the opened file make a visible effect: for example move the Saturation slider to minimum in order to have a black & white photo.
3. Close the Tab with the opened file. It will ask you to save the file. Choose 'yes'.
4. In thumbs pane, the thumb stays the same (a small bug). Press F5. The thumb will be updated with the image turned to black & white.
5. Double click again on the same JPG in thumbs pane. The file opens in view mode.

Expected:

The file should be black & white

Actual:

The file is in color (like the steps 2-3 would never happened)
m. Th.

The Ascetic Experience - The best photos and texts from Holy Mountain (Athos)

- Dark Themed XnViewMP 0.90 64bit & XnView 2.00 x64 on Win7 x64 -

HanVroon
Posts: 211
Joined: Thu Jan 28, 2010 7:30 am

Re: View modus shows wrong picture

Post by HanVroon » Fri Sep 19, 2014 12:24 pm

Hi,

Two days ago I saw the same issue, re-opening a saved image did show the original image, not the changed image.
I remember that I got the changed image on screen by selecting a different folder in the folder pane, then selected the folder with the changed image, then opened the changed image again and saw the changes. So a cache in memory issue, I thought.

I could reproduce it again. With one image in a folder, copy that image so I have an original to copy again and again to test with.
I tested several times now and sometimes the modified image was shown after re-opening it.
For now I thing that the modified image has to stay selected in the Browser. I can open the image 10 times and not see the modification.
As soon as I click in the white space of the Browser (then the thumbnail gets unselected) and then double click on the thumbnail again, the modified image is shown.
So a folder change is not necessary after all.

Regards,
Han

User avatar
m.Th.
XnThusiast
Posts: 1575
Joined: Wed Aug 16, 2006 6:31 am
Contact:

Re: View modus shows wrong picture

Post by m.Th. » Thu Sep 25, 2014 6:12 am

HanVroon wrote:Hi,

Two days ago I saw the same issue, re-opening a saved image did show the original image, not the changed image.
I remember that I got the changed image on screen by selecting a different folder in the folder pane, then selected the folder with the changed image, then opened the changed image again and saw the changes. So a cache in memory issue, I thought.

I could reproduce it again. With one image in a folder, copy that image so I have an original to copy again and again to test with.
I tested several times now and sometimes the modified image was shown after re-opening it.
For now I thing that the modified image has to stay selected in the Browser. I can open the image 10 times and not see the modification.
As soon as I click in the white space of the Browser (then the thumbnail gets unselected) and then double click on the thumbnail again, the modified image is shown.
So a folder change is not necessary after all.

Regards,
Han
Aha! The cache is cleared at selection change. Now Pierre must just clear it a little bit earlier: at save, if it is the same file which is saved.
m. Th.

The Ascetic Experience - The best photos and texts from Holy Mountain (Athos)

- Dark Themed XnViewMP 0.90 64bit & XnView 2.00 x64 on Win7 x64 -

bdesmet
Posts: 14
Joined: Thu Apr 10, 2014 7:29 pm

Re: View modus shows wrong picture

Post by bdesmet » Sat Oct 11, 2014 12:41 pm

I installed the new Mac OS X release of XNViewMP (0.69).

I observe that the issue described in this thread also appears version 0.69.

User avatar
B.Douille
Posts: 183
Joined: Sat Sep 09, 2006 9:25 pm
Location: Hte Savoie - France

Re: View modus shows wrong picture

Post by B.Douille » Tue Oct 28, 2014 7:39 pm

bdesmet wrote:I installed the new Mac OS X release of XNViewMP (0.69).

I observe that the issue described in this thread also appears version 0.69.
Same with Windows 7. I checked with both a change in saturation and a rotation. Opening the modified picture with XnView classic shows the change was well applied. To show in MP I need to clear the Catalog.

PS:
bdesmet wrote:In thumbs pane, the thumb stays the same (a small bug). Press F5
I admit is small bug but painful
Daniel, promoting XnView since 2004 and now using MP only (Platform Windows 10 & Windows 7, both 64 bits)

bdesmet
Posts: 14
Joined: Thu Apr 10, 2014 7:29 pm

Re: View modus shows wrong picture

Post by bdesmet » Mon Jun 22, 2015 12:17 pm

Hi,

The same bug is still out there. I tested it with XnViewMP 0.72 for Windows x32 running on Windows 7 (32-bit). The conditions in which the bug appears are still the same:

- Choose a picture in Browse Modus
- Double click the picture, it appears in View Modus.
- While in View Modus, perform an action on the picture, like rotation, crop, etc. Save the modification.
- The modified picture appears correctly in View Modus.
- Close the View Modus
- In Browse Modus, it should be nice if the thumbnail is updated automatically, but ok, press F5 and the thumbnail gets updated correctly.
- Double click the modified picture again.
- Surprisingly, the "old" (unmodified) picture re-appears in View Modus. Probably some cache issue. If you check the picture with an external viewer, the modification is correctly persisted in the picture file. The only work-around I could fine is restarting the application.

Best regards,
Brecht

User avatar
xnview
Author of XnView
Posts: 32251
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: View modus shows wrong picture

Post by xnview » Tue Jun 23, 2015 9:04 am

bdesmet wrote: The same bug is still out there. I tested it with XnViewMP 0.72 for Windows x32 running on Windows 7 (32-bit). The conditions in which the bug appears are still the same:

- Choose a picture in Browse Modus
- Double click the picture, it appears in View Modus.
- While in View Modus, perform an action on the picture, like rotation, crop, etc. Save the modification.
- The modified picture appears correctly in View Modus.
- Close the View Modus
- In Browse Modus, it should be nice if the thumbnail is updated automatically, but ok, press F5 and the thumbnail gets updated correctly.
- Double click the modified picture again.
- Surprisingly, the "old" (unmodified) picture re-appears in View Modus. Probably some cache issue. If you check the picture with an external viewer, the modification is correctly persisted in the picture file. The only work-around I could fine is restarting the application.
And if you desactivate setings>View>Misc>Read ahead & Keep current image?
Pierre.

HanVroon
Posts: 211
Joined: Thu Jan 28, 2010 7:30 am

Re: View modus shows wrong picture

Post by HanVroon » Tue Jun 23, 2015 11:03 am

If i may interfere...

If "Read one image ahead" and "Keep current image" are unchecked, it's still the same.
The unmodified picture is shown after reopening.
It looks like a "Keep current image" problem, but after closing the image this cache should be cleared, I thing. And after saving to disk the modification should be in cache, not the original.

The only way besides closing/opening XnViewMP is also moving one file ahead or back with Previous/Next file.

Regards,
Han
Last edited by HanVroon on Tue Jun 23, 2015 11:17 am, edited 1 time in total.

User avatar
B.Douille
Posts: 183
Joined: Sat Sep 09, 2006 9:25 pm
Location: Hte Savoie - France

Re: View modus shows wrong picture

Post by B.Douille » Tue Jun 23, 2015 11:17 am

Confirmed
Daniel, promoting XnView since 2004 and now using MP only (Platform Windows 10 & Windows 7, both 64 bits)

User avatar
xnview
Author of XnView
Posts: 32251
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: View modus shows wrong picture

Post by xnview » Wed Aug 19, 2015 4:02 pm

when you go back to browser, the preview is updated? or only the thumbnail is not updated?
Pierre.

Post Reply