descript.ion display unicode incorrectly

*** Please report new bugs here! ***

Moderator: Dreamer

User avatar
xnview
Author of XnView
Posts: 34093
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: descript.ion display unicode incorrectly

Post by xnview »

descript.ion must exists in utf8 else local codepage will be used
Pierre.
herb
Posts: 174
Joined: Sat Jul 18, 2009 3:19 pm

Re: descript.ion display unicode incorrectly

Post by herb »

Hello Pierre,

maybe I understand what you try to say.
But why can this file not be created with unicode encoding (and with BOM) in case it does not exist?

Best regards
Herb
User avatar
xnview
Author of XnView
Posts: 34093
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: descript.ion display unicode incorrectly

Post by xnview »

herb wrote: maybe I understand what you try to say.
But why can this file not be created with unicode encoding (and with BOM) in case it does not exist?
perhaps i need to add a setting for that. I'm not sure that unicode description will works with all apps...
Pierre.
herb
Posts: 174
Joined: Sat Jul 18, 2009 3:19 pm

Re: descript.ion display unicode incorrectly

Post by herb »

Hello Pierre,

With version 0.94.1 I still have the problem that unicode characters in field description are not properly stored in file descript.ion.

Best regards
herb
User avatar
xnview
Author of XnView
Posts: 34093
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: descript.ion display unicode incorrectly

Post by xnview »

herb wrote: Sun Nov 24, 2019 6:57 pm With version 0.94.1 I still have the problem that unicode characters in field description are not properly stored in file descript.ion.
how to reproduce?
Pierre.
herb
Posts: 174
Joined: Sat Jul 18, 2009 3:19 pm

Re: descript.ion display unicode incorrectly

Post by herb »

Hello Pierre,

sorry for my late reply.

In case of I test with unicode characters I use BabelMap. This is a small programm for Windows, which allows to select each defined unicode character.
With Copy & Paste I write such a unicode character in field description of EditComment window.
After write, opening file descript.ion with an editor, we see, this character is stored as "?" and not as proper unicode character.
I did this test with no file descript.ion avialable at test begin.

I hope this helps to reproduce.

Best regards
herb
User avatar
xnview
Author of XnView
Posts: 34093
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: descript.ion display unicode incorrectly

Post by xnview »

herb wrote: Sat Dec 21, 2019 11:41 am In case of I test with unicode characters I use BabelMap. This is a small programm for Windows, which allows to select each defined unicode character.
With Copy & Paste I write such a unicode character in field description of EditComment window.
which unicode? utf16?
Pierre.
herb
Posts: 174
Joined: Sat Jul 18, 2009 3:19 pm

Re: descript.ion display unicode incorrectly

Post by herb »

Hello Pierre,

BabelMap always uses UTF-8 encoding.
I think to use only UTF-8 in file descript.ion is the best solution.

Best regards
herb
User avatar
xnview
Author of XnView
Posts: 34093
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: descript.ion display unicode incorrectly

Post by xnview »

so you copy a utf8 text from BabelMap into description dialog?
Pierre.
herb
Posts: 174
Joined: Sat Jul 18, 2009 3:19 pm

Re: descript.ion display unicode incorrectly

Post by herb »

Hello Pierre,

To use BabelMap is only one possibility to write an unicode character. I use it when I am interested in a specific character.
I also use Windows IME to write e.g. chinese characters.

Best regards
herb
Post Reply