[Fixed] v0.78: BAD Delete/Move Bug - May Corrupt file system

Bugs and Suggestions in XnView MP or XnConvert MP which have been resolved.

Moderator: XnTriq

Erixx haxx
Posts: 330
Joined: Tue Jul 28, 2015 10:37 am

[Fixed] v0.78: BAD Delete/Move Bug - May Corrupt file system

Postby Erixx haxx » Sun Feb 07, 2016 10:18 am

To Reproduce:

-Enter a base folder with subfolders inside it.
-Have Photos inside the subfolders and have 1 empty subfolder
-Now move one of the subfolders with images inside to the empty subfolder via "FOLDER TREE" Drag an Drop.
-It will not move the folder, but create a new folder named "Copy Of "
-Try to delete it. It will delete and keep comming back each time you re-enter the folder.
-Explorer says its not their, can not delete.

This was done 4x times, Every time I tried it, and was on 2 external Hdd's. I was too afraid to try it on my local drive
because i really don't know how to get them removed other than reformat. 1st drive it happend on is 3tb's
The other 3 test in a row was on a small 2gig. no probs to reformat it.

Everything under: General... File operations... is checked except "use dialog for rename.

Win7x64Pro
v0.78x64
Last edited by Erixx haxx on Wed Feb 22, 2017 2:08 am, edited 1 time in total.

Erixx haxx
Posts: 330
Joined: Tue Jul 28, 2015 10:37 am

Re: v0.78 Bug: BAD Delete/Move Bug - May Corrupt file system

Postby Erixx haxx » Fri Feb 12, 2016 12:24 am

Any info on this.

Also any ideas on how to remove this ghost folder. Named "Copy of".
I can't delete or rename it and tried putting files inside, then it copies itself again and get 2 folders. Same name.
I can delete 1, but not the original.
Attachments
V0.78 Move And Delete Bug - Screen_2016-02-10 09.21.28.jpg
Ghost folder

Mixer
Posts: 166
Joined: Fri Aug 28, 2015 6:24 am

Re: v0.78 Bug: BAD Delete/Move Bug - May Corrupt file system

Postby Mixer » Fri Feb 12, 2016 12:54 am

Erixx haxx wrote:Also any ideas on how to remove this ghost folder.

No, because ghostly folders aren't common. But since this is filesystem glitch, have you tried to run disk check first before deletion attempt? The one from Computer->right click partition->tools->Check now.

Erixx haxx
Posts: 330
Joined: Tue Jul 28, 2015 10:37 am

Re: v0.78 Bug: BAD Delete/Move Bug - May Corrupt file system

Postby Erixx haxx » Fri Feb 19, 2016 4:35 pm

No, because ghostly folders aren't common. But since this is filesystem glitch, have you tried to run disk check first before deletion attempt? The one from Computer->right click partition->tools->Check now.


Yea, 3 of 4.tb is going to take awhile and i won't be able to use the drive, but i guess is my only option though.


Can anyone brave try and confirm this. It's really easy.

- Try on a small Removable drive you can reformat.
-Just drag and drop 1 folder of files into another via "Folder Tree"
-Then delete the folder That you just moved. ( It won't be moved, It copies instead, try to delete it. ) Right click or button.

**Problems***
1) Folders drag and dropped on the same drive should be moved, not copied
2) Folders and files should delete without having to reformat the whole drive.
3) I consider this a critical bug when file system is corrupted by a program.

Erixx haxx
Posts: 330
Joined: Tue Jul 28, 2015 10:37 am

Re: v0.78 Bug: BAD Delete/Move Bug - May Corrupt file system

Postby Erixx haxx » Tue Mar 01, 2016 10:27 am

Any news on this issue. Am I the only one this happens to?

brazenvoid
Posts: 5
Joined: Sun Feb 14, 2016 1:02 pm

Re: v0.78 Bug: BAD Delete/Move Bug - May Corrupt file system

Postby brazenvoid » Wed Mar 02, 2016 8:29 pm

I reproduced this bug accidentally. It happened quiet similarly for me, still;

- Drag and drop a folder onto another in the file tree, it gets copied into it.
- The new folder is named strangely "Copy of " with no reference to the folder name of the source. No matter which folder you drop, its name is "Copy of "!
- Delete the folder through MP, the dialog will show it getting deleted.
- The folder will still show in the folder tree and view, even after deletion. The contents however get deleted.
- Deleting it still will not do anything, no reaction will show up.
- Deleting it through explorer will give an error with similar text as "Item not at location anymore".
- Killing any handles of Xnview to the folders didn't provide any results.
- Restarting the system also didn't do anything.

The ghost folders are still there and can't be deleted which is driving me nuts!

brazenvoid
Posts: 5
Joined: Sun Feb 14, 2016 1:02 pm

Re: v0.78 Bug: BAD Delete/Move Bug - May Corrupt file system

Postby brazenvoid » Thu Mar 03, 2016 2:47 pm

Ran chkdsk with no results and delete through console also returns the not found error. That is some serious file system corruption there!

I am on Windows 10 x64 Professional

Erixx haxx
Posts: 330
Joined: Tue Jul 28, 2015 10:37 am

Re: v0.78 Bug: BAD Delete/Move Bug - May Corrupt file system

Postby Erixx haxx » Thu Mar 03, 2016 6:27 pm

brazenvoid wrote:Ran chkdsk with no results and delete through console also returns the not found error. That is some serious file system corruption there!

Did you try chkdsk wth the -r switch or a tool that uses it. It should be to be more precise, but takes longer. lots longer if you have many files
I never tried because i had 4tb worth of files to scan and it would of taken days.

Only other option is to reformat the whole drive. That's what i ended up doing. I can't believe we are the only 2 this has happened too.

This BUG really needs to be addressed. Please...
And
Thank You

brazenvoid
Posts: 5
Joined: Sun Feb 14, 2016 1:02 pm

Re: v0.78 Bug: BAD Delete/Move Bug - May Corrupt file system

Postby brazenvoid » Fri Mar 04, 2016 5:19 pm

Nope nothing happened, everything was fine.

Update: I was able to delete them! I had this utilities suite from Puran installed which I primarily use for defragmentation and it had a permanently delete tool which worked!

User avatar
xnview
Author of XnView
Posts: 28579
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: v0.78 Bug: BAD Delete/Move Bug - May Corrupt file system

Postby xnview » Tue Mar 08, 2016 4:42 pm

i've tried to reproduce, but each time the subfolder is correctly moved... Really strange...
are you able to reproduce??

do you drag&drop from treeview to treeview?
Pierre.

User avatar
xnview
Author of XnView
Posts: 28579
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: v0.78 Bug: BAD Delete/Move Bug - May Corrupt file system

Postby xnview » Tue Mar 08, 2016 4:43 pm

brazenvoid wrote:I reproduced this bug accidentally. It happened quiet similarly for me, still;

are you able to reproduce??
Pierre.

Erixx haxx
Posts: 330
Joined: Tue Jul 28, 2015 10:37 am

Re: v0.78 Bug: BAD Delete/Move Bug - May Corrupt file system

Postby Erixx haxx » Wed Mar 09, 2016 6:38 am

do you drag&drop from treeview to treeview?

Hello:

Yes, it's from the folder tree to folder tree.
1: Drag 1 folder with files and drop inside another folder, above or below Via drag and drop.
2: It Brings up the copy dialog and starts coping right away. The new folder will be named "copy of"
3: Try to delete it by button or right click. It acts like its deleting, but the folder keeps showing back up.
4 Go to win explore to delete it and you will get an "error box" folder not found..

Note: all my attempts were made on an external drive. I've tried a total of 6 times now and it happens every time i've tried. Not sure if user brazenvoid had this happen on his local drive or external, though.
Format is ntsf with default vaules.
win7x64 pro

Note from my OP
Everything under: General... File operations... is checked except "use dialog for rename.


If you still can't reproduce this than maybe I can post my .ini file if you think will help.

Thanks

User avatar
xnview
Author of XnView
Posts: 28579
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: v0.78 Bug: BAD Delete/Move Bug - May Corrupt file system

Postby xnview » Wed Mar 09, 2016 3:24 pm

Erixx haxx wrote:
If you still can't reproduce this than maybe I can post my .ini file if you think will help.

Thanks

i can reproduce on win7, not win8.1
A space is at the end of folder name, rename by removing remove it with XnView
Pierre.

User avatar
xnview
Author of XnView
Posts: 28579
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: v0.78 Bug: BAD Delete/Move Bug - May Corrupt file system

Postby xnview » Wed Mar 09, 2016 4:15 pm

See Issue 813 for current status and details.
Pierre.

Erixx haxx
Posts: 330
Joined: Tue Jul 28, 2015 10:37 am

Re: v0.78 Bug: BAD Delete/Move Bug - May Corrupt file system

Postby Erixx haxx » Wed Mar 09, 2016 6:48 pm

xnview wrote:i can reproduce on win7, not win8.1
A space is at the end of folder name, rename by removing remove it with XnView

I seen that too, but couldn't change it. I only tried through explorer though.

Anyways, Good job at finding the issue here..

See Issue 813 for current status and details.


That's Great News..


As always, Thank You


Return to “MP - Resolved Bugs & Requests”

Who is online

Users browsing this forum: No registered users and 0 guests