0.83: Set Rating Then Rename Issue

Older bugs which are supposed to be fixed in 0.84. *** Please try to reproduce your bug and confirm the bug fix. ***

Moderator: Dreamer

Post Reply
Erixx haxx
Posts: 330
Joined: Tue Jul 28, 2015 10:37 am

0.83: Set Rating Then Rename Issue

Post by Erixx haxx » Mon Nov 14, 2016 3:33 am

Hello:
To repo:

-Options>> Metadata>> IPTC&XMP Tab = "Rating and label" are ticked.
-3 jpegs in a folder name = ( im-001, im-002, im-003 )

1) Set rating on 2nd jpeg image
2) Reorder files so 2n image is 1st
3) Rename all files = im-001, im-002, im-003
4) leave folder
5) Re-enter folder
6) Notice witch file has the rating you set earlier, ( It's Not the one you set)
Last edited by Erixx haxx on Mon Nov 28, 2016 4:49 am, edited 1 time in total.

Erixx haxx
Posts: 330
Joined: Tue Jul 28, 2015 10:37 am

Re: 0.83: Set Rating Then Rename Issue

Post by Erixx haxx » Mon Nov 28, 2016 4:47 am

Hello:

I don't see this in bug tracker yet, so if anyone has time could you please confirm this bug.
I see it as a pretty big issue because it corrupts the database as I think we all use ratings alot.


thanks

User avatar
XnTriq
Moderator & Librarian
Posts: 5457
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: 0.83: Set Rating Then Rename Issue

Post by XnTriq » Mon Nov 28, 2016 8:45 pm

Is this the correct way to reproduce the bug, Erixx haxx?
  1. Activate Enable thumbnail caching (Tools » Settings... » Catalog » Catalog).
  2. Activate Export rating in XMP metadata and Export color label in XMP metadata (Tools » Settings... » Metadata » IPTC & XMP » Rating & Label).
  3. Create a new/empty folder (X:\Test\).
  4. Put three JPEG files (void of any metadata) into X:\Test\:
    • im-001.jpg
    • im-002.jpg
    • im-003.jpg
  5. Select im-002.jpg in the browser and rate it (View » Rating & Colour label » Average):
    • im-001.jpg
    • im-002.jpg (Rating: Average)
    • im-003.jpg
  6. Reorder the files via drag&drop:
    • im-002.jpg (Rating: Average)
    • im-001.jpg
    • im-003.jpg
  7. Rename the files:
    • im-002.jpg » 1.jpg (Rating: Average)
    • im-001.jpg » 2.jpg
    • im-003.jpg » 3.jpg
  8. Point the browser to a different folder (X:\Fubar\).
  9. Go back to X:\Test\:
    • 1.jpg (Rating: Average)
    • 2.jpg
    • 3.jpg

Erixx haxx
Posts: 330
Joined: Tue Jul 28, 2015 10:37 am

Re: 0.83: Set Rating Then Rename Issue

Post by Erixx haxx » Mon Nov 28, 2016 11:36 pm

Hello XnTriq:

Great seeing you again, Also thanks for taking a peek in here.

Ok, I'm with you all the way down to here.
Point the browser to a different folder (X:\Fubar\).
Go back to X:\Test\:

1.jpg (Rating: Average)
2.jpg
3.jpg
My results are:

Point the browser to a different folder (X:\Fubar\).
Go back to X:\Test\:

1.jpg
2.jpg (Rating: Average)
3.jpg

2 Things I think maybe why your not seeing this.

1.) Your not keeping the same name scheme in your test all the way to the end ex. im-001
2.) I'm using batch rename dialog. (the rating still follows the correct image, just Xn is not keeping in sync with it)

Also note its easier to use people in the test so you can see the problem.

I think the problem here is Xn .db is not updated during the resorting of files.

User avatar
XnTriq
Moderator & Librarian
Posts: 5457
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: 0.83: Set Rating Then Rename Issue

Post by XnTriq » Tue Nov 29, 2016 2:00 am

Erixx haxx wrote:I'm using batch rename dialog. (the rating still follows the correct image, just Xn is not keeping in sync with it)
Ha! Batch renaming (im-00#) did it! Once again, you caught a extra tricky one :twisted: :bugconfirmed:

User avatar
xnview
Author of XnView
Posts: 32052
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.83: Set Rating Then Rename Issue

Post by xnview » Tue Nov 29, 2016 2:46 pm

See Issue 1031 for details.
Pierre.

Erixx haxx
Posts: 330
Joined: Tue Jul 28, 2015 10:37 am

Re: 0.83: Set Rating Then Rename Issue

Post by Erixx haxx » Wed Nov 30, 2016 4:23 am

Thank you, XnTriq
Also,

Thank you Pierre, for the speedy fix. It Says "Resolved" 0.84.

I hope your getting sleep. Bug tracker shows that a ton of work has been done over the past few days.


Thanks again...

User avatar
helmut
Posts: 8174
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: 0.83: Set Rating Then Rename Issue

Post by helmut » Mon Dec 19, 2016 5:18 am

This problem is supposed to be fixed in XnView MP 0.84 beta 3. Could you please try and confirm the bug fix, Erixx haxx?

Post Reply