0.91: Open xnviewmp.exe with image file as argument doesn't work

*** Please report new bugs here! ***

Moderator: Dreamer

_Rayman_
Posts: 9
Joined: Thu Nov 30, 2017 10:53 pm

0.91: Open xnviewmp.exe with image file as argument doesn't work

Post by _Rayman_ » Wed Sep 12, 2018 8:17 pm

I just updated my XnViewMPx64 installation to 0.91 as a portable installation on Windows 10.

I assigned my image file types in Windows accordingly so that XnViewMP is opened when I double click an image file in windows explorer. With 0.91 this functionality stopped: A small progress bar is shown (loading image) and then nothing happens.

The problem can be reproduced by trying the same call on the command shell:

xnviewmp.exe "examplepath/file.jpg"

shows the loading progress bar, then the image/xnviewmp is not shown.

When I start xnviewmp.exe without any image filename as argument then the program works normal.

grgr
Posts: 16
Joined: Tue Apr 07, 2015 3:42 pm

Re: 0.91: Open xnviewmp.exe with image file as argument doesn't work

Post by grgr » Thu Sep 13, 2018 9:36 am

I can confirm the same behaviour for macOS 10.11.6

User avatar
deus-ex
Posts: 102
Joined: Mon Sep 20, 2004 7:24 pm
Location: Earth

Re: 0.91: Open xnviewmp.exe with image file as argument doesn't work

Post by deus-ex » Thu Sep 13, 2018 9:40 am

Cannot reproduce, commandline argument and association in Windows 10 64-bit works fine here.
Best regards,
deus-ex

User avatar
xnview
Author of XnView
Posts: 30286
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.91: Open xnviewmp.exe with image file as argument doesn't work

Post by xnview » Thu Sep 13, 2018 1:32 pm

i can't reproduce the problem, what is your setting in General>Mode when starting with a file?
Pierre.

JMM72
Posts: 32
Joined: Wed Feb 10, 2016 2:16 pm

Re: 0.91: Open xnviewmp.exe with image file as argument doesn't work

Post by JMM72 » Thu Sep 13, 2018 2:13 pm

I can confirm this bug.
Windows 7 64bit, 0.91 64bit.

XVMP opens with browsing a folder, or without commandline. With commandline file argument, it doesn't start (process appears briefly in task manager but closes quickly).

In general, mode, I have it opening in full screen - viewer, when opening with an image.

Reinstalling 0.90, and bug doesn't appear, so at least it's not some new library.

User avatar
eliio
Posts: 16
Joined: Fri Jan 13, 2017 6:40 am
Location: Khimki
Contact:

Re: 0.91: Open xnviewmp.exe with image file as argument doesn't work

Post by eliio » Thu Sep 13, 2018 5:34 pm

Confirm this bug.
Win 7 64bit, 0.91 64bit.

As JMM72 I have the viewer set to full screen when opening single files from explorer.
Best,
Elisei

_Rayman_
Posts: 9
Joined: Thu Nov 30, 2017 10:53 pm

Re: 0.91: Open xnviewmp.exe with image file as argument doesn't work

Post by _Rayman_ » Thu Sep 13, 2018 7:43 pm

xnview wrote:
Thu Sep 13, 2018 1:32 pm
i can't reproduce the problem, what is your setting in General>Mode when starting with a file?
The Mode setting is "Fullscreen - Viewer" and that seems to be the problem!

I can reproduce the following:

Mode "Fullscreen - Viewer" >> XNViewMP doesn't open
Mode "Fullscreen - Browser" >> XNViewMP opens, but the window is frozen
Mode "Normal" >> XNView opens normally and can be used

User avatar
deus-ex
Posts: 102
Joined: Mon Sep 20, 2004 7:24 pm
Location: Earth

Re: 0.91: Open xnviewmp.exe with image file as argument doesn't work

Post by deus-ex » Fri Sep 14, 2018 4:46 am

_Rayman_ wrote:
Thu Sep 13, 2018 7:43 pm
I can reproduce the following:

Mode "Fullscreen - Viewer" >> XNViewMP doesn't open
Mode "Fullscreen - Browser" >> XNViewMP opens, but the window is frozen
Mode "Normal" >> XNView opens normally and can be used
I have set start-up mode to "Fullscreen - Browser" and thankfully no issues at this time.

Previously though when I tried v0.91 beta 2 I had the frozen screen too, i.e. XnViewMP would start-up and load an image given as a command-line argument, then no further action was possible and XnViewMP had to be terminated via Taskmanager.

An option to try for those currently having similar issues is to start XnViewMP with vanilla settings, i.e. without a xnview.ini (make a back-up copy or rename the file). This has helped me in the past to fix certain issues, but it also requires to do the whole configuration process again. If you manage to get XnViewMP running again, you can use your back-up of xnview.ini as a reference and copy/paste over certain settings. Your choice.
Best regards,
deus-ex

User avatar
deus-ex
Posts: 102
Joined: Mon Sep 20, 2004 7:24 pm
Location: Earth

Re: 0.91: Open xnviewmp.exe with image file as argument doesn't work

Post by deus-ex » Fri Sep 14, 2018 10:00 am

xnview wrote:
Fri Sep 14, 2018 8:04 am
Win 7?
_Rayman_ wrote this in his first post:
_Rayman_ wrote:
Wed Sep 12, 2018 8:17 pm
I just updated my XnViewMPx64 installation to 0.91 as a portable installation on Windows 10.
Best regards,
deus-ex

User avatar
xnview
Author of XnView
Posts: 30286
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.91: Open xnviewmp.exe with image file as argument doesn't work

Post by xnview » Fri Sep 14, 2018 10:09 am

could you try to replace the exe by this one and tell me if it works now?
Pierre.

JMM72
Posts: 32
Joined: Wed Feb 10, 2016 2:16 pm

Re: 0.91: Open xnviewmp.exe with image file as argument doesn't work

Post by JMM72 » Fri Sep 14, 2018 4:36 pm

I've just tried this exe over a freshly installed 0.91 and now it works as expected.
I've also tried to reproduce that other error about cycling mode with Enter key, and it works also as expected with this exe.

User avatar
deus-ex
Posts: 102
Joined: Mon Sep 20, 2004 7:24 pm
Location: Earth

Re: 0.91: Open xnviewmp.exe with image file as argument doesn't work

Post by deus-ex » Fri Sep 14, 2018 5:02 pm

JMM72 wrote:
Fri Sep 14, 2018 4:36 pm
I've also tried to reproduce that other error about cycling mode with Enter key, and it works also as expected with this exe.
I tried this EXE, too. Again I removed xnview.ini to start with a vanilla setup. However the issue remains unchanged here, all three switching modes still stop in Viewer mode, no cycling. No such issues with previous release v0.90.
Best regards,
deus-ex

_Rayman_
Posts: 9
Joined: Thu Nov 30, 2017 10:53 pm

Re: 0.91: Open xnviewmp.exe with image file as argument doesn't work

Post by _Rayman_ » Fri Sep 14, 2018 5:36 pm

xnview wrote:
Fri Sep 14, 2018 10:09 am
could you try to replace the exe by this one and tell me if it works now?
With this new EXE file I can reproduce:

Mode "Fullscreen - Viewer" >> XNViewMP opens and shows the image fullscreen, good!
Mode "Fullscreen - Browser" >> XNViewMP opens in fullscreen, when I hit return and get back to XNViewMP viewer the application is frozen

When in "Fullscreen - Viewer" and I cycle one round using enter key: fullscreen > viewer > browser > fullscreen > viewer, then the application freezes as well.

User avatar
xnview
Author of XnView
Posts: 30286
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.91: Open xnviewmp.exe with image file as argument doesn't work

Post by xnview » Mon Sep 17, 2018 8:08 am

please try with this EXE
Pierre.

grgr
Posts: 16
Joined: Tue Apr 07, 2015 3:42 pm

Re: 0.91: Open xnviewmp.exe with image file as argument doesn't work

Post by grgr » Mon Sep 17, 2018 12:07 pm

Don't you have a test build for Mac as well?

Post Reply