0.91: Open xnviewmp.exe with image file as argument doesn't work

*** Please report new bugs here! ***

Moderator: Dreamer

cday
XnThusiast
Posts: 1862
Joined: Sun Apr 29, 2012 9:45 am
Location: Cheltenham, U.K.

Re: 0.91: Open xnviewmp.exe with image file as argument doesn't work

Post by cday » Mon Sep 17, 2018 12:41 pm

grgr wrote:
Mon Sep 17, 2018 12:07 pm
Don't you have a test build for Mac as well?
One thing at a time! :D

User avatar
juozas
Posts: 13
Joined: Sun Sep 27, 2009 11:42 am
Location: Lithuania
Contact:

Re: 0.91: Open xnviewmp.exe with image file as argument doesn't work

Post by juozas » Mon Sep 17, 2018 5:57 pm

Confirmed on Ubuntu linux with General page setting Mode when starting from a file set to Full Screen - Viewer, window does not open, program closes before it can do anything, not even a crash to possibly debug.
XnViewMP version 0.91

Code: Select all

==> 1,000000  216,799583  96,000000  (0)
XNVIEW restoreGeometry before : 640 480 
XNVIEW restoreGeometry after : 1366 768 
w.init
ThumbLoaderThread :: stop()
### ThumbLoaderThread :: stop() ok
ThumbLoaderThread :: stop()
### ThumbLoaderThread :: stop() ok
TIME  0  
ThumbLoaderThread :: stop()
### ThumbLoaderThread :: stop() ok
ThumbLoaderThread :: stop()
### ThumbLoaderThread :: stop() ok
w.start
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
QObject::connect: No such slot AbstractViewWindow::onPagePrevious()
##PB connect <1onPagePrevious()>
QObject::connect: No such slot AbstractViewWindow::onPageNext()
##PB connect <1onPageNext()>
QObject::connect: No such slot AbstractViewWindow::onPageFirst()
##PB connect <1onPageFirst()>
QObject::connect: No such slot AbstractViewWindow::onPageLast()
##PB connect <1onPageLast()>
QObject::connect: No such slot AbstractViewWindow::onNormalize2()
##PB connect <1onNormalize2()>
QObject::connect: No such slot AbstractViewWindow::onAlign()
##PB connect <1onAlign()>
MENU install : 263f940 
@@@@@@@@@@
Create window finished
==> 1366 
ThumbLoaderThread :: stop()
### ThumbLoaderThread :: stop() ok
MyView::change /home/juozas/Paveiksl?liai/fb7.png 
QObject::connect: No such slot BitmapLoadProgress::cancel()
## Bitmap :: load 0 
###### LOAD BITMAP </home/juozas/Paveikslėliai/fb7.png>
########################################
############### UPDATE MENU ############
########################################
### resetViewport (24519e0)  ==> 100 30  (42 30) 0 0
### ThumbLoaderThread :: setFileList(0)
### ThumbLoaderThread :: setFileList() wait
######ThumbLoaderThread :: run : 2666030 
######ThumbLoaderThread :: forever : 2666030 
 ** start condition wait
### ThumbLoaderThread :: setFileList() after wait
ThumbLoaderThread :: stop()
### ThumbLoaderThread :: stop() ok
 ** start condition wake one 2
### ThumbLoaderThread :: setFileList ok
######ThumbLoaderThread :: forever 2 : 2666030 
CHECK <0> 
######ThumbLoaderThread :: forever : 2666030 
 ** start condition wait
## OPEN FOLDER
  ## OPEN DB FOLDER ok
  ## UPDATE DB FOLDER ok
  ## OPEN FOLDER ok
## updateLabels
## updateLabels ok
ThumbLoaderThread :: stop()
### ThumbLoaderThread :: stop() ok
TIME  0  
## OPEN FOLDER done
setCurrentFilename </home/juozas/Paveiksl?liai/fb7.png>
LOAD INFO </home/juozas/Paveikslėliai/fb7.png>
10  IHDR 13 
29  pHYs 9 
3e  IDAT 65535 
10049  IDAT 65535 
20054  IDAT 65535 
3005f  IDAT 65535 
4006a  IDAT 65535 
50075  IDAT 65535 
60080  IDAT 18370 
ItemData :: update ==> fb7.png OK 
### ThumbLoaderThread :: setFirstItemToLoad
 ** start condition wake one 3
### ThumbLoaderThread :: setFirstItemToLoad ok
######ThumbLoaderThread :: forever 2 : 2666030 
CHECK <0> 
######ThumbLoaderThread :: forever : 2666030 
 ** start condition wait
## BaseViewWindow :: ~BaseViewWindow()
ThumbLoaderThread :: stop()
### ThumbLoaderThread :: stop() ok
ThumbLoaderThread :: stop()
### ThumbLoaderThread :: stop() ok
######ThumbLoaderThread :: run : 2666030 OK
QMutex: destroying locked mutex
## BaseViewWindow :: ~BaseViewWindow() ok
AbstractViewWindow :: ~AbstractViewWindow()
BitmapLoadThread :: stop()
Сделано в СССР

eptefal
Posts: 2
Joined: Thu Sep 13, 2018 6:57 pm

Re: 0.91: Open xnviewmp.exe with image file as argument doesn't work

Post by eptefal » Tue Sep 18, 2018 6:48 pm

xnview wrote:
Mon Sep 17, 2018 8:08 am
please try with this EXE
I have tried the new exe and just works perfect! :D
Win 10 Home
XnView MP Windows
Version 0.91.1 64bits (Sep 17 2018)
Libformat version 7.20

_Rayman_
Posts: 9
Joined: Thu Nov 30, 2017 10:53 pm

Re: 0.91: Open xnviewmp.exe with image file as argument doesn't work

Post by _Rayman_ » Tue Sep 18, 2018 9:29 pm

xnview wrote:
Mon Sep 17, 2018 8:08 am
please try with this EXE
Everything works as expected with this last EXE! (Win10x64 Prof) Thanks for fixing this!

Njbzh
Posts: 1
Joined: Wed Sep 19, 2018 4:52 am

Re: 0.91: Open xnviewmp.exe with image file as argument doesn't work

Post by Njbzh » Wed Sep 19, 2018 4:54 am

It's ok for me with this last exe, thanks for the fix ! (Win7X64)

Post Reply