Previewing video does not work when navigating with the cursor keys

*** Please report new bugs here! ***

Moderator: Dreamer

Post Reply
jon_joy_1999
Posts: 8
Joined: Wed Mar 16, 2011 1:40 am

Previewing video does not work when navigating with the cursor keys

Post by jon_joy_1999 » Thu Sep 13, 2018 4:19 am

Slightly similar to my previous bug report here: viewtopic.php?&t=34297, when moving through the folder icons list with the arrow keys, a video will not preview if it is at the "beginning" of a row of files. This is probably another hard to explain bug, so I've included some screenshots that show the issue. One notable exception is that the bug does not seem to happen if the file after the selected video is also a video.
Image
Image

User avatar
xnview
Author of XnView
Posts: 30014
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Previewing video does not work when navigating with the cursor keys

Post by xnview » Wed Sep 19, 2018 10:57 am

i can't reproduce, audio or video files? "At the beginning" you means in the visible items?
Pierre.

jon_joy_1999
Posts: 8
Joined: Wed Mar 16, 2011 1:40 am

Re: Previewing video does not work when navigating with the cursor keys

Post by jon_joy_1999 » Thu Sep 20, 2018 6:43 pm

I say "beginning" because the bug happens when going forward and when going backward.
If you consider the file list as a set of rows and columns of files, when I'm moving right and I get to the last file in a row, the next file is in the first column of the next row. If that file is a video/audio file, and the file following is not a video/audio file, then the file following is previewed instead of the video/audio file.
In the same manner, when I'm moving left, and I get to the first file in a row, the next file is in the last column of the previous row. If that file is a video/audio file, and the file following is not a video/audio file, then the file following is previewed instead of the video/audio file.

I have reproduced the bug with audio files as well, and updated this post to reflect.

I'm not sure what you mean by "visible items". If you mean with a "Filter by" applied (so if I'm Filtering by video) does it happen? No, that doesn't cause the bug to happen

Post Reply