Format colors are confused in the Browser

*** Please report new bugs here! ***

Moderator: Dreamer

Post Reply
User avatar
eliio
Posts: 31
Joined: Fri Jan 13, 2017 6:40 am
Location: Khimki
Contact:

Format colors are confused in the Browser

Post by eliio »

Hello,

PSD format color on some files is changed to default (see the screen attached). As you can see one PSD has the correct color, but the others have the default one.
XnView MP 0.93.1 on Win 10 x64.

Image
Best,
Elisei
User avatar
eliio
Posts: 31
Joined: Fri Jan 13, 2017 6:40 am
Location: Khimki
Contact:

Re: Format colors are confused in the Browser

Post by eliio »

Also "Select first item on entering folder" option doesn't always work.
Best,
Elisei
User avatar
xnview
Author of XnView
Posts: 33840
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Format colors are confused in the Browser

Post by xnview »

do you have the problem only with PSD?
Pierre.
User avatar
eliio
Posts: 31
Joined: Fri Jan 13, 2017 6:40 am
Location: Khimki
Contact:

Re: Format colors are confused in the Browser

Post by eliio »

I looked in that particular directory, also PNG have the default color despite the custom color in the settings.
Best,
Elisei
User avatar
xnview
Author of XnView
Posts: 33840
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Format colors are confused in the Browser

Post by xnview »

do you have changed the format colors setting?
Pierre.
User avatar
eliio
Posts: 31
Joined: Fri Jan 13, 2017 6:40 am
Location: Khimki
Contact:

Re: Format colors are confused in the Browser

Post by eliio »

Yes, I changed some format colors.
Best,
Elisei
User avatar
xnview
Author of XnView
Posts: 33840
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Format colors are confused in the Browser

Post by xnview »

could you send me the values in xnview.ini?
do you have same problem with default values?
Pierre.
User avatar
eliio
Posts: 31
Joined: Fri Jan 13, 2017 6:40 am
Location: Khimki
Contact:

Re: Format colors are confused in the Browser

Post by eliio »

I've attached the ini file (my old settings with custom colors).
To be sure I cleared XnView settings in "Roaming" and restarted the program. And it looks like the colors are good now.
See the screen:
Image
Attachments
xnview.zip
(5.49 KiB) Downloaded 20 times
Last edited by eliio on Sun Nov 17, 2019 2:19 am, edited 1 time in total.
Best,
Elisei
User avatar
eliio
Posts: 31
Joined: Fri Jan 13, 2017 6:40 am
Location: Khimki
Contact:

Re: Format colors are confused in the Browser

Post by eliio »

But when I got my old settings back the problem persists. Then I installed 0.94 but the colors are still wrong.
Best,
Elisei
User avatar
xnview
Author of XnView
Posts: 33840
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Format colors are confused in the Browser

Post by xnview »

eliio wrote: Sat Nov 16, 2019 3:06 am But when I got my old settings back the problem persists. Then I installed 0.94 but the colors are still wrong.
and if you change with a new settings, the format colors?
Pierre.
User avatar
eliio
Posts: 31
Joined: Fri Jan 13, 2017 6:40 am
Location: Khimki
Contact:

Re: Format colors are confused in the Browser

Post by eliio »

I think there was some problem with that particular directory, because I found no color mismatch with the others. Ultimately I changed the name of this directory (after exiting XnView) and then reread it. This time all the files had the right colors. Then I optimized the database and changed the name back. It's alright now.
Thank you.
Best,
Elisei
Post Reply