0.96.4: Not starting under Linux Mint 20. using qt5ct plugin Segmentation fault (core dumped)

*** Please report new bugs here! ***

Moderators: helmut, XnTriq, xnview, Dreamer

HansMuller
Posts: 1
Joined: Thu Jul 09, 2020 9:29 pm

0.96.4: Not starting under Linux Mint 20. using qt5ct plugin Segmentation fault (core dumped)

Post by HansMuller »

Hello,
when I start it (via command) the following message is displayed and xnviewmp does not work:

qt5ct: using qt5ct plugin
Segmentation fault (core dumped)

After deleteting the file "~/.config/qt5ct/qt5ct.conf" it works again but looks different (as then does VLC e.g)...

Regards
User avatar
winnylinny
Posts: 82
Joined: Fri Apr 17, 2020 5:35 pm

Re: 0.96.4: Not starting under Linux Mint 20. using qt5ct plugin Segmentation fault (core dumped)

Post by winnylinny »

I can confirm this too. It only happens if "gtk2" is selected under qt5ct.

In a terminal run the command qt5ct, then select any other style besides gtk2.

This is a messy workaround, since XnViewMP (or any Qt5-based applications) will not match the theme and colors of the rest of your desktop.
sjsepan
Posts: 3
Joined: Sun Jul 12, 2020 5:52 pm

Re: 0.96.4: Not starting under Linux Mint 20. using qt5ct plugin Segmentation fault (core dumped)

Post by sjsepan »

@ winnylinny, Thanks! I did not know about the qt5ct tool. Got me in.
sjsepan
ben_sa2000
Posts: 3
Joined: Sun May 17, 2009 4:31 pm

Re: 0.96.4: Not starting under Linux Mint 20. using qt5ct plugin Segmentation fault (core dumped)

Post by ben_sa2000 »

Some old version of libfreetype started getting shipped in 0.95.
libfreetype depends on libfontconfig, but since libfontconfig is not provided in the archive and the system , we need to remove this old libfreetype version so that Xnview uses the system newer libfreetype.

sudo rm /opt/XnView/lib/libfreetype.so

Tip from AUR Archlinux
Working perfectly