0.98.0: Hangs when myCloud (Swisscom) is running

*** Please report new bugs here! ***

Moderator: Dreamer

Post Reply
sternenatem
Posts: 8
Joined: Sun Jan 12, 2020 6:18 pm

0.98.0: Hangs when myCloud (Swisscom) is running

Post by sternenatem »

XnView MP 0.98.0 64 bit (tested from 0.90.0 up to 0.98.0)
OS: Windows 10 Pro 20H2 64 bit

"myCloud Desktop" (own free cloud sync application of my internet provider Swisscom, https://desktop.mycloud.ch) runs in the background. In XnView MP I try to switch to another directory in the file browser. This causes XnView MP to hang for some time ("no response" for a few seconds, half a minute or even longer). Further directory changes are unpredictable: sometimes normal, sometimes the same problem.

If I close "myCloud Desktop" this problem goes completely away and everything works as expected. I have also reported this in the Swisscom support forum because I think the culprit here is mainly "myCloud Desktop" and not XnView MP. Dropbox has no influence to XnView MP and Onedrive is uninstalled. I know this is a very specific problem which affects probably only me or very few people.

Effect: XnView MP hangs when changing directories

To reproduce:
1. Run "myCloud Desktop"
2. Run XnView MP and change a directory in the file browser
Actual behavior (bug): XnView MP hangs for some time

Expected behavior: Almost instantaneous directory changes
User avatar
xnview
Author of XnView
Posts: 34719
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.98.0: Hangs when myCloud (Swisscom) is running

Post by xnview »

you have it in all versions of XnView MP?
Pierre.
sternenatem
Posts: 8
Joined: Sun Jan 12, 2020 6:18 pm

Re: 0.98.0: Hangs when myCloud (Swisscom) is running

Post by sternenatem »

I had tested from Version 0.90.0 to 0.98.0 (0.91.0, 0.92.0 and so on). And I just tried version 0.79.0 and 0.69.0 but unfortunately with the same behaviour.
User avatar
xnview
Author of XnView
Posts: 34719
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.98.0: Hangs when myCloud (Swisscom) is running

Post by xnview »

sternenatem wrote: Mon Dec 28, 2020 10:39 am I had tested from Version 0.90.0 to 0.98.0 (0.91.0, 0.92.0 and so on). And I just tried version 0.79.0 and 0.69.0 but unfortunately with the same behaviour.
do you have a lot of files in this shared folder?
Pierre.
sternenatem
Posts: 8
Joined: Sun Jan 12, 2020 6:18 pm

Re: 0.98.0: Hangs when myCloud (Swisscom) is running

Post by sternenatem »

Sorry but it has nothing to do with shared or local files. It happens or it can happen in every directory, every folder and with any files or no files at all. Again, if myCloud Desktop runs in the background and I try to change into a different folder/directory inside XnView MP (for example: I click on any folder in the folder panel or on the "up" button in the browser itself), it hangs, locks up, freezes, stops responding or whatever you want to call it. I then have to wait for XnView MP to start responding again. After that it may hang again when I try to change into another folder or not. But for sure it happens again.

I can only imagine that XnView MP gets somehow disturbed by myCloud Desktop. Like an antivirus software that locks a file for scanning before one can access it. I have tried Process Explorer but I don’t know how to use it properly.

My English isn’t that great but I hope you understand what I want so say.
User avatar
xnview
Author of XnView
Posts: 34719
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.98.0: Hangs when myCloud (Swisscom) is running

Post by xnview »

could you try XnView Classic?
Pierre.
sternenatem
Posts: 8
Joined: Sun Jan 12, 2020 6:18 pm

Re: 0.98.0: Hangs when myCloud (Swisscom) is running

Post by sternenatem »

Thanks Pierre. I just tried XnView Classic and it works perfectly. The problem seems to exists only with XnView MP.
User avatar
xnview
Author of XnView
Posts: 34719
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.98.0: Hangs when myCloud (Swisscom) is running

Post by xnview »

sternenatem wrote: Wed Jan 06, 2021 1:31 pm Thanks Pierre. I just tried XnView Classic and it works perfectly. The problem seems to exists only with XnView MP.
not easy to know why
Pierre.
sternenatem
Posts: 8
Joined: Sun Jan 12, 2020 6:18 pm

Re: 0.98.0: Hangs when myCloud (Swisscom) is running

Post by sternenatem »

Ok, I have found the culprit. I was poking around with Process Explorer and found this (under "Threads"):

Code: Select all

ntdll.dll!ZwDelayExecution+0x14
KERNELBASE.dll!SleepEx+0x9e
clr.dll!LogHelp_TerminateOnAssert+0x763
clr.dll!LogHelp_NoGuiOnAssert+0x40f99
clr.dll!LogHelp_NoGuiOnAssert+0x410ad
[Managed to Unmanaged Transition]
C:\WINDOWS\Microsoft.Net\assembly\GAC_64\mscorlib\v4.0_4.0.0.0__b77a5c561934e089\mscorlib.dll!System.Threading.Thread.Sleep+0xb
C:\Program Files\myCloud Desktop\windows\DesktopClientOverlayIconHandler.net4.x64.dll!DesktopClientOverlayIconHandler.JavaRestClient.CheckDesktopClientPort+0x38
C:\Program Files\myCloud Desktop\windows\DesktopClientOverlayIconHandler.net4.x64.dll!<>c.<.cctor>b__3_0+0x21
C:\WINDOWS\Microsoft.Net\assembly\GAC_64\mscorlib\v4.0_4.0.0.0__b77a5c561934e089\mscorlib.dll!System.Threading.ExecutionContext.RunInternal+0x172
C:\WINDOWS\Microsoft.Net\assembly\GAC_64\mscorlib\v4.0_4.0.0.0__b77a5c561934e089\mscorlib.dll!System.Threading.ExecutionContext.Run+0x15
C:\WINDOWS\Microsoft.Net\assembly\GAC_64\mscorlib\v4.0_4.0.0.0__b77a5c561934e089\mscorlib.dll!System.Threading.ExecutionContext.Run+0x55
C:\WINDOWS\Microsoft.Net\assembly\GAC_64\mscorlib\v4.0_4.0.0.0__b77a5c561934e089\mscorlib.dll!System.Threading.ThreadHelper.ThreadStart+0x55
[Unmanaged to Managed Transition]
clr.dll!LogHelp_TerminateOnAssert+0x1b93
clr.dll!LogHelp_TerminateOnAssert+0x1aa4
clr.dll!LogHelp_TerminateOnAssert+0x2358
clr.dll!MetaDataGetDispenser+0x12a2f
clr.dll!LogHelp_TerminateOnAssert+0x2f50
clr.dll!LogHelp_TerminateOnAssert+0x2ec3
clr.dll!LogHelp_TerminateOnAssert+0x2e02
clr.dll!LogHelp_TerminateOnAssert+0x2fe7
clr.dll!MetaDataGetDispenser+0x12919
clr.dll!LogHelp_TerminateOnAssert+0x6835
KERNEL32.DLL!BaseThreadInitThunk+0x14
ntdll.dll!RtlUserThreadStart+0x21
There was the connection between XnView MP and myCloud Desktop:

Code: Select all

C:\Program Files\myCloud Desktop\windows\DesktopClientOverlayIconHandler.net4.x64.dll
I’ve tested it: If I quit myCloud Desktop, remove this dll file from its location and restart myCloud Desktop, the hangs in XnView MP are gone, no more problems at all.

This dll file seems to be necessary to draw file overlay icons which are used to show the file sync status (green checkmark, red cross, etc.). But only for third party applications like XnView MP or SpeedCommander (file browser that i use). In Windows Explorer these overlay icons show still up if I remove the dll file.

Another benefit of removing this dll file seems to be that my download folder opens now faster in Windows Explorer. Not true.

Dropbox’s overlay icons do not seem to affect XnView MP at all.

I am also in contact with the myCloud Desktop support.
Post Reply