Low systemload while creating thumbnails from HEIC

*** Please report new bugs here! ***

Moderators: helmut, XnTriq, xnview, Dreamer

Wandrer
Posts: 7
Joined: Thu Jul 22, 2021 4:18 pm

Low systemload while creating thumbnails from HEIC

Post by Wandrer »

With the last version the problem was fixed, with 1.0 64 Bit it resurfeaced.

Generating thumbnails from HEIC pictures is extremly slow.

System:
AMD Ryzen 7 5800X
32 GB RAM DDR4 3600MHz
NVM SSD PCI Express 3.0

The pictures are on the NVM SSD. The CPU load of the complete system does not go beyond 12%.
Priority is manually set to high.
RAM load ist around 5,3GB including Windows 11 Pro.
RAM for DB is at 8000MiB, but not used. SSD load is at a max of 2%.

So there is no way the system is the cause for the slo thumbnails, right? Theere has to be a software issue, as the problem was fixed in the last software version before 1.0 64 Bit.
Last edited by Wandrer on Thu Jun 02, 2022 1:29 pm, edited 1 time in total.
User avatar
xnview
Author of XnView
Posts: 37883
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Low Systemload while creating Thumbs

Post by xnview »

on jpeg? in 0.99.7 you have not same thing?
Pierre.
User avatar
masterjp
Posts: 275
Joined: Fri Feb 13, 2009 4:37 pm
Location: Duesseldorf, Germany

Re: Low Systemload while creating Thumbs

Post by masterjp »

On my computer the thumbnail creating process uses up to 2 cores.

You have an AMD CPU mit 8 cores. If you divide 100 % / 8, you will get 12,5 % for 1 core.
PC: Intel 8700k + Asus Z370-F + 16 GB RAM G.Skill
OS: Windows 10 Pro x64 (latest updates) | XN-View (latest stable version) |XnViewMP (latest stable version) | XnConvert (latest) | Adobe Photoshop Elements 2022 & Elements XXL 9
Wandrer
Posts: 7
Joined: Thu Jul 22, 2021 4:18 pm

Re: Low Systemload while creating Thumbs

Post by Wandrer »

Oh i fortgot something, will add this later to the original post. On HEIC.

How come a MP version of the app as in multi processor can only use 2 logical processors? Isn't this kinda wrong?

In 0.99.7 i used the plugin for HEIC from this forum. This plugin does not work anymore with 1.0.
User avatar
xnview
Author of XnView
Posts: 37883
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Low Systemload while creating Thumbs

Post by xnview »

Wandrer wrote: Thu Jun 02, 2022 1:28 pm In 0.99.7 i used the plugin for HEIC from this forum. This plugin does not work anymore with 1.0.
you need to use 0.99.7 to test
Pierre.
User avatar
masterjp
Posts: 275
Joined: Fri Feb 13, 2009 4:37 pm
Location: Duesseldorf, Germany

Re: Low Systemload while creating Thumbs from HEIC

Post by masterjp »

The heif plugin from this forum

viewtopic.php?f=82&t=36661&p=172880&hil ... in#p172880

is older than the version which is bundled with the XnviewMP Setup or zip file!
Do not use it!
Check the setup file on this official site and install it:
https://www.xnview.com/de/xnviewmp/#downloads
PC: Intel 8700k + Asus Z370-F + 16 GB RAM G.Skill
OS: Windows 10 Pro x64 (latest updates) | XN-View (latest stable version) |XnViewMP (latest stable version) | XnConvert (latest) | Adobe Photoshop Elements 2022 & Elements XXL 9
Wandrer
Posts: 7
Joined: Thu Jul 22, 2021 4:18 pm

Re: Low Systemload while creating Thumbs from HEIC

Post by Wandrer »

I rolled back to the bundles version, that's why i know it's slower.

The plugin version does does not work at all.