v1.00 - Minor GUI issue with abort button

Older bugs which are supposed to be fixed in 0.84. *** Please try to reproduce your bug and confirm the bug fix. ***

Moderators: XnTriq, helmut, xnview, Dreamer

appyface
Posts: 31
Joined: Thu Sep 15, 2011 12:23 am

v1.00 - Minor GUI issue with abort button

Post by appyface »

XnViewMP v1.00 64-bit portable on Win10.

Minor GUI issue. The abort button on the popup search box does not work. Clicking red X in upper right does.

To reproduce:
1. Issue Ctrl-F from the browser to bring up search box
2. Click 'abort' button
User avatar
helmut
Moderator
Posts: 8682
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: v1.00 - Minor GUI issue with abort button

Post by helmut »

Thank you for your problem report, appyface. From what I can see there is some misunderstanding: "Abort" means that search that is currently running is aborted/stopped. This works fine for me. If you want to both abort search and close the search dialog you have to use system menu "[X]".

But:
When aborting, in the log it says "Finished." which is not quite true - it should say "Aborted", "Stopped by user", or similar. :bug:
When starting next search, it says Finished: 8 file(s) found... from the previous search. I.e. this label is not reset when search is started. :bug:
appyface
Posts: 31
Joined: Thu Sep 15, 2011 12:23 am

Re: v1.00 - Minor GUI issue with abort button

Post by appyface »

OK fair enough, it operates a little different than I expected. My experience with OK and Cancel (or equivalent names - search and abort, for example) will exit a pop-up and no need to use the 'X'. If this deviates from that "standard" (if that's what you can call it) that's fine. Thanks for the reply.
User avatar
xnview
Author of XnView
Posts: 38704
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: v1.00 - Minor GUI issue with abort button

Post by xnview »

:bugconfirmed: Thanks to your detailed description I can reproduce the problem.
Pierre.
User avatar
xnview
Author of XnView
Posts: 38704
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: v1.00 - Minor GUI issue with abort button

Post by xnview »

This problem is supposed to be fixed in XnView MP 1.01. Please check and confirm the bug fix here.
Pierre.