PNG doesn't save new XMP metadata

Older bugs which are supposed to be fixed in 0.84. *** Please try to reproduce your bug and confirm the bug fix. ***

Moderators: XnTriq, helmut, xnview, Dreamer

erty
Posts: 6
Joined: Tue Apr 11, 2017 1:03 am

PNG doesn't save new XMP metadata

Post by erty »

When you try to add XMP metadata for PNG files nothing is saved:
how to reproduce:
1. open PNG with no metadata
2. try to add some xmp fields (I tested with title and author)
3. push apply or write, open dialog again and you will see empty fields
4. same if you try save as new png file with different name. nothing is writed

but if you try to change metadata in files with already existed metadata everything will write correctly
and if you export jpeg to png, xmp persisted too

XnViewMP 1.3.1
Windows 11 22H2 x64
You do not have the required permissions to view the files attached to this post.
User avatar
xnview
Author of XnView
Posts: 39392
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: PNG doesn't save new XMP metadata

Post by xnview »

i can't reproduce, you use 'Edit XMP' from browser right?
Pierre.
Kadet
Posts: 11
Joined: Thu Oct 20, 2022 7:23 pm

Re: PNG doesn't save new XMP metadata

Post by Kadet »

1. Open XnView
2. From Browser open test.png
3. Edit XMP and add autor, title...
4. Click Apply
5. Click again Edit XMP or save file as test2.png
---> No XMP info was written.

And now, after save test2.png if You Edit XMP this file from Browser, add something and click save --> test2.png disappears from Browser (but not from folder and XMP are saved).

Bug is only after start XnView.
User avatar
xnview
Author of XnView
Posts: 39392
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: PNG doesn't save new XMP metadata

Post by xnview »

:bugconfirmed: Thanks to your detailed description I can reproduce the problem.
Pierre.
User avatar
xnview
Author of XnView
Posts: 39392
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: PNG doesn't save new XMP metadata

Post by xnview »

This problem is supposed to be fixed in XnView MP 1.4.0. Please check and confirm the bug fix here.
Pierre.