1.4.3 64bits, Libformat version 7.138: Edited Pic not saved

*** Please report new bugs here! ***

Moderators: XnTriq, helmut, xnview, Dreamer

Tamaleus
Posts: 15
Joined: Fri Jan 28, 2022 10:25 pm

1.4.3 64bits, Libformat version 7.138: Edited Pic not saved

Post by Tamaleus »

Subject: 1.4.3, 64bits, Libformat version 7.138: <Edited Pic not saved>

XnView: MP 1.4.3 - 64 bit
OS: Windows 10 - 64bit

<After having made so Changes to Image (.jpg) File/Image is *NOT* saved, when "Saving as ...">

Effect: <File cannot be found, although it has been saved as ... and given different/new Filename>

To reproduce:
01. Info about XnView MP
02. Open Image-File (see Screenshots, BTW: Stated Max is 8, however only 7 accepted!)
03. Cut out of certain Part of Image
04. Turn it by -0.40
05. Cut out one more Time
06. Change Size to max Height of 800
07. Thereafter trying to "Speichern unter ..." (Save as ...)
08. Selecting Directory and giving new/different Filename
09. "Speichern" (confirming "Save")
10. Warning-Message: Attention. On Saving File in this Format Comment and all available Metadata shall be lost. (?) On a JPG? Why?
Needs to be confirmed twice.
11. More Screenshots showing Properties etc.
12. However File cannot be found, neither in chosen Directory, nor elsewhere on DiscDrives, incl. NAS

If I do an EXPORT of the edited File, this is "saved" an can be found in indicated Directory.

Actual behaviour (bug): <File cannot be saved with Saving-Function "Speicher unter..." (Save as...)>

Expected behaviour: <Should be saved>.

Hope, I did not make a mistake.
You do not have the required permissions to view the files attached to this post.
User avatar
xnview
Author of XnView
Posts: 43988
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: 1.4.3 64bits, Libformat version 7.138: Edited Pic not saved

Post by xnview »

could you send me the file used? Which format do you use in 'save as'?
Pierre.
Tamaleus
Posts: 15
Joined: Fri Jan 28, 2022 10:25 pm

Re: 1.4.3 64bits, Libformat version 7.138: Edited Pic not saved

Post by Tamaleus »

Hi Pierre
File I was working on, is JPG. And I "Save(d) as ..." JPG as well.
Probably due to huge Size of orig File, I could not attach here. Thats why I make Upload on https://www.swisstransfer.com/de-ch, to your Mail-Addy contact@xnview.com (You should get advising Mail). Hope, this works for you, Otherwise do not hesitate to let me know. Have a nice Dayè Martin
You do not have the required permissions to view the files attached to this post.
User avatar
xnview
Author of XnView
Posts: 43988
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: 1.4.3 64bits, Libformat version 7.138: Edited Pic not saved

Post by xnview »

Thanks for the file, i can't reproduce the problem.
You use 'JPEG /JFIF' and not 'Guetzli JPEG'?
Pierre.
Tamaleus
Posts: 15
Joined: Fri Jan 28, 2022 10:25 pm

Re: 1.4.3 64bits, Libformat version 7.138: Edited Pic not saved

Post by Tamaleus »

Tks a lot anyway. I'll tray avoiding the "Guetzli" ;-)
Have a nice Weekend!
Greets, Martin
Tamaleus
Posts: 15
Joined: Fri Jan 28, 2022 10:25 pm

Re: 1.4.3 64bits, Libformat version 7.138: Edited Pic not saved

Post by Tamaleus »

Hi Pierre

This is just to confirm, when saving as "JPG", it works as expected ;-)

However, your special kind of sorting Extensions (with very common ones at the top) confused me a lot. How about a Dash like "===" after the Specials ones, to make it more "obvious"!? And/or to indicate the "normal" JPG AGAIN down there where it is to be expected in alpha order!? Just suggesting.

And/or: Why to offer "Guetzli", if it does not work anyway?

But besides that: Super Tool! Go on with it! Thumb up!
cday
XnThusiast
Posts: 4044
Joined: Sun Apr 29, 2012 9:45 am
Location: Cheltenham, U.K.

Re: 1.4.3 64bits, Libformat version 7.138: Edited Pic not saved

Post by cday »

Tamaleus wrote: Sun Mar 05, 2023 12:29 pm Hi Pierre

This is just to confirm, when saving as "JPG", it works as expected ;-)
Tamaleus wrote: Sun Mar 05, 2023 12:29 pmHowever, your special kind of sorting Extensions (with very common ones at the top) confused me a lot. How about a Dash like "===" after the Specials ones, to make it more "obvious"!? And/or to indicate the "normal" JPG AGAIN down there where it is to be expected in alpha order!? Just suggesting.
Showing certain formats at the the top of the list is an option: Tools > Settings > General > Formats -- Saving tab -- Show most used format at beginning.

I don't see a way of customising the list if the option is active although I thought there might be one. I also wonder if formats displayed at the top should also be displayed in their normal alphabetical place, to avoid the confusion you refer to. Note also that the list can be filtered if required to reduce the number of formats displayed.

Tamaleus wrote: Sun Mar 05, 2023 12:29 pmWhy to offer "Guetzli", if it does not work anyway?
It does work, but was only ever intended to reduce the download size of small images on web pages. I have recently suggested that a warning be displayed when saving to Guetzli, with a 'Do not show again' option.