Import & Sort: Wrong Video subfolder

Bugs which are supposed to be fixed in the next test version (not available yet)

Moderators: XnTriq, helmut, xnview, Dreamer

User avatar
m.Th.
XnThusiast
Posts: 1671
Joined: Wed Aug 16, 2006 6:31 am

Import & Sort: Wrong Video subfolder

Post by m.Th. »

In the Import&Sort dialog the Video subfolder is processed even if it is disabled.

Steps to reproduce:

0. Open the Import and Sort dialog
1. Enter Source, Destination and Photos (sub)folders of your choice
2. Click on „Videos” checkbox.
3. Enter a (video) Subfolder of your choice.
4. Run the dialog. The videos should be imported in the subfolder specified at step 3.
5. Uncheck „Videos” checkbox from step 2.
6. Run the dialog again

Expected: the videos should go to Destination\Photos subfolder specified at step 1.

Actual: the videos are still going in the Videos subfolder specified at step 3.
m. Th.

- Dark Themed XnViewMP 1.7.1 64bit on Win11 x64 -
User avatar
xnview
Author of XnView
Posts: 43995
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Import & Sort: Wrong Video subfolder

Post by xnview »

it works here, which settings do you use? mp4 in source folder?
Pierre.
User avatar
m.Th.
XnThusiast
Posts: 1671
Joined: Wed Aug 16, 2006 6:31 am

Re: Import & Sort: Wrong Video subfolder

Post by m.Th. »

xnview wrote: Mon May 13, 2024 7:48 am it works here, which settings do you use? mp4 in source folder?
Yes, it is mp4 in source folder (on my card).

The settings are as follows:
Captură de ecran 2024-06-12 100311.png
Since „Videos” checkbox is disabled, I expect to have the videos also in the destination folder.

I can reproduce it at will, - I enable „Videos”, I change the videos subfolder to „Video folder 1”, I disable „Videos” checkbox (again) and the engine still saves the videos in „Video folder 1” - which it shouldn't.
You do not have the required permissions to view the files attached to this post.
m. Th.

- Dark Themed XnViewMP 1.7.1 64bit on Win11 x64 -
User avatar
xnview
Author of XnView
Posts: 43995
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Import & Sort: Wrong Video subfolder

Post by xnview »

:bugconfirmed: Thanks to your detailed description I can reproduce the problem.
Pierre.