Files in subfolder not found when search is filtered by category

*** Please report new bugs here! ***

Moderators: XnTriq, helmut, xnview, Dreamer

tom82
Posts: 1
Joined: Wed Jun 12, 2024 4:52 am

Files in subfolder not found when search is filtered by category

Post by tom82 »

Hi,

Thanks so much for putting this piece of software together.

I have one issue. I need to search for files where a category has not been assigned, so I can see what files are left to categorise.

When I do the search, the files that are in subfolders are not found UNLESS I manually click in those folders BEFORE I perform the search. It is like the search does not know they are here unless the user displays them on screen. I have hundreds of sub-folder so it won't be practical. Plus I am worried I will create a new folder and forget about it.

Any chance you can fix this ?

Enclosed are :
- my search criteria
- results before I click on on the sub-folder
- results after I click
You do not have the required permissions to view the files attached to this post.
User avatar
xnview
Author of XnView
Posts: 44030
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Files in subfolder not found when search is filtered by category

Post by xnview »

yes it's normal, 'category' field is the category written in catalog
Pierre.
User avatar
michel038
XnThusiast
Posts: 1313
Joined: Tue Sep 27, 2016 8:18 am
Location: France

Re: Files in subfolder not found when search is filtered by category

Post by michel038 »

It's working for me ...
My settings are nearly the same as yours ("Include folders" not ticked)
Search criteria : Categories contains (no category selected in drop down list) ... I think it means : contains nothing ...

Another way is to choose "uncategorized" in the "catalog filter" tab
(after selecting your settings in the "match" menu at the top of the catalog filter area )
inl
Posts: 2
Joined: Sun Jun 30, 2024 3:50 pm

Re: Files in subfolder not found when search is filtered by category

Post by inl »

Hello,
I have a similar problem.
Two updates ago, the search worked very well. Suddenly, nothing works anymore. My photos are assigned to categories. Despite this, the search for categories always comes up without results or only the wrong folders are specified. The photos I am looking for are not displayed directly, as before. What do I have to do? Am I doing something wrong in the settings?

Thank you for your help.
You do not have the required permissions to view the files attached to this post.
User avatar
xnview
Author of XnView
Posts: 44030
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Files in subfolder not found when search is filtered by category

Post by xnview »

inl wrote: Thu Jul 04, 2024 6:01 pm only the wrong folders are specified.
how that??
Do you have tried an older version?
Pierre.
inl
Posts: 2
Joined: Sun Jun 30, 2024 3:50 pm

Re: Files in subfolder not found when search is filtered by category

Post by inl »

I am working in the latest version 1.7.2 on mac sonoma. In older versions of xn view mp the search function worked without problems. What can i do?
User avatar
xnview
Author of XnView
Posts: 44030
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Files in subfolder not found when search is filtered by category

Post by xnview »

inl wrote: Sun Jul 07, 2024 6:25 pm I am working in the latest version 1.7.2 on mac sonoma. In older versions of xn view mp the search function worked without problems. What can i do?
So it works only when you browse the subfolders, right? 'Use catalog' is checked, are you use that files are already in catalog?
Pierre.