1.96 - Title bar showing when viewing pictures in fullscreen

Feedback and Comments on the new 1.96 Test version on Windows.

Moderator: XnTriq

pupusk
Posts: 3
Joined: Wed Feb 25, 2009 5:52 am

1.96 - Title bar showing when viewing pictures in fullscreen

Post by pupusk » Wed Feb 25, 2009 6:02 am

Hi,

this has bugged me for a while and I was hoping it would be fixed for 1.96 but it wasn't. So I'm reporting it now if anyone else hasn't noticed it.

This happens at least when you have two displays, and the secondary display is set to be on top of the primary one.

If you view a picture in full screen on the primary display (the bottom one), XnView shows the picture but also shows the title bar (which says XnView, picture name and shows non-functioning minimize/maximize/close -buttons).

If I move XnView to the secondary display, the one on top of the primary, and view a picture in fullscreen, it shows perfectly, no extra title bar =)

User avatar
xnview
Author of XnView
Posts: 30214
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 1.96 - Title bar showing when viewing pictures in fullsc

Post by xnview » Wed Feb 25, 2009 8:39 am

You have the bottom bar of windows when using fullscreen???? On Xp?
Pierre.

pupusk
Posts: 3
Joined: Wed Feb 25, 2009 5:52 am

Post by pupusk » Wed Feb 25, 2009 10:23 am

I'm using 64bit vista, had the same problem on 32bit xp if I remember right. The bottom bar or the menu bar aren't visible, only the title. And I forgot to mention that this doesn't happen on small pictures, my resolution is 1920*1200.
If I open a picture that is for example 2048*1536, with zoom at 100%, then click the middle button to view and fit it to fullscreen, the title bar stays visible.

If i rotate the same picture, so that it's 1536*2048, and then view it in full screen, there is no title bar, and it works perfectly

User avatar
xnview
Author of XnView
Posts: 30214
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Post by xnview » Wed Feb 25, 2009 12:27 pm

pupusk wrote:I'm using 64bit vista, had the same problem on 32bit xp if I remember right. The bottom bar or the menu bar aren't visible, only the title. And I forgot to mention that this doesn't happen on small pictures, my resolution is 1920*1200.
If I open a picture that is for example 2048*1536, with zoom at 100%, then click the middle button to view and fit it to fullscreen, the title bar stays visible.
Oh ok, i understand. Strange, i can't reproduce this problem...
Pierre.

pupusk
Posts: 3
Joined: Wed Feb 25, 2009 5:52 am

Post by pupusk » Wed Feb 25, 2009 5:27 pm

Weird, I tried deleting my .ini -file (shared settings for all users, .ini-file stored in XnView:s folder), and that helped... all images are displayed correctly in fullscreen now :o

I'll continue testing to see if I can reproduce the problem with a new .ini -file :)

Locked