MP 0.21 Win - Shortcuts not applied in View mode only

Bugs and Suggestions in XnView MP or XnConvert MP which have been resolved.

Moderator: XnTriq

User avatar
Dreamer
XnThusiast
Posts: 4605
Joined: Sun Jul 25, 2004 9:08 pm
Location: Slovakia

MP 0.21 Win - Shortcuts not applied in View mode only

Post by Dreamer » Fri Oct 09, 2009 11:14 pm

- change any shortcut in View mode (settings > interface > shortcuts)
- press OK
- re-open settings dialog
= changed shortcut is reverted to previous value :bug:

Changes in Browser mode are applied correctly.

Some shortcuts in View mode are set to "none", some to "custom". I tried to delete the default.keys file, but it's still the same - and it's strange that browser mode is still working, where the changes are saved?? ... OK in Roaming folder. :| I have changed it to XnView folder, but it's still the same.
Dreamer

User avatar
xnview
Author of XnView
Posts: 33336
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: MP 0.21 Win - Shortcuts not applied in View mode only

Post by xnview » Mon Nov 16, 2009 1:18 pm

Dreamer wrote:- change any shortcut in View mode (settings > interface > shortcuts)
- press OK
- re-open settings dialog
= changed shortcut is reverted to previous value :bug:
Right
Some shortcuts in View mode are set to "none", some to "custom". I tried to delete the default.keys file, but it's still the same - and it's strange that browser mode is still working, where the changes are saved?? ... OK in Roaming folder. :| I have changed it to XnView folder, but it's still the same.
The file is stored in the profile. And if you use "Defaults"?
Pierre.

User avatar
Dreamer
XnThusiast
Posts: 4605
Joined: Sun Jul 25, 2004 9:08 pm
Location: Slovakia

Re: MP 0.21 Win - Shortcuts not applied in View mode only

Post by Dreamer » Tue Nov 17, 2009 1:14 am

xnview wrote:
Dreamer wrote:Some shortcuts in View mode are set to "none", some to "custom". I tried to delete the default.keys file, but it's still the same - and it's strange that browser mode is still working, where the changes are saved?? ... OK in Roaming folder. :| I have changed it to XnView folder, but it's still the same.
The file is stored in the profile. And if you use "Defaults"?
If you mean "defaults" button, then it's still the same after restart. :|
Dreamer

User avatar
xnview
Author of XnView
Posts: 33336
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: MP 0.21 Win - Shortcuts not applied in View mode only

Post by xnview » Tue Nov 17, 2009 7:32 am

Dreamer wrote:If you mean "defaults" button, then it's still the same after restart. :|
You are not all shortcuts after clicking "defaults" button?
Pierre.

User avatar
Dreamer
XnThusiast
Posts: 4605
Joined: Sun Jul 25, 2004 9:08 pm
Location: Slovakia

Re: MP 0.21 Win - Shortcuts not applied in View mode only

Post by Dreamer » Tue Nov 17, 2009 11:38 pm

No, "Defaults" button doesn't work good here.

For example, "Open" has a custom shortcut (Ctrl+O), when I press the "Defaults" button, it's changed to "Default" and it's removed, but after XnView restart it's again "Custom" - Ctrl+O. It looks it's saved somewhere else.. Perhaps it's related with the other problem (in this topic).
Dreamer

User avatar
xnview
Author of XnView
Posts: 33336
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: MP 0.21 Win - Shortcuts not applied in View mode only

Post by xnview » Wed Nov 18, 2009 7:40 am

Dreamer wrote:For example, "Open" has a custom shortcut (Ctrl+O), when I press the "Defaults" button, it's changed to "Default" and it's removed, but after XnView restart it's again "Custom" - Ctrl+O. It looks it's saved somewhere else.. Perhaps it's related with the other problem (in this topic).
I can't reproduce, could you try by removing the .keys files?
Pierre.

User avatar
Dreamer
XnThusiast
Posts: 4605
Joined: Sun Jul 25, 2004 9:08 pm
Location: Slovakia

Re: MP 0.21 Win - Shortcuts not applied in View mode only

Post by Dreamer » Thu Nov 19, 2009 2:01 am

OK, removing default.keys file in Roaming folder helped, but there must be something wrong if that button didn't work, but perhaps it's the same issue.
Dreamer

User avatar
xnview
Author of XnView
Posts: 33336
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: MP 0.21 Win - Shortcuts not applied in View mode only

Post by xnview » Tue Mar 16, 2010 8:23 pm

Please, could you test XnViewMP 0.25
Pierre.

User avatar
Dreamer
XnThusiast
Posts: 4605
Joined: Sun Jul 25, 2004 9:08 pm
Location: Slovakia

Re: MP 0.21 Win - Shortcuts not applied in View mode only

Post by Dreamer » Sat Apr 03, 2010 12:04 am

Still not fixed in 0.26.1, I tried to delete default.keys file, ini file...
Dreamer

User avatar
xnview
Author of XnView
Posts: 33336
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: MP 0.21 Win - Shortcuts not applied in View mode only

Post by xnview » Tue Jul 20, 2010 12:22 pm

Dreamer wrote:Still not fixed in 0.26.1, I tried to delete default.keys file, ini file...
could you tell me how to reproduce? Which shortcut do you change?
Pierre.

User avatar
Dreamer
XnThusiast
Posts: 4605
Joined: Sun Jul 25, 2004 9:08 pm
Location: Slovakia

Re: MP 0.21 Win - Shortcuts not applied in View mode only

Post by Dreamer » Fri Jul 23, 2010 10:27 pm

Any shortcut in view mode. The shortcut column is empty, when I set any shortcut, press OK, restart XnView, it's empty again. When I change any shortcut in browser mode, it preserved.
Dreamer

User avatar
xnview
Author of XnView
Posts: 33336
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: MP 0.21 Win - Shortcuts not applied in View mode only

Post by xnview » Mon Jul 26, 2010 11:05 am

Dreamer wrote:Any shortcut in view mode. The shortcut column is empty, when I set any shortcut, press OK, restart XnView, it's empty again. When I change any shortcut in browser mode, it preserved.
But the shortcut column is not empty by default?????
Pierre.

User avatar
Dreamer
XnThusiast
Posts: 4605
Joined: Sun Jul 25, 2004 9:08 pm
Location: Slovakia

Re: MP 0.21 Win - Shortcuts not applied in View mode only

Post by Dreamer » Thu Jul 29, 2010 9:58 pm

OK, I tried to delete the default.keys file, then the shortcut column is not empty, but after 1 restart, when the new default.keys file is created, the shortcut column in view mode is empty again.

I tried to save the shortcuts to a new file, but the shortcut column in view mode is empty after 1 restart.
Dreamer

uly
Posts: 5
Joined: Wed Aug 18, 2010 9:57 am

Re: MP 0.21 Win - Shortcuts not applied in View mode only

Post by uly » Wed Aug 18, 2010 10:01 am

I'm getting exactly the same bug on 0.26.1, running on Win 7 x64.

User avatar
xnview
Author of XnView
Posts: 33336
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: MP 0.21 Win - Shortcuts not applied in View mode only

Post by xnview » Fri Oct 15, 2010 9:25 am

Please check XnViewMP 0.30
Pierre.

Post Reply