0.39 win-x86: Possible sinister Startup crash BUG

Bugs and Suggestions in XnView MP or XnConvert MP which have been resolved.

Moderators: helmut, XnTriq, xnview

User avatar
budz45
XnThusiast
Posts: 1598
Joined: Sun Jun 03, 2007 6:05 pm
Location: UK

0.39 win-x86: Possible sinister Startup crash BUG

Post by budz45 »

Hi,

to reproduce:

1.) download & extract a clean XnView MP 0.39 (x86)
2.) Create an 'xnview.ini' in the same extracted program folder(s)
3.) Make sure there is no Database file in default user app folder
4.) Drag & drop an image file to the xnview.exe (or I used an icon file(s) ICO or ICNS)
5.) Program opens with a brief first-time 'wait' (normal behaviour)...
6.) ...Now quickly do some multiple fast left-clicking on the interface during this 'wait'
7.) APP CRASH!!

Right, I think this is a probable 'Fullscreen' bug or 'Browser' command interference.

Furthermore, continuing from above steps
1.) After that App Crash
2.) Drag & drop the same file to xnview.exe
3.) Image file will open in fullscreen (with no program crash on multiple left-click)
4.) While in Image fullscreen....
5.) ...Now double-click on image to go to 'Browser' (still in fullscreen)
6.) User is now perpetually STUCK in Fullscreen 'Browser' - with no escape :evil:

Here is the very file I did the test with (Vista aero wallpaper):
wallpaper JPG.zip
tested Win 7 x86
You do not have the required permissions to view the files attached to this post.
All My Topics || my 'MP' Topics
My own Bookmarked topics--->for me only
User avatar
budz45
XnThusiast
Posts: 1598
Joined: Sun Jun 03, 2007 6:05 pm
Location: UK

Re: 0.39 win-x86: Possible sinister Startup crash BUG

Post by budz45 »

Thank you. Fixed in XnViewMP 0.50 :)
All My Topics || my 'MP' Topics
My own Bookmarked topics--->for me only