[Fixed] FullScreen: Doesn't sync with thumbnails

Bugs and Suggestions in XnView MP or XnConvert MP which have been resolved.

Moderator: XnTriq

Erixx haxx
Posts: 330
Joined: Tue Jul 28, 2015 10:37 am

[Fixed] FullScreen: Doesn't sync with thumbnails

Post by Erixx haxx » Wed Jul 27, 2016 8:49 am

Hi:

While inside Fullscreen. The thumbnails on the top don't stay in sync with the image being viewed.

This makes for harder navigation and keeping track of where you are.





Win7x64 pro
XnviewMP v0.79 - 0.82 B3 x64
Last edited by Erixx haxx on Wed Feb 22, 2017 2:03 am, edited 1 time in total.

User avatar
xnview
Author of XnView
Posts: 31733
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: FullScreen: Doesn't sync with thumbnails

Post by xnview » Mon Aug 15, 2016 2:23 pm

how to reproduce the problem?
Pierre.

Erixx haxx
Posts: 330
Joined: Tue Jul 28, 2015 10:37 am

Re: FullScreen: Doesn't sync with thumbnails

Post by Erixx haxx » Tue Aug 16, 2016 12:54 pm

just open image file in fullscrenn from MP browser
Scroll through images to 3 or 4th image
The image bar on the top stays at #1 or #2 image

Edit: Also mouse scroll is set, go to next image
The first 1 or 2 seem to stay synced, but after that they loose sync
Last edited by Erixx haxx on Tue Aug 16, 2016 1:42 pm, edited 1 time in total.

User avatar
xnview
Author of XnView
Posts: 31733
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: FullScreen: Doesn't sync with thumbnails

Post by xnview » Tue Aug 16, 2016 1:27 pm

i start XnViewMP, select an image, press F11, press 'Next file' 6 times, and show the little thumbnails bar. The good thumbnail is selected...
Pierre.

Erixx haxx
Posts: 330
Joined: Tue Jul 28, 2015 10:37 am

Re: FullScreen: Doesn't sync with thumbnails

Post by Erixx haxx » Tue Aug 16, 2016 1:29 pm

xnview wrote:i start XnViewMP, select an image, press F11, press 'Next file' 6 times, and show the little thumbnails bar. The good thumbnail is selected...
Can you try with mouse scroll as (next image)
Also edited my post above
First few do stay synced, its after them.. 3,4 and up

User avatar
xnview
Author of XnView
Posts: 31733
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: FullScreen: Doesn't sync with thumbnails

Post by xnview » Tue Aug 16, 2016 2:04 pm

i can't reproduce even with mouse wheel. the thumbnails view is locked?
Pierre.

Erixx haxx
Posts: 330
Joined: Tue Jul 28, 2015 10:37 am

Re: FullScreen: Doesn't sync with thumbnails

Post by Erixx haxx » Tue Aug 16, 2016 2:23 pm

xnview wrote:i can't reproduce even with mouse wheel. the thumbnails view is locked?
Seems to happen after 3 or 4 scrolls (images), also is much worse than this, sometimes picture viewed is not even in site of the bar at all. ( like stuck at #1 ) also how would ctr+t work here. Also tried with 0.82 b4, same issue..
Attachments
XnViewMP V0.81 0001.jpg
FullScreen Not in sync. v0.81x64

User avatar
XnTriq
Moderator & Librarian
Posts: 5445
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: FullScreen: Doesn't sync with thumbnails

Post by XnTriq » Tue Aug 16, 2016 7:00 pm

  1. Select a thumbnail in the browser.
  2. Hit F11 to enter fullscreen.
  3. Move the mouse cursor to the top of the screen to make the “filmstrip” navigation appear.
  4. Deactivate Auto hide for the filmstrip navigation.
  5. Move the mouse cursor to the right of the screen to make the info pane appear.
  6. Deactivate Auto hide for the info pane.
  7. Hit I to display the overlay info.
  8. Make sure the pane with the opened image has the focus.
I'm able to move to the previous/next image with the mouse wheel (up/down), the arrow keys (left/right), and the translucent navigation toolbar at the bottom of the screen.
The info pane does sync. Same goes for the overlay info.
The only way I can make the selected thumbnail in the filmstrip navigation sync is to scroll the mouse wheel very fast :bugconfirmed:

User avatar
xnview
Author of XnView
Posts: 31733
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: FullScreen: Doesn't sync with thumbnails

Post by xnview » Mon Aug 22, 2016 1:09 pm

XnTriq wrote:The only way I can make the selected thumbnail in the filmstrip navigation sync is to scroll the mouse wheel very fast :bugconfirmed:
sync or not sync?
Pierre.

User avatar
xnview
Author of XnView
Posts: 31733
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: FullScreen: Doesn't sync with thumbnails

Post by xnview » Mon Aug 22, 2016 1:09 pm

Erixx haxx wrote:
xnview wrote:i can't reproduce even with mouse wheel. the thumbnails view is locked?
Seems to happen after 3 or 4 scrolls (images), also is much worse than this, sometimes picture viewed is not even in site of the bar at all. ( like stuck at #1 ) also how would ctr+t work here. Also tried with 0.82 b4, same issue..
please send me the images used to try to reproduce...
Pierre.

User avatar
XnTriq
Moderator & Librarian
Posts: 5445
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: FullScreen: Doesn't sync with thumbnails

Post by XnTriq » Mon Aug 22, 2016 10:00 pm

xnview wrote:sync or not sync?
I've done more tests with a new INI. Now everything works as expected, no matter how fast I move the mouse wheel :?
  • Mouse cursor hovering over the filmstrip navigation pane:
    Spinning the mouse wheel makes the horizontal scrollbar below the thumbnails move.
  • Mouse cursor hovering over the view pane:
    Spinning the mouse wheel makes MP move to the next/previous thumbnail and file. Selected thumbnail in the navigation pane and displayed image in the view pane stay in sync.

Erixx haxx
Posts: 330
Joined: Tue Jul 28, 2015 10:37 am

Re: FullScreen: Doesn't sync with thumbnails

Post by Erixx haxx » Tue Aug 23, 2016 10:30 am

Hi guys:

Well I tried as XnTriq, to force a new .ini file. Now all that gives me is as Xntriq was getting when he tested.
"Files only stay in sync when I scroll really fast"

I've tried several new .ini files. All the same result. Only setting I'm changing is the switching mode.
This happens with all files, in all different directories, so I think that rules out files.

This is a deff. bug, i'm starting to think maybe its a Qt bug and a (Mouse sensitivity setting) or maybe wireless mouse. Since scroll speed is a factor.

---Or maybe the mouse scroll wheel is confused because the slider on the thumb-bar goes sideways, and regular scrolling is for up/down...
Newer mice have a side scroll function.

win7x64pro
v0.81x64 port

User avatar
xnview
Author of XnView
Posts: 31733
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: FullScreen: Doesn't sync with thumbnails

Post by xnview » Tue Aug 23, 2016 12:22 pm

the focus is on filmstrip or image view?
Pierre.

Erixx haxx
Posts: 330
Joined: Tue Jul 28, 2015 10:37 am

Re: FullScreen: Doesn't sync with thumbnails

Post by Erixx haxx » Tue Aug 23, 2016 4:13 pm

xnview wrote:the focus is on filmstrip or image view?
--The focus is on the image. If I un-hide the filmstrip I can watch it jump 1 file, then it sticks at said thumb, as the viewer pics keep changing. The slider nor Thumb highlighter move.
The info box and embeded info does change, like Xntriq pointed out above. --Only the thumb-bar isn't moving.

--With focus on the filmstrip the slider and pictures scroll correct..


If you want me to upload video clip, I can probally make one for you so you can see better.
I know you can't do anything until you can reproduce it yourself.

Things I Tried:
-New .ini -x5 or more
-New .db files
-New vresions,
v0.79
v0.81
v0.82 B4 All with their own cfg files and .db's

User avatar
xnview
Author of XnView
Posts: 31733
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: FullScreen: Doesn't sync with thumbnails

Post by xnview » Wed Aug 24, 2016 1:25 pm

i'm able to reproduce the problem with big picture file if i scroll quickly...
Pierre.

Post Reply