Focus stealing problem when running in the background with "delete original" enabled..

XnConvert Multi Platform - Windows, MacOSX, Linux
Post Reply
Jou
Posts: 51
Joined: Sat Nov 03, 2007 9:38 pm
Contact:

Focus stealing problem when running in the background with "delete original" enabled..

Post by Jou » Sat May 11, 2019 8:38 am

currently I am fighting xnconvert while it constantly steals my focus while doing a job in the background.
See this video: https://youtu.be/etLiotll1hI
The settings are: Convert to bmp to jpg and delete the original after conversion.

One could argue that this is the 30+ years old "focus stealing" problem of Windows, Mcaintosh and various unix/linux desktops. But here xnconvert helps ;).

Please ignore all typos, I am creating that post while it still converts in the background and steals m keyboard...
Gaming in 4k / 6k / 8k / 15k? Yes! http://joumxyzptlk.de

User avatar
xnview
Author of XnView
Posts: 33205
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Focus stealing problem when running in the background with "delete original" enabled..

Post by xnview » Mon May 20, 2019 2:25 pm

lastest version? Windows 10?
Pierre.

poser1999
Posts: 1
Joined: Wed Mar 18, 2020 5:18 am

Re: Focus stealing problem when running in the background with "delete original" enabled..

Post by poser1999 » Wed Mar 18, 2020 5:31 am

xnview wrote:
Mon May 20, 2019 2:25 pm
lastest version? Windows 10?
Hello,

I did not start this thread, but I've been having the same problem, with both XnViewMP and XnConvert. I'm running Windows 10 and in addition to the constantly flashing (focus-stealing) window, the other issue is that every couple of seconds, the Windows default "removing files" dialog pops up, whenever the program deletes the original pictures after conversion.

For some reason, I do not recall this being a problem with either XnConvert or XnViewMp in the past -- at least the file delete dialog constantly popping up and disappearing. I'm not sure when this started happening and what caused it -- but it's been well over a year, or two (or more?).

Is there anything that can be done about this? Is this a configuration (corruption?) in Windows, perhaps?

User avatar
xnview
Author of XnView
Posts: 33205
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Focus stealing problem when running in the background with "delete original" enabled..

Post by xnview » Sat Mar 21, 2020 2:48 pm

poser1999 wrote:
Wed Mar 18, 2020 5:31 am
Is there anything that can be done about this? Is this a configuration (corruption?) in Windows, perhaps?
I can't reproduce on windows 10. Which settings do you use?
Pierre.

resakator
Posts: 1
Joined: Wed Apr 22, 2020 11:45 am

Re: Focus stealing problem when running in the background with "delete original" enabled..

Post by resakator » Wed Apr 22, 2020 1:00 pm

Here same problem.
I'm using Windows 10 1909 64bit, XnConvert 1.83 64bit.
Configuration is:
Image

Updated 25/04/2020: with version 1.85 it still happens.

User avatar
xnview
Author of XnView
Posts: 33205
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Focus stealing problem when running in the background with "delete original" enabled..

Post by xnview » Tue Apr 28, 2020 1:23 pm

resakator wrote:
Wed Apr 22, 2020 1:00 pm
Updated 25/04/2020: with version 1.85 it still happens.
and what's happened?
Pierre.

Post Reply