XnRetro

More Multi Platform Tools - Windows, MacOSX, Linux
Post Reply
avpco
Posts: 4
Joined: Sun Nov 26, 2017 11:18 am
Location: Saint-Petersburg
Contact:

XnRetro

Post by avpco » Sun Nov 26, 2017 11:23 am

Hello.

I can't start ./xnretro.sh because I got error meggage: error while loading shared libraries: libgio-2.0.so.0: cannot open shared object file: No such file or directory

What program I need to install for start XnRetro (Ubuntu 16.04 x64) ?
Thank's in advance!

User avatar
xnview
Author of XnView
Posts: 31881
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: XnRetro

Post by xnview » Sun Nov 26, 2017 2:57 pm

do you have installed x86 libraries?
Pierre.

avpco
Posts: 4
Joined: Sun Nov 26, 2017 11:18 am
Location: Saint-Petersburg
Contact:

Re: XnRetro

Post by avpco » Sun Nov 26, 2017 6:30 pm

How can I know this? I'm a beginner user :(

User avatar
xnview
Author of XnView
Posts: 31881
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: XnRetro

Post by xnview » Mon Nov 27, 2017 7:44 am

please check this post
Pierre.

avpco
Posts: 4
Joined: Sun Nov 26, 2017 11:18 am
Location: Saint-Petersburg
Contact:

Re: XnRetro

Post by avpco » Mon Nov 27, 2017 9:36 am

Thanks, Pierre.
I'll try it at everning.

avpco
Posts: 4
Joined: Sun Nov 26, 2017 11:18 am
Location: Saint-Petersburg
Contact:

Re: XnRetro

Post by avpco » Mon Nov 27, 2017 5:17 pm

these packages are already installed.
where else can the error be contained?

dannyw
Posts: 1
Joined: Sat Mar 31, 2018 11:31 am

Re: XnRetro

Post by dannyw » Sat Mar 31, 2018 11:35 am

I was able to get it working on ubuntu 16.04 by doing this:

Code: Select all

sudo apt install libglib2.0-0:i386
sudo apt install libgstreamer-plugins:i386 # <-- Not sure if this one is required
sudo apt install gstreamer0.10-plugins-base:i386

scx
Posts: 10
Joined: Sun Mar 03, 2019 3:59 pm

Re: XnRetro

Post by scx » Sat Mar 09, 2019 7:31 pm

avpco wrote:
Sun Nov 26, 2017 11:23 am
Hello.

I can't start ./xnretro.sh because I got error meggage: error while loading shared libraries: libgio-2.0.so.0: cannot open shared object file: No such file or directory

What program I need to install for start XnRetro (Ubuntu 16.04 x64) ?
Thank's in advance!
I have created flatpak packages for XnView MP, XnConvert, XnSketch and XnRetro.
viewtopic.php?f=79&t=33329&&start=0&p=155029#p155029
viewtopic.php?f=79&t=33329&&start=15&p=155203#p155203

All of these packages should appear on Flathub soon.

Post Reply