Order of columns in Browser (maybe a bug)

Ask for help and post your question on how to use XnView MP.

Moderators: XnTriq, xnview

Post Reply
PP0815
Posts: 31
Joined: Wed Mar 26, 2014 10:47 am

Order of columns in Browser (maybe a bug)

Post by PP0815 » Mon Mar 23, 2020 7:48 pm

Hi,
first of all this:
System: Win7
current XnViewMP version:0.96 64bit zipped (ini is in Program folder)

I just updated to 0.96 comming from 0.89. I didn't copy the database & thumbnail but let the program create it's new by right clicking on the driveletter with my images and choose (recursive) so all imagedata is read.
I use the detail view in browser and all columns (No, Name, size etc.)
I let the progam work (creating the new db)
After I came back to the PC I realized that the No. column was not the first column but the second. First was Name.
The problem now is that I am not able to move the No. column (or any other column) to the first position. I also can't move the Name column away from it's first position.

Since I still had the 0.89 folder I opened this version and the order was correct. I made a copy of the xnview.ini, started the program again, played with the size and order of the columns, closed the program and then compared the 2 xnview.ini.

I realized different lines in section [Browser] and [Format]
The line (header) in [Browser] is cryptic and I can't figure what means what but it seem to be the place where the setting of the columns is stored.

Can someone help me figure out how this line work (or another way to change the position of the columns)?

Thanks

PP0815
Posts: 31
Joined: Wed Mar 26, 2014 10:47 am

Re: Order of columns in Browser (maybe a bug)

Post by PP0815 » Mon Mar 23, 2020 8:23 pm

Ok, I just copied (overwrite) the header line in the 0.96 version with the 0.89 version and now the No column is on first position.
Nonetheless it would be good to be able to simply drag&drop the first column within the program.

thanks

User avatar
xnview
Author of XnView
Posts: 32737
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Order of columns in Browser (maybe a bug)

Post by xnview » Wed Mar 25, 2020 12:44 pm

your problem is fixed?
Pierre.

PP0815
Posts: 31
Joined: Wed Mar 26, 2014 10:47 am

Re: Order of columns in Browser (maybe a bug)

Post by PP0815 » Wed Mar 25, 2020 1:21 pm

I would call it 'workaround' cause I've tried to move the first column with another instance of xnviewMP in another folder and it isn't possible. Any other column is movable to any position but the first.

User avatar
michel038
Posts: 436
Joined: Tue Sep 27, 2016 8:18 am
Location: France
Contact:

Re: Order of columns in Browser (maybe a bug)

Post by michel038 » Wed Mar 25, 2020 1:25 pm

Ok, I just copied (overwrite) the header line in the 0.96 version with the 0.89 version
How did you do that ?

PP0815
Posts: 31
Joined: Wed Mar 26, 2014 10:47 am

Re: Order of columns in Browser (maybe a bug)

Post by PP0815 » Thu Mar 26, 2020 8:56 pm

michel038 wrote:
Wed Mar 25, 2020 1:25 pm
Ok, I just copied (overwrite) the header line in the 0.96 version with the 0.89 version
How did you do that ?
I opened both .ini files in a texteditor (notepad++) and simply copied the mentioned line from the old version to the new version and saved it.

Post Reply