Import Rating and Colour Label

Ask for help and post your question on how to use XnView MP.

Moderators: XnTriq, xnview

Post Reply
toralf
Posts: 22
Joined: Sun Apr 06, 2014 1:39 am
Location: US

Import Rating and Colour Label

Post by toralf » Mon Apr 07, 2014 3:03 am

How can the Rating and Colour Label be imported from a file, if the data is in the XMP?

toralf
ciao
toralf

XnViewMP v0.64 64bit on Win8.1

User avatar
xnview
Author of XnView
Posts: 32739
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Import Rating and Colour Label

Post by xnview » Mon Apr 07, 2014 9:55 am

It's automatic
Pierre.

toralf
Posts: 22
Joined: Sun Apr 06, 2014 1:39 am
Location: US

Re: Import Rating and Colour Label

Post by toralf » Mon Apr 07, 2014 2:07 pm

Thank you Pierre,

I tried it several times, but it doesn't always do it automatically after a Batch Convert with "keep metadata".
The properties showed that the XMP metadata was maintained. But the rating, color label or category wasn't actively set (consistently).
A rebuild db from files solved the problem.
Above I wrote consistently, because when I tried to duplicate it today it partially did it, but not all the time. I'll continue to try to reproduce it.

ciao
toralf
ciao
toralf

XnViewMP v0.64 64bit on Win8.1

User avatar
m.Th.
XnThusiast
Posts: 1583
Joined: Wed Aug 16, 2006 6:31 am
Contact:

Re: Import Rating and Colour Label

Post by m.Th. » Tue Apr 08, 2014 5:55 am

toralf wrote:Thank you Pierre,

I tried it several times, but it doesn't always do it automatically after a Batch Convert with "keep metadata".
The properties showed that the XMP metadata was maintained. But the rating, color label or category wasn't actively set (consistently).
A rebuild db from files solved the problem.
Above I wrote consistently, because when I tried to duplicate it today it partially did it, but not all the time. I'll continue to try to reproduce it.

ciao
toralf
Generally it should work. However keep an eye to:

- different file types in the case of embedded metadata
- different sources (eg. from Lightroom, from ASP etc.) for XMP sidecars
- also for sidecars have a look at different encoding(s) (locale, UTF-8 etc.)

Good luck!
m. Th.

The Ascetic Experience - The best photos and texts from Holy Mountain (Athos)

- Dark Themed XnViewMP 0.90 64bit & XnView 2.00 x64 on Win7 x64 -

hic
Posts: 29
Joined: Thu Feb 27, 2014 2:55 pm

Re: Import Rating and Colour Label

Post by hic » Tue Apr 08, 2014 11:20 am

It seems indeed that XnViewMP reads xmp-files but doesn't show the results. I attach a picture. It was made after building a new databas from files. You can see on the left site that the picture is chosen correctly by category (here "Tiere | sonstiges"). But the thumbnail doesn't show the yellow flag for tagged file, and on the right you can see that the corresponding categories are not marked. It occurs only for those files that doesn't have embedded metadata but sidecar xmp files.
Screen-2014-04-08_13-11-2.jpg

User avatar
m.Th.
XnThusiast
Posts: 1583
Joined: Wed Aug 16, 2006 6:31 am
Contact:

Re: Import Rating and Colour Label

Post by m.Th. » Tue Apr 08, 2014 4:24 pm

hic wrote:It seems indeed that XnViewMP reads xmp-files but doesn't show the results. I attach a picture. It was made after building a new databas from files. You can see on the left site that the picture is chosen correctly by category (here "Tiere | sonstiges"). But the thumbnail doesn't show the yellow flag for tagged file, and on the right you can see that the corresponding categories are not marked. It occurs only for those files that doesn't have embedded metadata but sidecar xmp files.
Screen-2014-04-08_13-11-2.jpg
Please try the other filters: Color & Rate/Star. They behave the same?

Also if you force a refresh (go to another folder and back) the problem persists?
m. Th.

The Ascetic Experience - The best photos and texts from Holy Mountain (Athos)

- Dark Themed XnViewMP 0.90 64bit & XnView 2.00 x64 on Win7 x64 -

hic
Posts: 29
Joined: Thu Feb 27, 2014 2:55 pm

Re: Import Rating and Colour Label

Post by hic » Wed Apr 09, 2014 8:35 am

Even worse. If I now update files from database, the xmp info for keywords, ratings and colour are completely reset in the sidecar.

hic.

User avatar
xnview
Author of XnView
Posts: 32739
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Import Rating and Colour Label

Post by xnview » Mon Apr 14, 2014 12:36 pm

hic wrote:It seems indeed that XnViewMP reads xmp-files but doesn't show the results. I attach a picture. It was made after building a new databas from files. You can see on the left site that the picture is chosen correctly by category (here "Tiere | sonstiges"). But the thumbnail doesn't show the yellow flag for tagged file, and on the right you can see that the corresponding categories are not marked. It occurs only for those files that doesn't have embedded metadata but sidecar xmp files.
couldyou send me your file+sidecar?
Pierre.

Post Reply