browser trouble selecting using arrow keys

Ask for help and post your question on how to use XnView MP.

Moderators: XnTriq, xnview

Post Reply
shadowpower
Posts: 17
Joined: Sun Oct 13, 2013 3:16 am

browser trouble selecting using arrow keys

Post by shadowpower » Wed Nov 26, 2014 12:56 am

Ok, so I normally use arrow keys + shift when selecting multiple files in the browser but for some reason it's different from xnview , when you reach the last column and press right arrow + shift you get one thumbnail deselected, see images:
Image Image Image Image
I'm not sure whether it's a bug, an option or intentional. is there a way to change it so that the thumbnail at the last column gets selected?

quapurna
Posts: 129
Joined: Wed Jun 12, 2013 4:55 pm
Location: earth (the not-flat one)

Re: browser trouble selecting using arrow keys

Post by quapurna » Fri Nov 28, 2014 7:39 am

Hi.
If you posted the fifth image, you could show us that a strange behaviour exists.
If you also select the second column, the last column will be selected too.

Until it is fixed (assuming that it is a bug), you can move forward the RightKey to also select the second column, then move backward (shift+LeftKey) to unselect it; the image in the last column is still selected.

Thanks.

shadowpower
Posts: 17
Joined: Sun Oct 13, 2013 3:16 am

Re: browser trouble selecting using arrow keys

Post by shadowpower » Fri Nov 28, 2014 9:59 am

ah yes, I know about that trick moving to right then left however sometimes you can't do it if the last image is on the first column.
Focusing in the selection problem I forgot that the image displayed in the browser isn't correct when you try to select the 5th image which I'm pretty sure is a bug.
Image
All I did here is select the first image then press 4 times right arrow while holding shift. You can see the image in the browser corresponds to the 3rd image while it should show the 5th image, because it was the last one selected.
As far as I have tested the deselection (bug?) only happens if you use right arrow at the last column, if you tried to do it at the first column using the left arrow it doesn't deselect a thumbnail.
If you select an image on the last column hold shift then press right arrow then left arrow you end up with 2 images selected (1 if you do it on a different column) then if you press left arrow again you end up with 2 images selected (same as if you do it on a different column)

Post Reply