Linux requirements, installers for non-top-recent distros

Ask for help and post your question on how to use XnView MP.

Moderators: XnTriq, xnview

wwp
Posts: 45
Joined: Sun Jan 03, 2016 2:37 pm
Location: Montpellier/France

Linux requirements, installers for non-top-recent distros

Post by wwp » Sun Jan 03, 2016 3:13 pm

Hi there,

as far as I could see, XnViewMP 0.76.1 requires glibcxx_3.4.15/glibc, which means it can be installed on pretty recent distros only (AFAIK: CentOS7, Ubuntu 12.04, Debian 8), this excludes former production long-term support (LTS) ones. The website isn't clear about the software requirements to run this product on Linux, IIRC it doesn't say anything at all about it.

I'd like to run it on a CentOS6 (the RH6-equivalent free edition), is there either an older version of the product that runs on such system, or any plan to provide packages for 'older' distros? Or even a way to get the sources to compile them and provide (officially supported or not) RPM packages for RH6-like (note that I could afford the effort for this, I'm used to Qt5, C++ and RPM installers)?

User avatar
oops66
XnThusiast
Posts: 1999
Joined: Tue Jul 17, 2007 1:17 am
Location: France

Re: Linux requirements, installers for non-top-recent distro

Post by oops66 » Sun Jan 03, 2016 7:15 pm

Hi wwp,
... Right, XnViewMP 0.76.1 cannot be easily installed on not pretty recent distros ... and this is annoying for me too.
So maybe a solution can be find?
XnViewMP 0.82 Linux X64 - Ubuntu 16.04 LTS - X64

User avatar
xnview
Author of XnView
Posts: 33425
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Linux requirements, installers for non-top-recent distro

Post by xnview » Mon Jan 04, 2016 8:21 am

Pierre.

wwp
Posts: 45
Joined: Sun Jan 03, 2016 2:37 pm
Location: Montpellier/France

Re: Linux requirements, installers for non-top-recent distro

Post by wwp » Mon Jan 04, 2016 9:12 am

Hi Pierre!

I gunzip'ed this 64-bit beta version on top of an installed 0.76.1 release, it doesn't fix it. What is it supposed to change, BTW? The expected changes would affect all Qt5 .so and binary files, not only the XnView one.

# sh xnview.sh
/opt/XnView/XnView: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by /opt/XnView/XnView)
/opt/XnView/XnView: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by /opt/XnView/XnView)
/opt/XnView/XnView: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /opt/XnView/XnView)
/opt/XnView/XnView: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by /opt/XnView/lib/libQt5WebKit.so.5)

It seems that you compiled XnView with an even more recent gcc version (with a dep to libstdc++ 3.4.20 instead of 3.4.15) and that's where the issue resides.

With the original XnView binary, I get:
/opt/XnView/XnView: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by /opt/XnView/XnView)
/opt/XnView/XnView: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /opt/XnView/XnView)
/opt/XnView/XnView: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by /opt/XnView/lib/libQt5WebKit.so.5)

Feel free to ask for testing, your product is very attracting to me, and I'm willing to be involved as a contributor if you wish.
Last edited by wwp on Mon Jan 04, 2016 9:28 am, edited 1 time in total.

User avatar
xnview
Author of XnView
Posts: 33425
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Linux requirements, installers for non-top-recent distro

Post by xnview » Mon Jan 04, 2016 9:16 am

right, i build on ubuntu 12.04. so i need to check QT5 on CentOS6...
Pierre.

wwp
Posts: 45
Joined: Sun Jan 03, 2016 2:37 pm
Location: Montpellier/France

Re: Linux requirements, installers for non-top-recent distro

Post by wwp » Mon Jan 04, 2016 9:33 am

Indeed!
The EPEL repository, quite a standard one for expanding a CentOS6 to more modern software, proposes Qt5 (5.5.1), which is the latest available at this time from Digia. Compiling your C++ code with Qt 5.5.x, if you come from Qt 5.4.x, might need only very few and minor changes, depending on the code quality and the API you use, AFAIK.

FYI:
http://www.rackspace.com/knowledge_cent ... nd-red-hat

User avatar
xnview
Author of XnView
Posts: 33425
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Linux requirements, installers for non-top-recent distro

Post by xnview » Mon Jan 04, 2016 12:34 pm

please try this version
Pierre.

wwp
Posts: 45
Joined: Sun Jan 03, 2016 2:37 pm
Location: Montpellier/France

Re: Linux requirements, installers for non-top-recent distro

Post by wwp » Mon Jan 04, 2016 3:01 pm

Pierre, it works ;-).

I had to install Qt5 libs from EPEL repository using yum on my CentOS6 x64 system, and set QT_PLUGIN_PATH to /usr/lib64/qt5/plugins in my environment, et voila.

Nice (and fast) work, man!

User avatar
xnview
Author of XnView
Posts: 33425
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Linux requirements, installers for non-top-recent distro

Post by xnview » Mon Jan 04, 2016 3:10 pm

ok, great :)
Pierre.

wwp
Posts: 45
Joined: Sun Jan 03, 2016 2:37 pm
Location: Montpellier/France

Re: Linux requirements, installers for non-top-recent distro

Post by wwp » Mon Jan 04, 2016 3:13 pm

Yes that's great, now I can use it from Linux, my favourite work environment.
I'll test it intensively and report any issue. Feel free to request for more.

wwp
Posts: 45
Joined: Sun Jan 03, 2016 2:37 pm
Location: Montpellier/France

Re: Linux requirements, installers for non-top-recent distro

Post by wwp » Mon Jan 04, 2016 7:06 pm

Pierre, I've been playing w/ this CentOS6 beta version.. couldn't find anything wrong yet BUT the deletion of folders, which doesn't work at all.

I don't know if the issue is specific to this version or general to Linux versions.

Whatever if I delete a folder from the file list view or from the folders list view, the folder is removed from the *view*, but it's still present in the filesystem. Next time I'll re-open xnview, it will show it again (or if I press F5 in the file list view only, F5 in the folder list view doesn't bring it back, amazingly).

It doesn't seem to be related to the settings "Use Recycle Bin", because it behaves the same whatever this option is cheched or not.

User avatar
xnview
Author of XnView
Posts: 33425
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Linux requirements, installers for non-top-recent distro

Post by xnview » Mon Jan 04, 2016 7:43 pm

any folder?
Pierre.

wwp
Posts: 45
Joined: Sun Jan 03, 2016 2:37 pm
Location: Montpellier/France

Re: Linux requirements, installers for non-top-recent distro

Post by wwp » Mon Jan 04, 2016 7:49 pm

Well, as far as I could see, any folder that I have permissions to erase (and can erase from another software). Empty or not. I see no error in stdout/stderr.

wwp
Posts: 45
Joined: Sun Jan 03, 2016 2:37 pm
Location: Montpellier/France

Re: Linux requirements, installers for non-top-recent distro

Post by wwp » Tue Jan 05, 2016 8:51 am

Oh, BTW, renaming a folder doesn't work either. The item name changes in folder tree, but when I look at the filesystem from a console, the folder still has its old name.

User avatar
xnview
Author of XnView
Posts: 33425
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Linux requirements, installers for non-top-recent distro

Post by xnview » Tue Jan 05, 2016 8:54 am

wwp wrote:Oh, BTW, renaming a folder doesn't work either. The item name changes in folder tree, but when I look at the filesystem from a console, the folder still has its old name.
and in thumbnail list?
Pierre.

Post Reply