MP 0.76.1 very slow

Ask for help and post your question on how to use XnView MP.

Moderators: XnTriq, xnview

josedumoretzsohn
Posts: 33
Joined: Fri Sep 25, 2009 11:13 am

MP 0.76.1 very slow

Post by josedumoretzsohn »

For the first time, XNviewMP (now 0.76.1) is very slow to load miniatures, and it often locks down for a few seconds, locking out any other further command; not just inside the application, but even unabling prompt access do the desktop screen. In both configurations, enabling or disabling Cache. If I go back to 0.72 this problem disappears. What am I doing wrong?
Erixx haxx
Posts: 330
Joined: Tue Jul 28, 2015 10:37 am

Re: MP 0.76.1 very slow

Post by Erixx haxx »

josedumoretzsohn wrote:For the first time, XNviewMP (now 0.76.1) is very slow to load miniatures,
Do you mean thumbnails
enabling or disabling Cache
You really should enable cache
1.)Enabled = Fast access to folders already scanned by xnviewmp. "First time depends on file size ect..."
2.)Disabled = xnviewmp needs to rescan and build thumbs for folders each time you enter.

Only time i see this happen is when entering an external hdd. "it takes time to wake it up. ("Details view" is usually faster than "Thumbs view" or "Thumbs+labels")
Other things we don't know:
1.) O.S ??
2.) File types, sizes, folder sizes, ect...??
3.) Placement of .db and cache files ??
4.) is your setup and settings same as when 0.72 was installed ??
josedumoretzsohn
Posts: 33
Joined: Fri Sep 25, 2009 11:13 am

Re: MP 0.76.1 very slow

Post by josedumoretzsohn »

Yes, I mean "thumbnails".
O.S.: Windows 7, SP 2
Configuration: equal to 0.72
Placement of .db and cache files: Thumb.db and Xnview.db: C:\Program Files (x86)\XnViewMP and C:\Users\user\AppData\Roaming\XnViewMP

As for "View", I need "Thumbnails + description". which I use.

Steps I took after having read your reply: 1) expanded databank from 100 MB to 400MB (actual size of photos' folder: 366Mb); 2) disabled "labels"

P.S.: XN View is still very very fast, even disabling cache.
User avatar
xnview
Author of XnView
Posts: 34093
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: MP 0.76.1 very slow

Post by xnview »

XnView MP 0.76 is slower than 0.72 in 'Thumbnails + labels' with same configuration?
XnView MP 0.72 is slower than XnView Classic?

how many files do you have? only images?
do you have tried to rename .db files?
Pierre.
Mixer
Posts: 166
Joined: Fri Aug 28, 2015 6:24 am

Re: MP 0.76.1 very slow

Post by Mixer »

josedumoretzsohn wrote:O.S.: Windows 7, SP 2
SP2 for windows 7 does not exist. http://windows.microsoft.com/en-us/wind ... ptabs=win7
Users on nonexistent platforms. This must be some haunted forum. I believe I even saw picture of digital ghost somewhere around.
Erixx haxx
Posts: 330
Joined: Tue Jul 28, 2015 10:37 am

Re: MP 0.76.1 very slow

Post by Erixx haxx »

If This is on a local drive then i would:

Try dev's sollution

1.) Check # of files your trying to scan
2.) Are These only Photo's

"i've had problems with video files being bad" This will usually hang other software trying to access them too, while creating thumbs.
Videos will load slower also, unless cached
josedumoretzsohn
Posts: 33
Joined: Fri Sep 25, 2009 11:13 am

Re: MP 0.76.1 very slow

Post by josedumoretzsohn »

Re: MP 0.76.1 very slow

by xnview » Tue Jan 26, 2016 1:58 pm
1) XnView MP 0.76 is slower than 0.72 in 'Thumbnails + labels' with same configuration?
2) XnView MP 0.72 is slower than XnView Classic?
3) how many files do you have? only images?
4) do you have tried to rename .db files?
Pierre.

1) Under any configuration. I need to use "Thumbnails + Description"
2) No, same "fast" speed. (immediate openings)
3) I have 4000 thumbnails and about 40.000 images (only images, although not many other files' (.doc, .txt, .htm., .xld, .sbs) icons are shown. (HDD 1 Tb, 6GB RAM). Total size of folder: ca. 380 Mb.
4) No, I have not renamed .db files. Will it help speed?

Note: This slowness has never existed until MP 0.72. (The program does not respond to any command; it often locks even a mouse command to desktop; delay is about one minute.)

To Mixer: You are right, Win 7 SP2 does not exist. I took Office 2010 SP2 for it.
Erixx haxx
Posts: 330
Joined: Tue Jul 28, 2015 10:37 am

Re: MP 0.76.1 very slow

Post by Erixx haxx »

No, I have not renamed .db files. Will it help speed?
If you have important info on .db file than make a backup before trying anything below..

Rename the .db file to OEM.db or simular
This will force xnviewmp to create a new .db file in case yours is corrupt for some reason. 'You will loose all your keywords unless their embeded."
The first scan might be slower but after, then should be back to normal. I would use a clean cache also.

If this does not help then rename your original back to the original name and delete the new file created.

Other than this i'm out of options. Maybe try also a portable version with default settings in another location and see if it is different.
User avatar
xnview
Author of XnView
Posts: 34093
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: MP 0.76.1 very slow

Post by xnview »

josedumoretzsohn wrote: Note: This slowness has never existed until MP 0.72. (The program does not respond to any command; it often locks even a mouse command to desktop; delay is about one minute.)
it's very strange, nobody have this problem... Please try to rename your .db files
Pierre.
josedumoretzsohn
Posts: 33
Joined: Fri Sep 25, 2009 11:13 am

Re: MP 0.76.1 very slow

Post by josedumoretzsohn »

" it's very strange, nobody have this problem... Please try to rename your .db files
Pierre. "

Will I loose my "Comments" ? I have ca. 330 files with them.
User avatar
xnview
Author of XnView
Posts: 34093
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: MP 0.76.1 very slow

Post by xnview »

josedumoretzsohn wrote: Will I loose my "Comments" ? I have ca. 330 files with them.
comment made with 'edit description/comment'??
Rename only the 2 .db files, if database is not the problem you'll restore them after...
Pierre.
josedumoretzsohn
Posts: 33
Joined: Fri Sep 25, 2009 11:13 am

Re: MP 0.76.1 very slow

Post by josedumoretzsohn »

All of a sudden, when I opened Xn and XnMP this evening, XnMP worked as fast and perfectly as before, even with Cache disabled.
I think that happened because, last night, before closing, I deleted all the folders enlisted in the Catalogue (German "Katalog") tab in Options, which I thought would partly correspond to your instruction to rename .db files (what I feared would delete "Comments" too. And, yes, I operate it with "Edit Description/Comment", although in XNview Classic.).

In "IPTC-XMP" tab, I also disabled "Import XMP/IPTC" and "Export DB to XMP". (I don't have the slightest idea whether that has to do with MP speed's actual recovery. I just disabled them because I thought those items were not relevant for my type of work. Anyway...)

So much so, I think, because the first thing I noticed when I opened MP today was that the icons bars had returned to Default, which led me right now to the process of rebuilding them, both in Folder and View modes. But the regular fast speed is back, fortunately.

Thank you very much for your instructions.
josedumoretzsohn
Posts: 33
Joined: Fri Sep 25, 2009 11:13 am

Re: MP 0.76.1 very slow

Post by josedumoretzsohn »

Some additions, perhaps relevant to MP speed's recovery:

In System Integration/Directories (Folders), I had also changed Catalogue, Data Bank and Other, from Default positions to Customized (German: Angepasst)

Again, thank you.
josedumoretzsohn
Posts: 33
Joined: Fri Sep 25, 2009 11:13 am

Re: MP 0.76.1 very slow

Post by josedumoretzsohn »

A last addition: Where I wrote previously "I operate it with "Edit Description/Comment", although in XNview Classic.)"

please read "No, I insert Comment in XNview Classic, through Edit/Edit Comment..."

Thank you.
User avatar
xnview
Author of XnView
Posts: 34093
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: MP 0.76.1 very slow

Post by xnview »

now it's no more slow??
Pierre.
Post Reply