Profiles: Option '-ini' in XnView MP?

Older bugs which are supposed to be fixed in 0.84. *** Please try to reproduce your bug and confirm the bug fix. ***

Moderator: Dreamer

obelisk
Posts: 400
Joined: Fri Jan 09, 2009 9:54 am

Profiles: Option '-ini' in XnView MP?

Post by obelisk » Thu Oct 06, 2016 4:22 am

What's the MP equivalent to

"C:\Program Files (x86)\XnView\xnview.exe" -ini D:\alt.ini

It seems to just overwrite back to
<...>\Roaming\XnViewMP\xnview.ini

obelisk
Posts: 400
Joined: Fri Jan 09, 2009 9:54 am

Re: Profiles

Post by obelisk » Thu Oct 06, 2016 4:43 am

I even made 2 shortcuts with -ini
still everything is stuffed around, written to wrong ini, settings not saved, etc

User avatar
xnview
Author of XnView
Posts: 31175
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Profiles: Option '-ini' in XnView MP?

Post by xnview » Sat Oct 08, 2016 7:36 am

-ini ... doesn't work with XnViewMP?
Pierre.

obelisk
Posts: 400
Joined: Fri Jan 09, 2009 9:54 am

Re: Profiles: Option '-ini' in XnView MP?

Post by obelisk » Sun Oct 09, 2016 8:49 am

what can I use to have 2 different XnView MP then? diff thumbs catalog, settings, etc

User avatar
xnview
Author of XnView
Posts: 31175
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Profiles: Option '-ini' in XnView MP?

Post by xnview » Mon Oct 10, 2016 11:47 am

obelisk wrote:what can I use to have 2 different XnView MP then? diff thumbs catalog, settings, etc
sorry but i don't understand, you can use '-ini' to choose between different config
Pierre.

obelisk
Posts: 400
Joined: Fri Jan 09, 2009 9:54 am

Re: Profiles: Option '-ini' in XnView MP?

Post by obelisk » Thu Oct 13, 2016 9:10 am

I made '-ini' and had 1 in the user/roaming default and 1 other ini. Let's call it profile A & B
Then I set them db files to live with the ini file

After setting that up I ran B and loaded a folder.
Then load A, and saw the catalog had folders I loaded with B.
Then changed some things again, load B and found catalog from A.

So no it's not working.

I thought it was from the settings bug, so I tried change settings and close MP each time 1st.

User avatar
xnview
Author of XnView
Posts: 31175
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Profiles: Option '-ini' in XnView MP?

Post by xnview » Thu Oct 13, 2016 3:19 pm

and the settings for database folder are not the same?
Pierre.

obelisk
Posts: 400
Joined: Fri Jan 09, 2009 9:54 am

Re: Profiles: Option '-ini' in XnView MP?

Post by obelisk » Sat Oct 15, 2016 10:45 pm

otherFlag=2
updater=0
language=en
otherFolder=C:/path1/XnViewMP/
dbFlag=2
dbFolder=c:/path1/XnViewMP/
OpenWith=@Invalid()
OpenWithName=@Invalid()
startupType=1
customPath=
startInFull=2
startBrowser=true
singleView=true
oneInstance=false
dbThumbFlag=4
dbThumbFolder=
sessionSave=false
toolbar=default.bar
shortcut=default.keys
toolbarIcons=
sessionFlag=0

obelisk
Posts: 400
Joined: Fri Jan 09, 2009 9:54 am

Re: Profiles: Option '-ini' in XnView MP?

Post by obelisk » Sat Oct 15, 2016 10:57 pm

Seems a bit better now.
I think just having to quit after each change

User avatar
xnview
Author of XnView
Posts: 31175
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Profiles: Option '-ini' in XnView MP?

Post by xnview » Mon Oct 17, 2016 6:54 am

obelisk wrote:Seems a bit better now.
I think just having to quit after each change
resolved?
Pierre.

obelisk
Posts: 400
Joined: Fri Jan 09, 2009 9:54 am

Re: Profiles: Option '-ini' in XnView MP?

Post by obelisk » Tue Oct 18, 2016 9:38 am

Noope, it was working for a while, then it messed up again.

As soon as I right click a folder and open MP, then it will overwrite my \Roaming\XnViewMP ini with the last ini I used.

User avatar
xnview
Author of XnView
Posts: 31175
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Profiles: Option '-ini' in XnView MP?

Post by xnview » Tue Oct 18, 2016 12:02 pm

obelisk wrote:Noope, it was working for a while, then it messed up again.
As soon as I right click a folder and open MP, then it will overwrite my \Roaming\XnViewMP ini with the last ini I used.
it's normal, you need to change the registry value and the -ini wanted
Pierre.

obelisk
Posts: 400
Joined: Fri Jan 09, 2009 9:54 am

Re: Profiles: Option '-ini' in XnView MP?

Post by obelisk » Sun Nov 20, 2016 5:51 am

Still no good. I've changed HKEY_CLASSES_ROOT\Directory\shell\XnViewMP\command
but if you double click a jpg, it still makes a default folder/ini up.

User avatar
xnview
Author of XnView
Posts: 31175
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Profiles: Option '-ini' in XnView MP?

Post by xnview » Fri Nov 25, 2016 12:47 pm

obelisk wrote:Still no good. I've changed HKEY_CLASSES_ROOT\Directory\shell\XnViewMP\command
but if you double click a jpg, it still makes a default folder/ini up.
you means that you have the 'Startup wizard' if you use -ini?
Pierre.

obelisk
Posts: 400
Joined: Fri Jan 09, 2009 9:54 am

Re: Profiles: Option '-ini' in XnView MP?

Post by obelisk » Sun Nov 27, 2016 3:18 am

Sometimes. Sometimes not.

So again settings won't save for
tagReset=3

I had to edit it in ini.

Post Reply