Rating of a file lost when moving video file

Ask for help and post your question on how to use XnView MP.

Moderators: XnTriq, xnview

Post Reply
scalle
Posts: 6
Joined: Sat Nov 05, 2016 1:13 pm

Rating of a file lost when moving video file

Post by scalle » Sat Nov 05, 2016 1:35 pm

Hi

When i change the location of a file (other folder), its allocated rating disappears in the new folder. When i put it back in the original folder the rating appears again.
How to make sure rating (and other attributes) go along with the file ?

Regards
scalle

jadO
Posts: 394
Joined: Wed Apr 29, 2015 6:36 am

Re: Rating of a file lost when moving file

Post by jadO » Mon Nov 07, 2016 12:09 pm

Did you move it from within XnViewMP function or from your operating system or other application?

scalle
Posts: 6
Joined: Sat Nov 05, 2016 1:13 pm

Re: Rating of a file lost when moving file

Post by scalle » Wed Nov 09, 2016 10:16 pm

first within windows explorer, then tried within xnview, same result

Erixx haxx
Posts: 330
Joined: Tue Jul 28, 2015 10:37 am

Re: Rating of a file lost when moving file

Post by Erixx haxx » Thu Nov 10, 2016 4:22 am

Hello:

Please Check to see if:

-Options>> Metadata>> IPTC&XMP Tab = "Rating and label" are ticked.

jadO
Posts: 394
Joined: Wed Apr 29, 2015 6:36 am

Re: Rating of a file lost when moving file

Post by jadO » Thu Nov 10, 2016 7:45 am

scalle wrote:first within windows explorer, then tried within xnview, same result
From within Windows Explorer, there is no way XnView MP can know that a file has been moved.
So this behavior would be expected.
If you do it within XnView MP however it should move the rating along with the file.

scalle
Posts: 6
Joined: Sat Nov 05, 2016 1:13 pm

Re: Rating of a file lost when moving file

Post by scalle » Sun Nov 13, 2016 9:20 pm

Erixx haxx wrote:Hello:

Please Check to see if:

-Options>> Metadata>> IPTC&XMP Tab = "Rating and label" are ticked.
this is the case

scalle
Posts: 6
Joined: Sat Nov 05, 2016 1:13 pm

Re: Rating of a file lost when moving file

Post by scalle » Sun Nov 13, 2016 9:32 pm

jadO wrote:
scalle wrote:first within windows explorer, then tried within xnview, same result
From within Windows Explorer, there is no way XnView MP can know that a file has been moved.
So this behavior would be expected.
If you do it within XnView MP however it should move the rating along with the file.

unfortunately not, when moving it copies the file to the new folder, the copy doesnt carry the rating along with it, its blanc. i also get a "copy warning, cannot remove file" dialog box, but the file is being copied anyway.

Erixx haxx
Posts: 330
Joined: Tue Jul 28, 2015 10:37 am

Re: Rating of a file lost when moving file

Post by Erixx haxx » Mon Nov 14, 2016 3:23 am

-Options>> Metadata>> IPTC&XMP Tab = "Rating and label" are ticked.
Hello:
This is working for me if file is moved by MP.
With this setting set, MP should be embedding the rating into the files metadata. So the program moving the file should not matter.
Can you check to see if this is happening for you when you rate an image file.
For the warning dialog you are getting, This sounds like a locked file/folder, or folder permissions not set right.


I think I have found an issue here with ratings and win explorer. MP is not reading the rating set by win explorer, Nor does is after the file is moved and renamed.
I need more info on this first.

1.) Does MP auto read ratings set by Win explorer?? I always thought it did.

Can someone help answer please.

scalle
Posts: 6
Joined: Sat Nov 05, 2016 1:13 pm

Re: Rating of a file lost when moving file

Post by scalle » Mon Nov 14, 2016 3:59 pm

Erixx haxx wrote:
-Options>> Metadata>> IPTC&XMP Tab = "Rating and label" are ticked.
Hello:
This is working for me if file is moved by MP.
With this setting set, MP should be embedding the rating into the files metadata. So the program moving the file should not matter.
Can you check to see if this is happening for you when you rate an image file.
For the warning dialog you are getting, This sounds like a locked file/folder, or folder permissions not set right.


I think I have found an issue here with ratings and win explorer. MP is not reading the rating set by win explorer, Nor does is after the file is moved and renamed.
I need more info on this first.

1.) Does MP auto read ratings set by Win explorer?? I always thought it did.

Can someone help answer please.

Hello
First of all thanks for your reply. I tried it with an image file and this works flawless. However like said before still not on video files.
Does anyone have a suggestion to use of other software that i can rate all kind of video files with ?

Erixx haxx
Posts: 330
Joined: Tue Jul 28, 2015 10:37 am

Re: Rating of a file lost when moving file

Post by Erixx haxx » Mon Nov 14, 2016 9:46 pm

Hello:

Sorry, I missed the part where you said these were video files. :shock:

For video files there is a few known issues with XnviewMp and video files.

1.) Mp is not able to create xmp for mp4 videos as of yet. http://www.xnview.com/mantisbt/view.php?id=959
I think you should still be able to rate and move videos using MP and its database. I'll have to test this, I haven't done videos for a while.

2.) Mp is known to hang or lock video files so that Renaming and Moving may be tricky sometimes. http://www.xnview.com/mantisbt/view.php?id=1020
I think this has to do with Mp's preview pane and or Thumbnail creator. It likes to lock the files it's using.
Maybe you could try Xnview Classic version for this reason.

Myself, I use Win Explorer + QtTabBar to rate videos. Just pull up the bottom info panel enough to see the rating stars.
But here again, i'm not sure if Mp auto reads ratings set by Win Explorer. I'll have to look into this.

Also note: some video formats cannot take on embedded metadata, ex: .flv's. Some programs use a database, and Some use a sidecar file to get around this, though.
Maybe @JadO can answer this better, he seems to use Mp alot for videos.

scalle
Posts: 6
Joined: Sat Nov 05, 2016 1:13 pm

Re: Rating of a file lost when moving video file

Post by scalle » Fri Nov 18, 2016 10:14 pm

again : thank you for your reply.

However plain XNView isn't either doing what i want it to do, when i allocate a rating to a file, as soon as i click on another folder and return to the previous folder the rating is lost, let alone that i move the file from folder within XNView.

About QTTabBar : i installed it and studied it a bit but i dont see how i could rate files with this program. "To pull up the bottom info panel to see the rating stars" as you said is something i can do in win explorer too, the whole problem that lead me to search for alternative software is the fact that not all video files can be rated with those rating stars.

I cannot believe that this problem, that has already been mentioned years ago by other users, hasn't been "solved' at present day. So the whole concept of XNView is useless to me in this respect.

jadO
Posts: 394
Joined: Wed Apr 29, 2015 6:36 am

Re: Rating of a file lost when moving video file

Post by jadO » Thu Nov 24, 2016 12:36 pm

@scalle: I have just made some test move and copy action from within XnviewMP 0.81 and I cannot replicate your issue.
Every video file I have moved or copied via drag and drop or via right mouse click travels with its rating, color and category.

So it seems something specifically to your setup that it is not working. Maybe you wanna try from the scratch with the 0.81 portable version to make some tests. As said it is working for me.

User avatar
xnview
Author of XnView
Posts: 31598
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Rating of a file lost when moving video file

Post by xnview » Tue Nov 29, 2016 4:03 pm

scalle wrote: However plain XNView isn't either doing what i want it to do, when i allocate a rating to a file, as soon as i click on another folder and return to the previous folder the rating is lost, let alone that i move the file from folder within XNView.
XnViewMP?

I've tried to rate a movie file, and move it. I can't reproduce, the rating is correctly kept
Pierre.

Post Reply