Can something be done about the "embedded" Exiftool version?

Ask for help and post your question on how to use XnView MP.

Moderators: XnTriq, xnview

Dominius
Posts: 28
Joined: Mon Nov 28, 2016 9:58 am

Can something be done about the "embedded" Exiftool version?

Postby Dominius » Mon Jul 31, 2017 5:42 pm

The current version of Exiftool in the Ubuntu/LinuxMint repos is 10.56.
The version embedded (?!) in MP 0.86 is 9.45.
The former comsistently gives an error about the encoding of Rating and/or Label when attempting to write other metadata to a file, while XnView MP itself sometimes fails to write either to a file.
Re the error: Phil Harvey, when consulted via the Exiftool forum, explained that some familiar Microsoft XMP fields have changed how they are encoded, and that he, version-to-version, has made the appropriate changes to the Exiftool code.
I suggest taking the time to embed a newer version in the app; at least to one at or after 10.1.

D.

User avatar
xnview
Author of XnView
Posts: 28073
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Can something be done about the "embedded" Exiftool version?

Postby xnview » Tue Aug 01, 2017 11:05 am

ok, i'll update it
Pierre.

Dominius
Posts: 28
Joined: Mon Nov 28, 2016 9:58 am

Re: Can something be done about the "embedded" Exiftool version?

Postby Dominius » Thu Aug 24, 2017 1:45 pm

Thanks. Merci. Danke. Spasibo.


Return to “MP - General Support”

Who is online

Users browsing this forum: No registered users and 4 guests