Linux: "tools -> open with" : Gimp problems

Ask for help and post your question on how to use XnView MP.

Moderators: XnTriq, xnview

forest_bear59
Posts: 8
Joined: Mon Jul 31, 2017 8:25 am

Linux: "tools -> open with" : Gimp problems

Postby forest_bear59 » Tue Aug 01, 2017 10:07 am

Hello,

I have installed xnviewmp (0.86, 64 bit version) on two of my systems (Arch Linux, almost identical in respect to installed software and configuration). After customizing xnviewmp to start gimp I have found out, that every system has a problem, but different problems!

The first system starts gimp easily, but the plugin-collection "G'mic-Qt" crashes. If gimp is started before xnviewmp then invoking gimp via the 'tools' dialog naturally needs not to start gimp any more, but pictures are handed over to gimp correctly and G'mic-Qt works flawlessly.
(Can it be a problem with Qt? G'mic-Qt runs here with version 5.9.1).

Notification: installing an xnviewmp version which uses system libraries solves the G'mic problem.


On the other system gimp does not start when I try - but xnviewmp is cutomized identically to computer #1. If I start gimp before xnviewmp, no data arrives at the gimp instance. It does show no reaction.

I don't expect You to find easily the cause of this 'wierd' behaviour, but maybe You have an idea how I can search for the reason. Invoking via command line helps not that much as I thought; using tools like 'strace' should be no problem, but You eventually can get lost in the enormous output not knowing if You may find the needle in the haystack.

Thank You in advance for any idea.
Stephan

forest_bear59
Posts: 8
Joined: Mon Jul 31, 2017 8:25 am

Re: Linux: "tools -> open with" : Gimp problems

Postby forest_bear59 » Mon Aug 21, 2017 9:30 am

This post is to push the thread.

What I can add to the informations is, that I can reproduce the issue on 2 of my 4 Computers. One of them is a desktop with an I5 processor, one a laptop with an I7. On a quad-core Xeon system and an (older) I7 system gimp can be invoked without any Problem. Memory (and other hardware) tests were ok.
As a workaround I can start gimp independently an drag all pictures I want to open in it's window. This works as intended.
If it helps I can send a gdb backtracking info.

Thank you for reading and thinking about ...

Stephan

Here are additional informations:

ug 06 11:48:58 RHO kernel: gimp[15652]: segfault at 43c06 ip 0000000000043c06 sp 00007ffc6de31d38 error 14 in gimp-2.8[400000+571000]
Aug 06 11:48:58 RHO systemd[1]: Created slice system-systemd\x2dcoredump.slice.
Aug 06 11:48:58 RHO systemd[1]: Started Process Core Dump (PID 15665/UID 0).
Aug 06 11:48:59 RHO systemd-coredump[15666]: Process 15652 (gimp) of user 1000 dumped core.

Stack trace of thread 15652:
#0 0x0000000000043c06 n/a (n/a)


...and here some further ...

[New LWP 15652]
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/usr/lib/libthread_db.so.1".
Core was generated by `/usr/bin/gimp /home/waldi/Daten/Bilder/2016/2016_03/2016_03_28_KLOSTER_ARNSBUR'.
Program terminated with signal SIGSEGV, Segmentation fault.
#0 0x0000000000043c06 in ?? ()
(gdb) bt
#0 0x0000000000043c06 in ()
#1 0x00007f3862e5b000 in () at /usr/lib/libIlmImf-2_2.so.22
#2 0x00007f3870f0337a in call_init.part () at /lib64/ld-linux-x86-64.so.2
#3 0x00007f3870f03486 in _dl_init () at /lib64/ld-linux-x86-64.so.2
#4 0x00007f3870f0793e in dl_open_worker () at /lib64/ld-linux-x86-64.so.2
#5 0x00007f386c9cbe44 in _dl_catch_error () at /usr/lib/libc.so.6
#6 0x00007f3870f0715a in _dl_open () at /lib64/ld-linux-x86-64.so.2
#7 0x00007f3869870ea6 in () at /usr/lib/libdl.so.2
#8 0x00007f386c9cbe44 in _dl_catch_error () at /usr/lib/libc.so.6
#9 0x00007f38698715a7 in () at /usr/lib/libdl.so.2
#10 0x00007f3869870f42 in dlopen () at /usr/lib/libdl.so.2
#11 0x00007f386c47b702 in g_module_open () at /usr/lib/libgmodule-2.0.so.0
#12 0x00007f386def9986 in () at /usr/lib/libgegl-0.2.so.0
#13 0x00007f386def9bdb in gegl_module_new () at /usr/lib/libgegl-0.2.so.0
#14 0x00007f386defa0ee in () at /usr/lib/libgegl-0.2.so.0
#15 0x00007f386def906c in gegl_datafiles_read_directories () at /usr/lib/libgegl-0.2.so.0
#16 0x00007f386ded911c in () at /usr/lib/libgegl-0.2.so.0
#17 0x00007f386d1d0ab0 in g_option_context_parse () at /usr/lib/libglib-2.0.so.0
#18 0x00007f386d1d1a34 in g_option_context_parse_strv () at /usr/lib/libglib-2.0.so.0
#19 0x000000000047f46a in main ()


Return to “MP - General Support”

Who is online

Users browsing this forum: No registered users and 4 guests