Fontconfig Problem

Reported bugs that have been closed and/or resolved

Moderators: XnTriq, xnview, Dreamer

Post Reply
forest_bear59
Posts: 10
Joined: Mon Jul 31, 2017 8:25 am

Fontconfig Problem

Post by forest_bear59 » Sat Sep 23, 2017 7:10 pm

Two days ago there was an update of the fontconfig packages in my Linux distribution (Arch Linux). It was upgraded from version ...

2.12.5-1 to 2.12.6-1.

Since that happened, xnviewmp starts without any letters shown. Just the windows and symbols can be seen.
Starting xnviewmp from a command line yields the following error:
Fontconfig error: "/etc/fonts/fonts.conf", line 33332943: syntax error
Fontconfig error: Cannot load config file from /etc/fonts/fonts.conf
Fontconfig warning: no <cachedir> elements found. Check configuration.
Fontconfig warning: adding <cachedir>/var/cache/fontconfig</cachedir>
Fontconfig warning: adding <cachedir prefix="xdg">fontconfig</cachedir>
I assume, the line number doesn't mean anything, as this file isn't that large at all.
Can You give me a hint (besides from downgrading to the previous Fontconfig version. I want to understand what's going on.)?

Every input welcome :) .

Stephan

User avatar
xnview
Author of XnView
Posts: 32081
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Fontconfig Problem

Post by xnview » Sun Sep 24, 2017 1:02 pm

I need to ask QT team, are you using the x64bits?
Pierre.

forest_bear59
Posts: 10
Joined: Mon Jul 31, 2017 8:25 am

Re: Fontconfig Problem

Post by forest_bear59 » Sun Sep 24, 2017 3:11 pm

Yes, I am using the x64bits.

User avatar
xnview
Author of XnView
Posts: 32081
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Fontconfig Problem

Post by xnview » Tue Sep 26, 2017 7:26 am

forest_bear59 wrote:Yes, I am using the x64bits.
Seems to be an issue with fontconfig 2.12.6. Do you have app that use fontconfig with same problem? Other Qt apps?
Pierre.

forest_bear59
Posts: 10
Joined: Mon Jul 31, 2017 8:25 am

Re: Fontconfig Problem

Post by forest_bear59 » Tue Sep 26, 2017 2:39 pm

It is definitely an issue with fontconfig 2.12.6
I tested this and found, that downgrading helps. Ok so far, but I cannot leave it that way for long.

Today in the evening I'll try to find out, if (an)other application(s) behave the same way. Until now I didn't stumble upon one, but now I'll check them all systematically.

Best regards
Stphan

User avatar
xnview
Author of XnView
Posts: 32081
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Fontconfig Problem

Post by xnview » Tue Sep 26, 2017 2:50 pm

is it XnView MP 0.87?
Pierre.

forest_bear59
Posts: 10
Joined: Mon Jul 31, 2017 8:25 am

Re: Fontconfig Problem

Post by forest_bear59 » Wed Sep 27, 2017 5:54 pm

Yes, it's Version 0.87 64bits (Sep 5 2017) .

I have tested now quite a lot of software, but couldn't reproduce the error. AutopanoPro f.ex. works flawlessly.

User avatar
pangwolin
Posts: 60
Joined: Sun Sep 25, 2016 7:53 pm

Re: Fontconfig Problem

Post by pangwolin » Wed Sep 27, 2017 10:27 pm

Same problem here (Arch Linux 64 bits), downgrading libfontconfig.so to 1.9.4 seems to fix this problem, making a symbolic link to the library should be enough

Code: Select all

ln -sf /usr/lib/libfontconfig.1.9.4 /opt/xnviewmp/lib/libfontconfig.so.1
My current xnview.sh looks like this:

Code: Select all

export LD_LIBRARY_PATH="$dirname/lib:$dirname/Plugins"
export QT_PLUGIN_PATH="$dirname/lib:/usr/lib/qt/plugins"
export QT_QPA_PLATFORM_PLUGIN_PATH="$dirname/lib/platforms/"
QT_QPA_PLATFORMTHEME=qt5ct
qt.conf:

Code: Select all

[Paths]
Plugins = Plugins
lib = lib
However I have the old font glitch from several months ago again, where the font is some weird font called GoudyBookLetter1911.ttf. How do I know this? Reading strace:

Code: Select all

openat(AT_FDCWD, "/usr/share/fonts/TTF/GoudyBookletter1911.ttf", O_RDONLY) = 12
I used to be able to fix it but not anymore (for now).
Image

User avatar
xnview
Author of XnView
Posts: 32081
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Fontconfig Problem

Post by xnview » Mon Oct 02, 2017 9:00 am

O.k., thank you, I can also reproduce the problem. See issue 1315 for current status and some details. I'll post here once the problem has been fixed.
Pierre.

User avatar
karolg
Posts: 3
Joined: Sat Oct 28, 2017 3:55 pm

Re: Fontconfig Problem

Post by karolg » Sat Oct 28, 2017 5:11 pm

When we can expect version 0.88 to be released?

User avatar
xnview
Author of XnView
Posts: 32081
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Fontconfig Problem

Post by xnview » Sun Oct 29, 2017 2:19 pm

karolg wrote:When we can expect version 0.88 to be released?
this week i hope
Pierre.

User avatar
karolg
Posts: 3
Joined: Sat Oct 28, 2017 3:55 pm

Re: Fontconfig Problem

Post by karolg » Sun Oct 29, 2017 5:45 pm

It's fantastic information! Because of this strange fontconfig issue I had to use imagemagick for image conversions recently and it wasn't pleasant experience :D

User avatar
xnview
Author of XnView
Posts: 32081
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Fontconfig Problem

Post by xnview » Fri Nov 03, 2017 1:04 pm

This problem is supposed to be fixed in XnView MP 0.88. Please check and confirm the bug fix here.
Pierre.

User avatar
pangwolin
Posts: 60
Joined: Sun Sep 25, 2016 7:53 pm

Re: Fontconfig Problem

Post by pangwolin » Fri Nov 03, 2017 1:57 pm

Early testings, but it seems to be fixed alright! Fonts look good, no more fontconfig errors.
Thank you very much! <3

User avatar
karolg
Posts: 3
Joined: Sat Oct 28, 2017 3:55 pm

Re: Fontconfig Problem

Post by karolg » Fri Nov 03, 2017 3:54 pm

I can also confirm that fonts look good in version 0.88. Thank you very much.

Post Reply