Problems with open Suse Leap 42.3 and XnView MP 0.89 -> solved

Ask for help and post your question on how to use XnView MP.

Moderators: XnTriq, xnview

Posts: 1
Joined: Tue Jan 30, 2018 7:54 pm

Problems with open Suse Leap 42.3 and XnView MP 0.89 -> solved

Postby wenigeristmehr » Tue Jan 30, 2018 8:23 pm


I'm using XnView MP already for some time.
Recently I installed new Linux distro open Suse Leap 42.3.
When trying to install XnView MP 0.89 (linux tgz 64 bit) it took some time, until I solved my problems.
Perhaps it helps somebody, if I write them down here.
Downloading, gunzip and tar -xvf worked as usual.

First problem: didn't work for me.
It seemed, the following 2 lines in did not work
dirname=`readlink -e "$0"`
dirname=`dirname "$dirname"`
I was not searching why and replaced them simply by

Second problem was more difficult.
Running in a terminal, the terminal crashed.
Finially I found:
error while loading shared libraries: cannot open shared object file: No such file or directory
So i had to install the missing package "libpulse-mainloop-glib0 - GLIB 2.0 Main Loop wrapper for PulseAudio" (with yast).

Then XnView works fine !

best regards

This was my way, perhaps it is usefull for somebody.
Other or better solutions may exist.

Return to “MP - General Support”

Who is online

Users browsing this forum: No registered users and 2 guests