Page 1 of 1

How to run flatpak GIMP 2.10

Posted: Wed Jul 11, 2018 1:43 pm
by Over60
Hello,

I wonder how it is possible to open an image from within xnview like "open with GIMP 2.10".
My GIMP is a flatpak installation on Linux Mint 18.3
Xnview wants a programme to be entered in the settings but how would I enter stuff like this?:

Code: Select all

/usr/bin/flatpak run --branch=stable --arch=x86_64 --command=gimp-2.10 --file-forwarding org.gimp.GIMP @@u %U @@
.
(That's the menu entry)

Regards
Over60

Re: How to run flatpak GIMP 2.10

Posted: Mon Nov 18, 2019 3:06 am
by XnViewOnLinux
I just found your post after asking the same question. Since you haven't received a single answer in over a year, I'm guessing the XnView developer doesn't know how to do it. Either way, it would be nice if the dev would at least reply and let us know the status.

Re: How to run flatpak GIMP 2.10

Posted: Mon Nov 18, 2019 2:42 pm
by Over60
I still haven't found a solution yet.
After all I upgraded my sysetm so I can use a normal GIMP PPA.
Still there is a glitch with xnview: GIMP crashes when using clipboard functions when xnview is open at the same time.

Re: How to run flatpak GIMP 2.10

Posted: Tue Nov 19, 2019 3:28 am
by XnViewOnLinux
Over60 wrote:
Mon Nov 18, 2019 2:42 pm
I still haven't found a solution yet.
After all I upgraded my sysetm so I can use a normal GIMP PPA.
Still there is a glitch with xnview: GIMP crashes when using clipboard functions when xnview is open at the same time.
Which version of GIMP crashes? 2.8 or 2.10? I had constant headaches with GIMP 2.8 crashing when trying to copy & paste images or layers. I never even considered it might have something to do with XnViewMP, but I almost always have it open on a secondary monitor.

Re: How to run flatpak GIMP 2.10

Posted: Tue Nov 19, 2019 8:36 am
by Over60
I'e encountered this with GIMP 2.10 on a linux mint system