IPTC caption not saving if entered in view mode

Ask for help and post your question on how to use XnView MP.

Moderators: XnTriq, xnview

Post Reply
iain
Posts: 2
Joined: Mon Mar 04, 2019 8:27 pm

IPTC caption not saving if entered in view mode

Post by iain » Mon Mar 04, 2019 8:49 pm

Hello,

I've just installed XnView MP 0.92 on Linux Mint 19.1 and I'm working through my photo collection, mainly adding captions.

I've just gone through a folder of 20 photos, working through them in view mode (ie. full-size photo after double-clicking the thumbnail, but not full-screen), pressing Ctrl-I and filling in the Caption box before clicking Apply. I have the information panel on the screen configured to include {IPTC:Caption} and it appears shortly after clicking the Apply button, then I move onto the next photo. All well and good.

After finishing the 20 photos, I've gone back through them all, and the captions have all disappeared from all of them :evil: . No caption appears in the information panel, and going back into the Ctrl-I box, there's no caption in there either. I went back and re-captioned about 5 of them as before, the caption appeared in the panel before I moved on, but on going back to the photos again the captions had vanished again.

After a bit of cursing and swearing, I've found that if I add the captions from thumbnail mode, doing Ctrl-I as before on each one, they stay put - I've configured the thumbnail view to include the caption beneath each one, and they've all stayed on, and they all show on the photo when opened full-screen.

Is there a setting I've missed somewhere, or have I uncovered a bug?

EDIT - the photos in question are all JPEG's

User avatar
xnview
Author of XnView
Posts: 31869
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: IPTC caption not saving if entered in view mode

Post by xnview » Tue Mar 05, 2019 11:20 am

'Apply' don't save the metadata in the file, you need to use File>'Save' after
Pierre.

Post Reply