700,000+ images in catalog - delay in categorising images

Ask for help and post your question on how to use XnView MP.

Moderators: XnTriq, xnview

Post Reply
User avatar
Optic
Posts: 20
Joined: Sat Jun 03, 2017 3:19 am
Contact:

700,000+ images in catalog - delay in categorising images

Post by Optic » Thu Nov 07, 2019 12:53 pm

Hi there,

I am using XnView MP 0.94 beta 3.

My catalog size has 700,000+ tagged images.

I am noticing a delay of around ~5-8 seconds after I select about 10-20 images (first left-click on one, then shift+left click to select set) and apply category on them using sidebar. After I categorise them, I scroll down in my folder and left-click on the next starting set to catagorise, but then XnView MP freezes, for about 5-8 seconds. I'm guessing it is updating the catalog .db on my previous set. Then after the wait, it unfreezes.

This is making cataloging/categorising a bit frustrating, and not as fun any more.

Any tips to remove or reduce the delay?

I have tried increasing RAM in my laptop to 32 GB, unfortunately my catalog .db and thumbnails database is on the same drive, but is still an SSD. I have also tried setting "memory usage for database engine" to 10000MiB


Also, I do not use IPTC or XMP import/export options. No XMP sidecar either. Just internal XnView MP .db category name and star ratings, sometimes the circle labels too.


Any suggestions welcome.

Thank you,

User avatar
michel038
Posts: 395
Joined: Tue Sep 27, 2016 8:18 am
Location: France
Contact:

Re: 700,000+ images in catalog - delay in categorising images

Post by michel038 » Thu Nov 07, 2019 1:30 pm

What settings do you use in "Intergration paths" ?
I'm using "program(xnview)", so I can install a second XnViewMP for tests, in a place like C:\test
Take care of your xnview.db file (first, copy it for a backup)

I suggest export "file's categories" from your main xnviewmp installation ... and import this xml file in the test install, maybe starting with an empty thumbnail cache, it will run faster ?
Here you can also use "settings, catalog, optimize" and try some options...

User avatar
xnview
Author of XnView
Posts: 32078
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 700,000+ images in catalog - delay in categorising images

Post by xnview » Wed Nov 13, 2019 1:23 pm

so category is only written in catalog, right? do you have a lot of categories?
Pierre.

User avatar
michel038
Posts: 395
Joined: Tue Sep 27, 2016 8:18 am
Location: France
Contact:

Re: 700,000+ images in catalog - delay in categorising images

Post by michel038 » Fri Nov 15, 2019 12:48 pm

Sometimes, when I quickly unmark/mark categories, the task can be uncompletely done.
I have to slow down when changing state twice for the same selection.
(not tested since V0.89)

This happened when I used the categories panel to update categories in photos, where some of which had missing keywords.

Post Reply