xnview mp 0.84 is fast, 0.85 is slow

Ask for help and post your question on how to use XnView MP.

Moderators: XnTriq, xnview

fred.jp
Posts: 6
Joined: Sat Jan 18, 2020 11:19 pm

xnview mp 0.84 is fast, 0.85 is slow

Post by fred.jp » Sat Jan 18, 2020 11:58 pm

From these topics, it seems the lagginess is caused by qt.

viewtopic.php?t=37831
https://forum.xnview.com/viewtopic.php? ... 751586b052

On the same Win 10 PC,
Xnview MP 0.84 opens any image instantly (< 0.5s),
while 0.85-0.94 need 1-2s to load a simple full hd jpeg.

I compared 0.84 and 0.85,
and found that beside the difference in qt libraries,
0.85 is the first versoin to include icuin57.dll (some unicode libraries?).

Is it part of the reasons to the problem?

Meanwhile I will stick with 0.84.

Xnview is a great image viewer,
(0.84 is) faster than fastsone and a lot of other viewers that claim to be fast and lightweight.
Mangameeya (dev stopped for a long time) is probably the only thing faster.
Thank you!
:D
Last edited by fred.jp on Sun Jan 19, 2020 10:31 am, edited 1 time in total.

User avatar
Brother Gabriel-Marie
Posts: 274
Joined: Thu Aug 23, 2007 2:33 pm
Location: United States

Re: xnview mp 0.84 is fast, 0.85 is slow

Post by Brother Gabriel-Marie » Sun Jan 19, 2020 3:33 am

I'm running 0.94 and don't have any lag at all loading images. They all open instantly, even 5mb jpegs. (running Windows 7)

I've always loved how fast MP is. I even use MP instead of Adobe Bridge. MP is soooo fast.

Now, I admit, it will take a tad bit longer if you load a directory full of images for the first time - MP has to build the cache for that directory in order to build the thumbnails for the browser view, you know. But after that it's lightning fast.

fred.jp
Posts: 6
Joined: Sat Jan 18, 2020 11:19 pm

Re: xnview mp 0.84 is fast, 0.85 is slow

Post by fred.jp » Sun Jan 19, 2020 10:44 am

Brother Gabriel-Marie wrote:
Sun Jan 19, 2020 3:33 am
I'm running 0.94 and don't have any lag at all loading images. They all open instantly, even 5mb jpegs. (running Windows 7)

I've always loved how fast MP is. I even use MP instead of Adobe Bridge. MP is soooo fast.

Now, I admit, it will take a tad bit longer if you load a directory full of images for the first time - MP has to build the cache for that directory in order to build the thumbnails for the browser view, you know. But after that it's lightning fast.
I am using Win 10,
and I notice the lagginess of 0.85 when I open images from windows file explorer.

User avatar
xnview
Author of XnView
Posts: 32471
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: xnview mp 0.84 is fast, 0.85 is slow

Post by xnview » Mon Jan 20, 2020 11:25 am

fred.jp wrote:
Sun Jan 19, 2020 10:44 am
and I notice the lagginess of 0.85 when I open images from windows file explorer.
A lot?

It seems that the problem occurs on some Win 7 & 10 with lot of fonts, the issue is not with icu* dll, but QT's version (5.6.2 -> 5.8)
Pierre.

User avatar
Brother Gabriel-Marie
Posts: 274
Joined: Thu Aug 23, 2007 2:33 pm
Location: United States

Re: xnview mp 0.84 is fast, 0.85 is slow

Post by Brother Gabriel-Marie » Mon Jan 20, 2020 3:13 pm

Not for me, actually, I have 1033 fonts installed - maybe that doesn't qualify as a lot.
I have at times noticed lagginess but most of the time MP is blazing fast. Now I'm only saying this (as it isn't my thread) because I think it's probably a windows issue somehow.

fred.jp
Posts: 6
Joined: Sat Jan 18, 2020 11:19 pm

Re: xnview mp 0.84 is fast, 0.85 is slow

Post by fred.jp » Tue Jan 21, 2020 8:59 am

xnview wrote:
Mon Jan 20, 2020 11:25 am
fred.jp wrote:
Sun Jan 19, 2020 10:44 am
and I notice the lagginess of 0.85 when I open images from windows file explorer.
A lot?

It seems that the problem occurs on some Win 7 & 10 with lot of fonts, the issue is not with icu* dll, but QT's version (5.6.2 -> 5.8)
Xnview MP 0.84 opens any image instantly (< 0.5s),
while 0.85-0.94 need 1-2s to load a simple full hd jpeg.
These are the figures of opening images from windows file explorer,
not from xnview's browser mode.

Yes it is very noticeable coz xnview used to be a very very fast program. :)
(It is still faster than most alternatives, only behind mangameeya coz it is a pure viewer.)

I have only 200 fonts installed.
I am using an i5 CPU, 8GB ram and a SSD.

If the problem is caused by the newer version of QT,
then let's hope that its developers could fix it before the next next olympic games... (2024)

User avatar
xnview
Author of XnView
Posts: 32471
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: xnview mp 0.84 is fast, 0.85 is slow

Post by xnview » Tue Jan 21, 2020 7:05 pm

fred.jp wrote:
Tue Jan 21, 2020 8:59 am
Xnview MP 0.84 opens any image instantly (< 0.5s),
while 0.85-0.94 need 1-2s to load a simple full hd jpeg.
When you open the browser you have not this delay?
If you try to open a image file from a folder with only this file, same delay?
Pierre.

fred.jp
Posts: 6
Joined: Sat Jan 18, 2020 11:19 pm

Re: xnview mp 0.84 is fast, 0.85 is slow

Post by fred.jp » Thu Jan 23, 2020 8:38 pm

xnview wrote:
Tue Jan 21, 2020 7:05 pm
fred.jp wrote:
Tue Jan 21, 2020 8:59 am
Xnview MP 0.84 opens any image instantly (< 0.5s),
while 0.85-0.94 need 1-2s to load a simple full hd jpeg.
When you open the browser you have not this delay?
If you try to open a image file from a folder with only this file, same delay?
Yes, the delay of 0.85 startup is still there if I just open the program but not any images, the xnview browser mode only.

And I tried to start 0.84 and 0.85 in different patterns (e.g. start 0.84 then 0.85, then 0.85, then 0.84...),
0.85's delay is consistent, while 0.84 always show up immediately.

fred.jp
Posts: 6
Joined: Sat Jan 18, 2020 11:19 pm

Re: xnview mp 0.84 is fast, 0.85 is slow

Post by fred.jp » Thu Jan 23, 2020 8:48 pm

fred.jp wrote:
Thu Jan 23, 2020 8:38 pm
xnview wrote:
Tue Jan 21, 2020 7:05 pm
fred.jp wrote:
Tue Jan 21, 2020 8:59 am
When you open the browser you have not this delay?
If you try to open a image file from a folder with only this file, same delay?
Yes, the delay of 0.85 startup is still there if I just open the program but not any images, the xnview browser mode only.

And I tried to start 0.84 and 0.85 in different patterns (e.g. start 0.84 then 0.85, then 0.85, then 0.84...),
0.85's delay is consistent, while 0.84 always show up immediately.
Do you observe similar result in your machine? (which likely has a high spec than mine)

I just tested the new 0.95 too.
I noticed a slight speed improvemet.
But still, I would rank the startup speeds as : 0.84 >> 0.95 ~= 0.85 > 0.94

User avatar
xnview
Author of XnView
Posts: 32471
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: xnview mp 0.84 is fast, 0.85 is slow

Post by xnview » Fri Jan 24, 2020 7:34 am

fred.jp wrote:
Thu Jan 23, 2020 8:48 pm
But still, I would rank the startup speeds as : 0.84 >> 0.95 ~= 0.85 > 0.94
If you try to open a image file from a folder with only this file, same delay?

And do you have a lot of fonts?
Pierre.

fred.jp
Posts: 6
Joined: Sat Jan 18, 2020 11:19 pm

Re: xnview mp 0.84 is fast, 0.85 is slow

Post by fred.jp » Sat Jan 25, 2020 12:27 am

xnview wrote:
Fri Jan 24, 2020 7:34 am
fred.jp wrote:
Thu Jan 23, 2020 8:48 pm
But still, I would rank the startup speeds as : 0.84 >> 0.95 ~= 0.85 > 0.94
If you try to open a image file from a folder with only this file, same delay?

And do you have a lot of fonts?
Yes.
Just now I put 1 1920x1080 png file to a ramdisk drive.
Then I tried to open it with 0.84, 0.85, and 0.95.

Still 0.84 open the image almost instantly, from windows file explorer.
And 0.85, 0.95 both have a consistent delay of around 1 second.

For the fonts, I have around 200 fonts that comes with win10 and office.
I think it is on the low side?

User avatar
xnview
Author of XnView
Posts: 32471
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: xnview mp 0.84 is fast, 0.85 is slow

Post by xnview » Sun Jan 26, 2020 2:05 pm

fred.jp wrote:
Sat Jan 25, 2020 12:27 am
Still 0.84 open the image almost instantly, from windows file explorer.
And 0.85, 0.95 both have a consistent delay of around 1 second.
could you make a video with 0.84 & 0.95 when starting in browser mode & view mode?
Pierre.

User avatar
BK201
Posts: 43
Joined: Fri Apr 06, 2012 3:43 pm

Re: xnview mp 0.84 is fast, 0.85 is slow

Post by BK201 » Thu Feb 13, 2020 4:50 pm

0.95 here

The first startup is extremely slow, takes like 10 seconds

Later runs are normal

User avatar
xnview
Author of XnView
Posts: 32471
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: xnview mp 0.84 is fast, 0.85 is slow

Post by xnview » Fri Feb 14, 2020 8:02 am

BK201 wrote:
Thu Feb 13, 2020 4:50 pm
0.95 here

The first startup is extremely slow, takes like 10 seconds

Later runs are normal
same with 0.94?
Pierre.

User avatar
BK201
Posts: 43
Joined: Fri Apr 06, 2012 3:43 pm

Re: xnview mp 0.84 is fast, 0.85 is slow

Post by BK201 » Mon Feb 17, 2020 4:03 am

xnview wrote:
Fri Feb 14, 2020 8:02 am
BK201 wrote:
Thu Feb 13, 2020 4:50 pm
0.95 here

The first startup is extremely slow, takes like 10 seconds

Later runs are normal
same with 0.94?
0.94.2, yes (not quite sure, can't remember)

Post Reply