[SOLVED] Fedora 31 - XnView MP 0.95 - QT error

Ask for help and post your question on how to use XnView MP.

Moderators: XnTriq, xnview

Post Reply
ivnmad
Posts: 12
Joined: Sun Jun 17, 2012 3:32 pm

[SOLVED] Fedora 31 - XnView MP 0.95 - QT error

Post by ivnmad » Fri Jan 31, 2020 2:48 pm

Hi, I upgraded Xnview MP from 0.94.3 to 0.95.

I now get the following error when trying to use the software:
./xnview.sh
Warning: Ignoring XDG_SESSION_TYPE=wayland on Gnome. Use QT_QPA_PLATFORM=wayland to run on Wayland anyway.
qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: linuxfb, minimal, minimalegl, offscreen, vnc, wayland-egl, wayland, wayland-xcomposite-egl, wayland-xcomposite-glx, xcb.

Aborted (core dumped)
I haven't managed to find a solution yet.

Ivan
Last edited by ivnmad on Mon Feb 10, 2020 6:25 pm, edited 1 time in total.

tika
Posts: 1
Joined: Sun Dec 15, 2019 9:30 am

Re: Fedora 31 - XnView MP 0.95 - QT error

Post by tika » Sat Feb 01, 2020 2:34 am

It's the same issue as this: viewtopic.php?f=82&t=32321&start=15

Problem with that solution (which works) is that the executable is 0.76ish.

ivnmad
Posts: 12
Joined: Sun Jun 17, 2012 3:32 pm

Re: Fedora 31 - XnView MP 0.95 - QT error

Post by ivnmad » Sat Feb 01, 2020 2:18 pm

Hi, thank you for the suggestion.

I tried to download that file and tested it, but unfortunately it didn't work (see below).
./XnView-archx64
qt.qpa.plugin: Could not find the Qt platform plugin "wayland" in ""
qt.qpa.plugin: Could not find the Qt platform plugin "xcb" in ""
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Aborted (core dumped)
Ivan

ivnmad
Posts: 12
Joined: Sun Jun 17, 2012 3:32 pm

Re: Fedora 31 - XnView MP 0.95 - QT error

Post by ivnmad » Sat Feb 01, 2020 2:23 pm

BTW, I tried to reinstall 0.94.3 and 0.94.2, but I get the same error message.
Fedora did get a couple of QT updates lately (one just yesterday), so the issue might have been caused by that.
Just guessing, since everything worked fine until a few weeks ago.

Ivan

ivnmad
Posts: 12
Joined: Sun Jun 17, 2012 3:32 pm

Re: Fedora 31 - XnView MP 0.95 - QT error

Post by ivnmad » Mon Feb 03, 2020 2:54 pm

Reinstalled a few QT packages, deleted XnView completely and "re-installed" it..
Everything works fine now. It will remain a mystery why I was getting the error message.

Ivan

User avatar
xnview
Author of XnView
Posts: 32454
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Fedora 31 - XnView MP 0.95 - QT error

Post by xnview » Tue Feb 04, 2020 9:45 am

ivnmad wrote:
Sat Feb 01, 2020 2:23 pm
BTW, I tried to reinstall 0.94.3 and 0.94.2, but I get the same error message.
I've fixed the .deb & tgz, please download it again
Pierre.

ivnmad
Posts: 12
Joined: Sun Jun 17, 2012 3:32 pm

Re: Fedora 31 - XnView MP 0.95 - QT error

Post by ivnmad » Tue Feb 04, 2020 6:20 pm

Hi Pierre,

I'm sorry, but that didn't work.
I've just downloaded the 0.95 (tgz) file again, and XnView doesn't start:
./xnview.sh
qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: linuxfb, minimal, minimalegl, offscreen, vnc, wayland-egl, wayland, wayland-xcomposite-egl, wayland-xcomposite-glx, xcb.

Aborted (core dumped)
Compared to before the "Warning: Ignoring XDG_SESSION_TYPE=wayland on Gnome. Use QT_QPA_PLATFORM=wayland to run on Wayland anyway." error message has disappeared.

I installed 0.94.3 and everything woks as normal, with the following output from the command line:
./xnview.sh
==> 1.000000 113.598937 96.000000 (0)
XNVIEW restoreGeometry before : 640 480
XNVIEW restoreGeometry after : 960 503
w.init
w.start
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
QObject::connect: No such slot AbstractViewWindow::onPagePrevious()
##PB connect <1onPagePrevious()>
QObject::connect: No such slot AbstractViewWindow::onPageNext()
##PB connect <1onPageNext()>
QObject::connect: No such slot AbstractViewWindow::onPageFirst()
##PB connect <1onPageFirst()>
QObject::connect: No such slot AbstractViewWindow::onPageLast()
##PB connect <1onPageLast()>
QObject::connect: No such slot AbstractViewWindow::onNormalize2()
##PB connect <1onNormalize2()>
QObject::connect: No such slot AbstractViewWindow::onAlign()
##PB connect <1onAlign()>
MENU install : 0x2b02d60
@@@@@@@@@@
Create window finished
==> 960
ThumbLoaderThread :: stop()
########################################
############### UPDATE MENU ############
########################################
########################################
############### UPDATE MENU ############
########################################
## BaseViewWindow :: ~BaseViewWindow()
ThumbLoaderThread :: stop()
ThumbLoaderThread :: stop()
## BaseViewWindow :: ~BaseViewWindow() ok
AbstractViewWindow :: ~AbstractViewWindow()
BitmapLoadThread :: stop()
Ivan

User avatar
xnview
Author of XnView
Posts: 32454
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Fedora 31 - XnView MP 0.95 - QT error

Post by xnview » Fri Feb 07, 2020 2:15 pm

ivnmad wrote:
Tue Feb 04, 2020 6:20 pm
I'm sorry, but that didn't work.
I've just downloaded the 0.95 (tgz) file again, and XnView doesn't start:
It seems that the problem comes from libfontconfig, QT 5.12 requires libfontconfig 1.13
Pierre.

joshas
Posts: 1
Joined: Sat Feb 08, 2020 10:11 am

Re: Fedora 31 - XnView MP 0.95 - QT error

Post by joshas » Sat Feb 08, 2020 10:29 am

Got same issue here. XnViewMP is using xcb platform plugin (X11), but Fedora 31 by default is using wayland.
When starting with QT_QPA_PLATFORM=wayland set, it still results in error.
Here's a debug log when starting with QT_DEBUG_PLUGINS=1 param: https://pastebin.com/ickv0eYD

Problem is that platform plugin is trying to use libQt5WaylandClient.so.5 lib from main file system which has more recent version (v5.13.2):

Code: Select all

Cannot load library /home/virtualbox/Downloads/XnViewMP-linux-x64/XnView/lib/platforms/libqwayland-generic.so: (/lib64/libQt5WaylandClient.so.5: version `Qt_5_PRIVATE_API' not found (required by /home/virtualbox/Downloads/XnViewMP-linux-x64/XnView/lib/platforms/libqwayland-generic.so))
QLibraryPrivate::loadPlugin failed on "/home/virtualbox/Downloads/XnViewMP-linux-x64/XnView/lib/platforms/libqwayland-generic.so" : "Cannot load library /home/virtualbox/Downloads/XnViewMP-linux-x64/XnView/lib/platforms/libqwayland-generic.so: (/lib64/libQt5WaylandClient.so.5: version `Qt_5_PRIVATE_API' not found (required by /home/virtualbox/Downloads/XnViewMP-linux-x64/XnView/lib/platforms/libqwayland-generic.so))"
Adding correct versions of Qt libraries to XnViewMP lib should fix the issue, right?

Update: after dropping in correct Qt5 wayland lib versions into XnViewMP lib directory I ended up with same libfontconfig issue.

User avatar
xnview
Author of XnView
Posts: 32454
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Fedora 31 - XnView MP 0.95 - QT error

Post by xnview » Sat Feb 08, 2020 4:06 pm

joshas wrote:
Sat Feb 08, 2020 10:29 am
Update: after dropping in correct Qt5 wayland lib versions into XnViewMP lib directory I ended up with same libfontconfig issue.
The problem comes with libfontconfig/libfreetype, please check here
Pierre.

ivnmad
Posts: 12
Joined: Sun Jun 17, 2012 3:32 pm

Re: Fedora 31 - XnView MP 0.95 - QT error

Post by ivnmad » Mon Feb 10, 2020 6:22 pm

Hi, I can confirm that the following fixes the issue with 0.95:

cd /XnView/lib

rm libfreetype.so
rm libfreetype.so.6

sudo ln -s /lib64/libbz2.so.1 libbz2.so.1.0 <--- this was required in previous versions as well
sudo ln -s /usr/lib64/libfreetype.so.6 libfreetype.so.6

Thanks,

Ivan

Post Reply