XnView MP installation on Fedora 31

Ask for help and post your question on how to use XnView MP.

Moderators: XnTriq, xnview

Post Reply
rob1grie
Posts: 3
Joined: Mon Jun 22, 2020 7:41 am

XnView MP installation on Fedora 31

Post by rob1grie » Wed Jun 24, 2020 5:21 am

I've been trying for days to get XnView MP installed on Fedora 31, including suggestions from several different threads on this and other forums, but can't get past the failing dependencies. Here's the sequence I went through:

1 - Downloaded the RPM from https://download.xnview.com/XnViewMP-linux.x86_64.rpm
2 - Tried the command 'sudo dnf install XnViewMP-linux.x86_64.rpm'
3 - I get:
Error:
Problem: conflicting requests
- nothing provides libQt5Core.so.5(Qt_5_PRIVATE_API)(64bit) needed by xnview-0.96.2-2.x86_64
- nothing provides libQt5Gui.so.5(Qt_5_PRIVATE_API)(64bit) needed by xnview-0.96.2-2.x86_64
- nothing provides libQt5Multimedia.so.5(Qt_5_PRIVATE_API)(64bit) needed by xnview-0.96.2-2.x86_64
- nothing provides libQt5MultimediaGstTools.so.5(Qt_5_PRIVATE_API)(64bit) needed by xnview-0.96.2-2.x86_64
- nothing provides libQt5Network.so.5(Qt_5_PRIVATE_API)(64bit) needed by xnview-0.96.2-2.x86_64
- nothing provides libQt5PrintSupport.so.5(Qt_5_PRIVATE_API)(64bit) needed by xnview-0.96.2-2.x86_64
- nothing provides libQt5WaylandClient.so.5(Qt_5_PRIVATE_API)(64bit) needed by xnview-0.96.2-2.x86_64
- nothing provides libQt5Widgets.so.5(Qt_5_PRIVATE_API)(64bit) needed by xnview-0.96.2-2.x86_64
- nothing provides libQt5XcbQpa.so.5(Qt_5_PRIVATE_API)(64bit) needed by xnview-0.96.2-2.x86_64
(try to add '--skip-broken' to skip uninstallable packages)
4 - So I tried finding the QT_5_PRIVATE_API package, found one at https://pkgs.org/download/libQt5Gui.so. ... PI)(64bit)
5 - Downloaded http://ftp.altlinux.org/pub/distributio ... x86_64.rpm, tried to install it with dnf, got:
Error:
Problem: conflicting requests
- nothing provides libqt5-network = 5.12.8-alt4:sisyphus+252546.100.2.1 needed by libqt5-gui-5.12.8-alt4.x86_64
- nothing provides libqt5-eglfsdeviceintegration = 5.12.8-alt4:sisyphus+252546.100.2.1 needed by libqt5-gui-5.12.8-alt4.x86_64
- nothing provides libqt5-xcbqpa = 5.12.8-alt4:sisyphus+252546.100.2.1 needed by libqt5-gui-5.12.8-alt4.x86_64
- nothing provides libqt5-eglfskmssupport = 5.12.8-alt4:sisyphus+252546.100.2.1 needed by libqt5-gui-5.12.8-alt4.x86_64
- nothing provides rpmlib(PayloadIsLzma) needed by libqt5-gui-5.12.8-alt4.x86_64
(try to add '--skip-broken' to skip uninstallable packages)
I have a feeling I'm going to be chasing dependencies to kingdom come, and I can't believe there's not an easier way!
Any help at all would be appreciated.

rob1grie
Posts: 3
Joined: Mon Jun 22, 2020 7:41 am

Re: XnView MP installation on Fedora 31

Post by rob1grie » Wed Jun 24, 2020 8:44 am

Hmph ... nevermind. This was the solution: viewtopic.php?f=82&t=39973&p=160708&hil ... PI#p160832

rob1grie
Posts: 3
Joined: Mon Jun 22, 2020 7:41 am

Re: XnView MP installation on Fedora 31

Post by rob1grie » Tue Jun 30, 2020 5:50 am

Just installed Fedora 31 on another computer and still fighting the dependencies battle. The solution at viewtopic.php?f=82&t=39973&p=160708&hil ... PI#p160832 didn't work this time. I downloaded the 0.96.3 TGZ 64-bit, extracted it to a directory in my home, then followed the steps outlined in that solution, but I get an error loading libopenal.so.1.

I've also tried downloading the RPM file from the link in my original post, but get all the same errors listed in that post.

One other thing I noticed is, looking at the XnView/lib directory, I see a broken symlink lib/libqgsttools_p.so -> libqgsttools_p.so.1.0.0, not sure if that's relevant or not.

If anyone has help to offer, I'd very much appreciate it!

User avatar
xnview
Author of XnView
Posts: 33336
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: XnView MP installation on Fedora 31

Post by xnview » Tue Jun 30, 2020 2:55 pm

in a terminal, set export QT_DEBUG_PLUGINS=1, and execute XnView, what do you see?
Pierre.

Post Reply