Low Systemload while creating Thumbs

Ask for help and post your question on how to use XnView MP.

Moderators: XnTriq, xnview

Wandrer
Posts: 3
Joined: Thu Jul 22, 2021 4:18 pm

Low Systemload while creating Thumbs

Post by Wandrer »

The original pictures are 12MP or 108MP, the document format is HEIF, created with a Xiaomi Mi11 device.

HW
CPU i7-7700k
RAM 16GB (2x 8GB Corsair DDR4-2400)

SW
XNView MP 0.98.4 64Bit
Windows 10 Pro 64Bit 21H1 build 19043.1110

I tried this with an old 7200rpm HDD and with a Samsung EVO 970.

The HDD has about 90% load while creating the thumbs, which should be quite normal. CPU und RAM load are between 15% and 20%.
The EVO has around 0% load, while CPU and RAM load is still between 15% and 20%.

Does XNView MP have such a slow HEIF plugin or are there some other problems, why it can't create thumbs faster?

The other problem i have. On the HDD and the EVO it takes about 10 seconds to open/show a 108MP picture, each time with little to no CPU or RAM load.
User avatar
xnview
Author of XnView
Posts: 36318
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Low Systemload while creating Thumbs

Post by xnview »

could you send me a HEIF sample file?
Pierre.
Wandrer
Posts: 3
Joined: Thu Jul 22, 2021 4:18 pm

Re: Low Systemload while creating Thumbs

Post by Wandrer »

One example.

Created with Xiaomi Mi11 EU Version V12.5.2.0.RKBEUXM.

https://drive.google.com/file/d/1UjXRTE ... sp=sharing
User avatar
xnview
Author of XnView
Posts: 36318
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Low Systemload while creating Thumbs

Post by xnview »

ok, this file has no embedded thumbnail, and is very large so full image need to be loaded to create thumbnail
Pierre.
Wandrer
Posts: 3
Joined: Thu Jul 22, 2021 4:18 pm

Re: Low Systemload while creating Thumbs

Post by Wandrer »

The problem is the low CPU/RAM/SSD load while creating thumbs.

And XnView creates these again at every start.