Appimage doesn't work: symbol lookup error

Ask for help and post your question on how to use XnView MP.

Moderators: XnTriq, xnview

Moltke
Posts: 2
Joined: Fri Dec 31, 2021 5:58 am

Appimage doesn't work: symbol lookup error

Post by Moltke »

Hi everyone! Hope you're all having a nice life! :)

Subject: 0.99.6:: symbol lookup error

XnView: XnView_MP.glibc2.18-x86_64.AppImage
OS: Arch Linux 64bit
DE: KDE
Display: X11

I just downloaded XnView_MP.glibc2.18-x86_64.AppImage tried to launch, and I got the following error:

Code: Select all

/tmp/.mount_XnViewxF1jCA/usr/XnView/XnView: symbol lookup error: /usr/lib/libkrb5.so.3: undefined symbol: k5_buf_free, version krb5support_0_MIT
.

Effect: Program doesn't start.
To reproduce:
1. Download XnView_MP.glibc2.18-x86_64.AppImage.
2. Make executable.
3. Launch XnView_MP.glibc2.18-x86_64.AppImage
Actual behaviour (bug): I got the following error:

Code: Select all

/tmp/.mount_XnViewxF1jCA/usr/XnView/XnView: symbol lookup error: /usr/lib/libkrb5.so.3: undefined symbol: k5_buf_free, version krb5support_0_MIT
.

Expected behaviour: XnView_MP.glibc2.18-x86_64.AppImage should start without problems.

Thanks in advance for any help.
User avatar
xnview
Author of XnView
Posts: 36821
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Appimage doesn't work: symbol lookup error

Post by xnview »

do you have tried the tgz?
Pierre.
Moltke
Posts: 2
Joined: Fri Dec 31, 2021 5:58 am

Re: Appimage doesn't work: symbol lookup error

Post by Moltke »

xnview wrote: Fri Dec 31, 2021 8:43 am do you have tried the tgz?
Thanks for your reply. No, I didn't try that, however, I just installed from AUR, and it works just fine :) Tho, it doesn't have an annotation tool, but looks really nice and have some handy features. I'm looking something like fast stone for Linux.