Linux ARM64 support?

Ask for help and post your question on how to use XnView MP.

Moderators: helmut, XnTriq, xnview

anchorsam
Posts: 3
Joined: Thu Mar 24, 2022 1:14 pm

Linux ARM64 support?

Post by anchorsam »

It was implied in this forum that the Linux ARM-HF package is to be used for ARM64,
I tried to install it following https://wiki.debian.org/Multiarch/HOWTO but I'm getting unresolvable dependencies.
apt-get complains about dependencies of a bunch of libqt5 packages from armhf architecture and refuses to install them. When trying to install them explicitly it asks for even more libqt5*:armhf packages.
Am I supposed to have all of Qt5 in armhf to run xnviewmp-linux:armhf?
Or is it possible, in a reasonable fashion, to run xnviewmp-linux:armhf in an otherwise fully-arm64 userland?

Specifically this is Debian Buster,
the only Linux ARM package I found for XnviewMP is 0.92,
Tried both "apt-get install" and "dpkg -i", dpkg is aware of armhf as a foreign-architecture.
When running apt-get update && upgrade it refuses to install xnview, asks to --fix-broken install and removes the package,
specific unmet dependencies from apt-get:
libqt5multimediawidgets5:armhf libqt5webkit5:armhf
Unable to correct problems, you have held broken packages.

Thanks
User avatar
xnview
Author of XnView
Posts: 37753
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Linux ARM64 support?

Post by xnview »

you need all qt5, you have installed this one
Pierre.
anchorsam
Posts: 3
Joined: Thu Mar 24, 2022 1:14 pm

Re: Linux ARM64 support?

Post by anchorsam »

xnview wrote: Thu Mar 24, 2022 3:52 pm you need all qt5, you have installed this one
Thank you Pierre for quick reply,
In case I wasn't clear - I have Qt5 arm64 installed, just not armhf

when I try to apt-get the missing libraries in armhf I get this:

Code: Select all

Reading package lists...
Building dependency tree...
Reading state information...
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 libqt5multimediawidgets5:armhf : Depends: libc6:armhf (>= 2.4) but it is not going to be installed
                                  Depends: libqt5core5a:armhf (>= 5.11.3+dfsg~) but it is not going to be installed
                                  Depends: libqt5gui5:armhf (>= 5.11.3+dfsg~) but it is not going to be installed
                                  Depends: libqt5multimedia5:armhf (>= 5.6.0~beta) but it is not going to be installed
                                  Depends: libqt5opengl5:armhf (>= 5.11.3+dfsg~) but it is not going to be installed
                                  Depends: libqt5widgets5:armhf (>= 5.11.3+dfsg~) but it is not going to be installed
                                  Depends: libstdc++6:armhf (>= 5) but it is not going to be installed
                                  Depends: qtbase-abi-5-11-3:armhf
 libqt5webkit5:armhf : Depends: libc6:armhf (>= 2.28) but it is not going to be installed
                       Depends: libegl1:armhf
                       Depends: libgcc1:armhf (>= 1:4.0) but it is not going to be installed
                       Depends: libgles2:armhf
                       Depends: libglib2.0-0:armhf (>= 2.37.3) but it is not going to be installed
                       Depends: libgstreamer-plugins-base1.0-0:armhf (>= 1.2.0) but it is not going to be installed
                       Depends: libgstreamer1.0-0:armhf (>= 1.4.0) but it is not going to be installed
                       Depends: libhyphen0:armhf (>= 2.7.1) but it is not going to be installed
                       Depends: libicu63:armhf (>= 63.1-1~) but it is not going to be installed
                       Depends: libjpeg62-turbo:armhf (>= 1.3.1) but it is not going to be installed
                       Depends: libpng16-16:armhf (>= 1.6.2-1) but it is not going to be installed
                       Depends: libqt5core5a:armhf (>= 5.11.0~rc1) but it is not going to be installed
                       Depends: libqt5gui5:armhf (>= 5.9.0~beta) but it is not going to be installed
                       Depends: libqt5network5:armhf (>= 5.9.0~beta) but it is not going to be installed
                       Depends: libqt5positioning5:armhf (>= 5.6.0) but it is not going to be installed
                       Depends: libqt5printsupport5:armhf (>= 5.0.2) but it is not going to be installed
                       Depends: libqt5qml5:armhf (>= 5.1.0) but it is not going to be installed
                       Depends: libqt5quick5:armhf (>= 5.9.0~beta) but it is not going to be installed
                       Depends: libqt5sensors5:armhf (>= 5.6.0) but it is not going to be installed
                       Depends: libqt5webchannel5:armhf (>= 5.6.1) but it is not going to be installed
                       Depends: libqt5widgets5:armhf (>= 5.4.0) but it is not going to be installed
                       Depends: libsqlite3-0:armhf (>= 3.7.15) but it is not going to be installed
                       Depends: libstdc++6:armhf (>= 6) but it is not going to be installed
                       Depends: libwebp6:armhf (>= 0.5.1) but it is not going to be installed
                       Depends: libwoff1:armhf (>= 1.0.0) but it is not going to be installed
                       Depends: libxml2:armhf (>= 2.7.4) but it is not going to be installed
                       Depends: libxslt1.1:armhf (>= 1.1.25) but it is not going to be installed
                       Depends: qtbase-abi-5-11-3:armhf
                       Depends: qtdeclarative-abi-5-11-2:armhf
                       Depends: zlib1g:armhf (>= 1:1.2.0) but it is not going to be installed
Every armhf package I add to the install I keep getting more and more dependencies, this doesn't seem right. Is it possible XnView simply can't run on arm64 using the armhf package?

Unpacking the TGZ doesn't help because XnView won't launch, every executable I try to run says "File not found", the bash file says the same.
User avatar
xnview
Author of XnView
Posts: 37753
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Linux ARM64 support?

Post by xnview »

anchorsam wrote: Thu Mar 24, 2022 4:15 pm In case I wasn't clear - I have Qt5 arm64 installed, just not armhf

when I try to apt-get the missing libraries in armhf I get this:
sorry but i don't know
Unpacking the TGZ doesn't help because XnView won't launch, every executable I try to run says "File not found", the bash file says the same.
the package is for Raspberry so it's ARM 32bits
Pierre.
anchorsam
Posts: 3
Joined: Thu Mar 24, 2022 1:14 pm

Re: Linux ARM64 support?

Post by anchorsam »

xnview wrote: Fri Mar 25, 2022 7:13 am the package is for Raspberry so it's ARM 32bits
It also has ARM 64 now as well : /
q4a
Posts: 1
Joined: Sun Jul 26, 2015 2:24 pm

Re: Linux ARM64 support?

Post by q4a »

Hi. Latest Raspberry Pi moved to arm64: https://www.raspberrypi.com/news/raspbe ... os-64-bit/
Please, add arm64 package for XnView MP.