How to add a checkmark tag in image view?

Ask for help and post your question on how to use XnView MP.

Moderators: XnTriq, helmut, xnview

pulancho
Posts: 39
Joined: Fri Jul 22, 2022 5:49 am

How to add a checkmark tag in image view?

Post by pulancho »

I am using 1.00 on an M1 Mac. I see how to add a checkmark tag to a photo in the browser, but I cannot find how to add a checkmark tag to a photo in the image view mode. In the image view mode is when I can clearly see a photo, zoom in, etc. to determine whether I want to add a checkmark tag as a mark for deletion or something else later.
User avatar
helmut
Posts: 8705
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: How to add a checkmark tag in image view?

Post by helmut »

Hmm, in XnView MP on Windows, keyboard shortcut is Ctrl + T for tagging/untagging. One can see the tagging status in the info ("i" for showing/hiding info). I've no idea whether Ctrl + T also works on an M1 Mac.

BTW: In image view mode I can't find a menu item for tagging/untagging - is there any?
pulancho
Posts: 39
Joined: Fri Jul 22, 2022 5:49 am

Re: How to add a checkmark tag in image view?

Post by pulancho »

helmut wrote: Fri Jul 22, 2022 9:46 am Hmm, in XnView MP on Windows, keyboard shortcut is Ctrl + T for tagging/untagging. One can see the tagging status in the info ("i" for showing/hiding info). I've no idea whether Ctrl + T also works on an M1 Mac.
Thank you for that tip. I just now tried it using Cmd + T and that worked. Unfortunately, while in image view I do not see any indication that I have created a tag. When I go back to the browser though I see the tag checkmark.
helmut wrote: Fri Jul 22, 2022 9:46 am BTW: In image view mode I can't find a menu item for tagging/untagging - is there any?
I cannot find anything either.
User avatar
helmut
Posts: 8705
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: How to add a checkmark tag in image view?

Post by helmut »

pulancho wrote: Fri Jul 22, 2022 10:20 am...Thank you for that tip. I just now tried it using Cmd + T and that worked.
Good to read that Ctrl + T works on your M1 Mac, too.
pulancho wrote: Fri Jul 22, 2022 10:20 amUnfortunately, while in image view I do not see any indication that I have created a tag. When I go back to the browser though I see the tag checkmark.
With "View > Show information" (or "i" key) you should be able to show/hide information about the current image. By default, the info displays directory and filename and tag status; you can set contents displayed in the info in Tools > Settings | View | Info
pulancho wrote: Fri Jul 22, 2022 10:20 am
helmut wrote: Fri Jul 22, 2022 9:46 am BTW: In image view mode I can't find a menu item for tagging/untagging - is there any?
I cannot find anything either.
To me it looks as if menu items for tagging have been forgotten in image view mode, both in XnView MP and Classic.
pulancho
Posts: 39
Joined: Fri Jul 22, 2022 5:49 am

Re: How to add a checkmark tag in image view?

Post by pulancho »

Thank you for the additional information.

I have been using an outstanding free program called Faststone on my various Windows PCs for over 15 years:

https://www.faststone.org/FSViewerDetail.htm

Unfortunately, it is not available for Macs. :(
User avatar
xnview
Author of XnView
Posts: 43897
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: How to add a checkmark tag in image view?

Post by xnview »

helmut wrote: Fri Jul 22, 2022 9:46 am BTW: In image view mode I can't find a menu item for tagging/untagging - is there any?
I cannot find anything either.
there is no menu, but you have hotkey for it, please check Settings>Interface>Shortcuts - viewer mode
Pierre.
marwro
Posts: 14
Joined: Wed Sep 21, 2022 11:03 am

CORE FUNCTIONALITY MISSING -> How to add a checkmark tag in image view?

Post by marwro »

1) I am very sorry to see, that on my MacBook Pro, MacOs 12.3, XnView MPVersion 1.02 64bits (Aug 24 2022) Libformat version 7.114

tagging or rating pictures while in the image viewing mode (full screen mode) does not work at all!!

the information displayed, to find at settings/view/info, won't reflect tagging. only those strange brackets show up, for instance: ([]) () ()

is there any workaround to repair this behaviour?

2) another problem: while in the browser mode I tag some pictures with ctrl+t, that works fine. then I leave the folder and work on images in a another, different folder. then I come back to the first folder, that with tagged images, but - the marks are now missing!

is that a normal behaviour?

seems wrong to me, as all my tagging work is now lost??
User avatar
xnview
Author of XnView
Posts: 43897
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: CORE FUNCTIONALITY MISSING -> How to add a checkmark tag in image view?

Post by xnview »

marwro wrote: Sat Feb 18, 2023 6:04 pm 1) I am very sorry to see, that on my MacBook Pro, MacOs 12.3, XnView MPVersion 1.02 64bits (Aug 24 2022) Libformat version 7.114

tagging or rating pictures while in the image viewing mode (full screen mode) does not work at all!!

the information displayed, to find at settings/view/info, won't reflect tagging. only those strange brackets show up, for instance: ([]) () ()

is there any workaround to repair this behaviour?
How do you reproduce the problem?
2) another problem: while in the browser mode I tag some pictures with ctrl+t, that works fine. then I leave the folder and work on images in a another, different folder. then I come back to the first folder, that with tagged images, but - the marks are now missing!

is that a normal behaviour?
Settings>Browser - Tag
Pierre.
marwro
Posts: 14
Joined: Wed Sep 21, 2022 11:03 am

Re: How to add a checkmark tag in image view?

Post by marwro »

Pierre,

1) I open the image (image view, full screen) and switch the information panel on, then try to tag an image (space bar, command+T) -> nothing happens, there is still no X mark inside the brackets


2.) nope, in the browser view I tag images with command+T, then go to an another folder, then come back -> the tags are missing


3) also, how can I open an image in image view not always in full size view (not full size of the program window)? no matter what I try, it opens either in 100% view or fitting the whole frame. I would like to open all images always in 30% size - is there any way to do that?

These are the 3 major points which make the usefulness of the program near 0, for me, and I have paid for it. The 3rd point I is probably not so important, bu the first two are crucial for any serious photo work and I have never seen a prog without this functionality, even Canon free soft can that.

Please help :-)
marwro
Posts: 14
Joined: Wed Sep 21, 2022 11:03 am

Re: How to add a checkmark tag in image view?

Post by marwro »

update, now I see I can tag images only the browser view (command+t). when I switch to image view, then there is an X in brackets indeed

but how can I tag, or mark, an image in the full screen view? I need to mark the images the other way round, first to see them big, and then go to the browser view and see what I images I have marked

tagging or marking images from the browser view level is neither easy nor useful...
User avatar
xnview
Author of XnView
Posts: 43897
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: How to add a checkmark tag in image view?

Post by xnview »

you can't use command+T in 'edit view' or 'fullscreen view'?
Pierre.
marwro
Posts: 14
Joined: Wed Sep 21, 2022 11:03 am

Re: How to add a checkmark tag in image view?

Post by marwro »

Pierre,

on a M1 Mac, MacOS 12.3

1) I can tag an image only in the browser view, after that I can see the X in the info panel when viewing this image in the full screen view. I cannot tag an image while in the full screen view and later see the tagged images in the browser view. that won't work

2) I tag images in the browser view, then leave the folder, then come back to that folder - all tags are missing!

3) I can't rate any image (colour label) neither in the browser view nor in the full screen view (when watching an enlarged, single image). Basically speaking, the whole labeling functionality doesn't exist at all.


I have already spent countless hours playing with preferences, to no avail. Any ideas?
User avatar
xnview
Author of XnView
Posts: 43897
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: How to add a checkmark tag in image view?

Post by xnview »

I've just tried on a M1, and it works
marwro wrote: Tue Feb 28, 2023 8:07 pm 1) I can tag an image only in the browser view, after that I can see the X in the info panel when viewing this image in the full screen view. I cannot tag an image while in the full screen view and later see the tagged images in the browser view. that won't work
You can only tag an image in fullscreen from browser, select an image file in browser, and View>Fullscreen
2) I tag images in the browser view, then leave the folder, then come back to that folder - all tags are missing!
Do you have changed Settings>Browser-Tag => Never?
3) I can't rate any image (colour label) neither in the browser view nor in the full screen view (when watching an enlarged, single image). Basically speaking, the whole labeling functionality doesn't exist at all.
Rate or color label? What do you have in Settings>Metadata? In browser, if you change rating, it is not applied?
Pierre.
marwro
Posts: 14
Joined: Wed Sep 21, 2022 11:03 am

Re: How to add a checkmark tag in image view?

Post by marwro »

You can only tag an image in fullscreen from browser, select an image file in browser, and View>Fullscreen
But how am I supposed to do this? I open an image in the full screen view and tagging doesn't work. Neither command+t nor space tab
Do you have changed Settings>Browser-Tag => Never?
Yes I have. Does not work. Leave the folder, come back -> all tags are gone
Rate or color label? What do you have in Settings>Metadata? In browser, if you change rating, it is not applied?
Neither works. I open an image in a full screen view, hit command+1 and see a red star in the upper right corner. I close the image, go back to the browser view and the image has no mark.

Which settings/metadata do you mean exactly, there are tons of them there?? See the attachment
Screenshot 2023-03-11 at 19.02.08.jpg
You do not have the required permissions to view the files attached to this post.
User avatar
xnview
Author of XnView
Posts: 43897
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: How to add a checkmark tag in image view?

Post by xnview »

marwro wrote: Sat Mar 11, 2023 6:15 pm
You can only tag an image in fullscreen from browser, select an image file in browser, and View>Fullscreen
But how am I supposed to do this? I open an image in the full screen view and tagging doesn't work. Neither command+t nor space tab
From browser, you click on F11?
Do you have changed Settings>Browser-Tag => Never?
Yes I have. Does not work. Leave the folder, come back -> all tags are gone
Rate or color label? What do you have in Settings>Metadata? In browser, if you change rating, it is not applied?
Neither works. I open an image in a full screen view, hit command+1 and see a red star in the upper right corner. I close the image, go back to the browser view and the image has no mark.
If you make that in browser view, it works?

Where do you save the catalog Settings>Integration>Paths?
Pierre.