0.84: XnView not responsive while opening image file

Older bugs which are supposed to be fixed in 0.84. *** Please try to reproduce your bug and confirm the bug fix. ***

Moderator: Dreamer

Post Reply
User avatar
helmut
Posts: 8145
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

0.84: XnView not responsive while opening image file

Post by helmut » Mon Mar 06, 2017 5:05 pm

XnView: MP 0.84
OS: Windows 7 - 64bit

When opening a large image file from a slow medium (e.g. network drive), XnView is unresponsive and in the title bar it even shows "Not responding".

Effect: Irritating program state; XnView seems to hang although it's still active.

To reproduce:
1. Download and unzip the attached BMP file (300 MB, 10.000 x 10.000 pixel image in BMP format) and store it on your slowest medium (e.g. network or USB drive).
2. Start XnView, browse the folder with the BMP file. Double click to open the BMP file.
Actual behaviour (bug): XnView does not respond in any way until it has loaded and displayed the image. :bug:

Expected behaviour: XnView should display a wait cursor and remain responsive.
Attachments
large_image.zip
(1.41 MiB) Downloaded 29 times

User avatar
XnTriq
Moderator & Librarian
Posts: 5320
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: 0.84: XnView not responsive while opening image file

Post by XnTriq » Mon Mar 06, 2017 9:16 pm

Confirmed.

User avatar
Theobald93
Posts: 13
Joined: Tue Apr 11, 2017 8:39 pm
Location: Austria

Re: 0.84: XnView not responsive while opening image file

Post by Theobald93 » Sat Jun 24, 2017 2:36 pm

This also occures on fast drives when you open a big (~30MB) gif animation. Confirmed with 0.86 64bit Win7+10.
Sorry for my bad english in some cases...

User avatar
xnview
Author of XnView
Posts: 30270
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.84: XnView not responsive while opening image file

Post by xnview » Wed Apr 18, 2018 4:20 pm

See issue for current status and some details.
Pierre.

User avatar
xnview
Author of XnView
Posts: 30270
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.84: XnView not responsive while opening image file

Post by xnview » Thu Jun 07, 2018 9:44 am

This problem is supposed to be fixed in XnView MP 0.91. Please check and confirm the bug fix here.
Pierre.

Post Reply